Windows 7 dosn't shut down my computer

#1
Hello

I have the last version of Windows 7 RC. when i trying to shut down my computer, windows doesn't shut down automatically (i see only black screen), and i have to shut down manually.

There is also someone the same problem like mine has?
 


#2
I'm running Build 7100 RC and when I try to shutdown I don't get a black screen but instead it restarts. Randomly when I try to shutdown it will shutdown. This problem happened when i was running Build 7077 so I believe it is a hardware problem.
I'm guessing it will be for you too.
 


#3
I'm running Build 7100 RC and when I try to shutdown I don't get a black screen but instead it restarts. Randomly when I try to shutdown it will shutdown. This problem happened when i was running Build 7077 so I believe it is a hardware problem.
I'm guessing it will be for you too.
maybe. so for Microsoft - your attention please.
 


#4
Hope this is fixed in the new build 7127.
 


#5
Hello

I have the last version of Windows 7 RC. when i trying to shut down my computer, windows doesn't shut down automatically (i see only black screen), and i have to shut down manually.

There is also someone the same problem like mine has?

Do you have an Asus P5B variant motherboard? There is an issue several people have reported with this motherboard. In my case the machine tries to shut down, blanks the monitor, but the fans and lights keep running. If you have a P5B board or something similar you will get the same problem. Nothing I know that solves it right now.

Has that helped?
 


#6
Do you have an Asus P5B variant motherboard? There is an issue several people have reported with this motherboard. In my case the machine tries to shut down, blanks the monitor, but the fans and lights keep running. If you have a P5B board or something similar you will get the same problem. Nothing I know that solves it right now.

Has that helped?
yeha, i have ASUS motherboard. there is also problem to get into sleep mode.
 


#7
For Asus P5B owners, I think I've found the solution: turn off firewire (1394) in your BIOS. Works great now for me on Asus P5B-E. Try it and let me know!
 


#9
I have an ASUS P5N32-SLI and it also has the shutting down problem with Windows 7, however it shuts down just fine when I'm running XP or Vista.

I don't want to shut off my firewire connection. I may need it for something someday, this is a Windows 7 problem that needs to be fixed in Windows.

:confused:
 


#10
For Asus P5B owners, I think I've found the solution: turn off firewire (1394) in your BIOS. Works great now for me on Asus P5B-E. Try it and let me know!
Works perfectly! Can't understand it as I don't have a firewire interface in the motherboard though I do have a plugin card. It seems you've hit upon the solution.

Well done! Spread the word!
 


#11
The suggestion said "turn off in Bios" If you can't find the option in bios, then disable it in Device Manager in Windows. This may not work, but worth the shot. It should be fixed, but don't cross your fingers. Other than testing the update feature, and Windows Defender, MS doesn't seem overly agressive to fixing Bugs in the RC.
 


#12
I have an ASUS P5N32-SLI and it also has the shutting down problem with Windows 7, however it shuts down just fine when I'm running XP or Vista.

I don't want to shut off my firewire connection. I may need it for something someday, this is a Windows 7 problem that needs to be fixed in Windows.

:confused:
You don't have to shut down the firewire connection. In fact, if you disable it, you get the same problem. You just have to set the power option so that the firewire connection is allowed to power down (in the same way hard disks power down if they are not used). You can still use the firewire port.

Go into device manager, select the 1394 interface, and enable the tick box that allows it to power down. That's it. You're done!
 


#13
You don't have to shut down the firewire connection. In fact, if you disable it, you get the same problem. You just have to set the power option so that the firewire connection is allowed to power down (in the same way hard disks power down if they are not used). You can still use the firewire port.

Go into device manager, select the 1394 interface, and enable the tick box that allows it to power down. That's it. You're done!
I just tried that but it had no effect, W7 still won't shut down. Thanks anyhow.


:)
 


#14
Fix for Windows 7 won't turn off computer with Asus P5B-E motherboard

For Asus P5B owners, I think I've found the solution: turn off firewire (1394) in your BIOS. Works great now for me on Asus P5B-E. Try it and let me know!
If you still wish to use the Firewire port built into the motherboard - you do not need to turn it off in the BIOS. Rather, go to Control Panel\Device Manager and right click on IEEE 1394 Bus host controllers and select Properties. Select the Power Management tab and click in the tickbox adjacent to Allow the computer to turn off this device to save power, to turn this feature on. This worked perfectly for me - while still allowing the use of the firewire port. Thanks to Lapino for giving the original suggestion about the BIOS. This is just an alternative.
 


#15
For Asus P5B owners, I think I've found the solution: turn off firewire (1394) in your BIOS. Works great now for me on Asus P5B-E. Try it and let me know!
I registered here just to say thank you Lapino. I have an ASUS P5B-E as well and 7 wasn't powering off my computer either, just a black screen and the fans stayed running. The 1394 controller being disabled worked like a charm!

Thanks!

I think it may be time to look at replacing this setup anyway, can't run the XP Mode stuff because the P5B-E doesn't support Intel Virtualization Technology so Virtual PC won't work. I can't get a Cisco VPN client for 64-bit either because Cisco is an evil corporation who is forcing organizations to upgrade all their firewall hardware... haha. I was going to follow the advice here: Cisco IOS hints and tricks: Cisco VPN client in 64-bit Windows 7 but that requires XP Mode.
 


#16
If you still wish to use the Firewire port built into the motherboard - you do not need to turn it off in the BIOS. Rather, go to Control Panel\Device Manager and right click on IEEE 1394 Bus host controllers and select Properties. Select the Power Management tab and click in the tickbox adjacent to Allow the computer to turn off this device to save power, to turn this feature on. This worked perfectly for me - while still allowing the use of the firewire port. Thanks to Lapino for giving the original suggestion about the BIOS. This is just an alternative.
And even better - thank you as well, this worked also. Don't really use the firewire port, but at least now I can if needed.
 


#17
P5b-e

My system uses the Asus P5B-E motherboard and I was having the same shutdown problems with Win 7 as everyone else.

I have a hard drive rack (which uses removable drives) in my system which lets me boot any operating system that I want to use. One drive uses Win XP Pro, another uses Vista Home Premium and I just purchased a third drive to use for Win 7.

I noticed that Win 7 didn't power off my system upon shutdown, so I used the recommendation posted here regarding the 1394 (Allow the computer to turn off this device to save power). This worked great and win 7 is now able to power down the system. However, there was a deadly unintended consequence - I am now unable to boot using any of my other operating system drives (Win XP or Vista). The operating system boot hangs at what I believe is some device driver discovery stage.

This is unfortunate since I actually use XP and Vista.... whereas I was only using Win7 as a curiosity.

I have tried disabling the onboard 1394 controller in the BIOS and also I have reset the 1394 power management in Win7. All combinations of doing these things have failed. It appears that Win7 does something pretty radical to the actual hardware when this situation arises. To be honest, I am horrified that Microsoft could do something like this.

Any suggestions would be appreciated.

John Cookson
 


#18
Okay I have the shutting down problem fixed. It was being caused by my M-Audio 1010LT sound card driver. The manufacturer released a new beta driver for Windows 7 and that solved the problem. My computer now shuts down as it should.


:)
 


rapapar

Senior Member
#19
Very interesting!
I have the same problem on my w7 x64 with a M-audio delta audiophile 2496

can you give me a link to get the driver?
it's not on the officiel web site M-AUDIO - Recherche de Pilotes et de Logiciels :(

thks in advance :)
 


#20
I do not have a link handy, but you should be able to find the driver at the M-Audio website in their user forums. It's posted there somewhere. Look for driver 6.0.2.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top