Windows 7 not setting default program correctly

Discussion in 'Windows 7 Help and Support' started by Zeren, Dec 21, 2014.

  1. Zeren

    Zeren New Member

    Joined:
    Dec 21, 2014
    Messages:
    2
    Likes Received:
    0
    I have been trying to set Firefox as my default player for locally saved .sfw files after I had to reinstall windows. No matter how I go about it, as soon as I browse for Firefox.exe and select it to add it in as a default program, it does not appear like it should. Going through the set association menu does not work either since as soon as I'm allowed to browse for the program I want and select firefox, it won't add it to the list. I have made sure firefox, shockwave, and flash are all up to date, have tried clearing the cache, and anything else I can find online, but to no avail.

    This worked before I reinstalled windows, so I'm not sure why it's not working now.

    1.PNG 2.PNG

    Please help!
     
  2. Pauli

    Pauli Extraordinary Member
    Premium Supporter

    Joined:
    Mar 1, 2012
    Messages:
    2,499
    Likes Received:
    211
    .swf is an Adobe file format. It will probably go automatically to Adobe, like it shows in your screenshot - companies preserve their own. Due to all sorts of copyright issues, directing Windows may not be that easy. It's actually more a Firefox or Adobe problem, than Windows problem. Check that you have all Adobe up-to-date,

    Don't know if this gives anything, but https://support.mozilla.org/en-US/questions/975971 It's Mozilla, yes, but contains Windows info.

    Shockwave Plug-ins are crucial.
     
  3. Zeren

    Zeren New Member

    Joined:
    Dec 21, 2014
    Messages:
    2
    Likes Received:
    0
    While I thank you for your input, it's not solving my issue, and as I said, all plugins and programs are up to date. I've already tried the steps in that forum. After I made that post, I checked other formats and not even .gifs are working. There is an issue with windows allowing me to select firefox at all, not just for one format. When I click open after selecting firefox as I did in the second image, nothing happen. No errors, no conformations, no option to use firefox at all.
     

Share This Page

Loading...