Windows 7 won't boot, hits BSOD and restarts.

Discussion in 'Windows 7 Help and Support' started by Iropan, May 1, 2011.

  1. Iropan

    Iropan New Member

    Joined:
    May 1, 2011
    Messages:
    6
    Likes Received:
    0
    I've spent the last two days reading threads on anything remotely connected to my problem but i can't fix it, i'm really hoping someone here can help me...I run Windows 7 64bit.

    The other day the computer shut down on it's own. I turned it back on, Windows wouldn't load, it entered a loop of about 2 or 3 reboots and finally it loaded Windows 7. I thought it was just a big hiccup, and after a while i got a prompt to install some updates for Windows, some of which required a restart. After that restart the PC never booted Windows again. It took me to Startup Repair, where it couldn't fix the problem. In the log i could see "boot critical file D:\ ci.dll is corrupt".
    Since then i've installed Windows on another HD i had, and i have accessed the problematic one connecting it as an external HD. This has allowed to scan it with several antivirus and antimalware programs; TDSSKiller found "Rootkit.Win32.TDSS.TDL4" and eliminated it. Malwarebytes found the following: "e:\Users\{username}\AppData\Local\Temp\rasdialb.exe (Trojan.Agent) -> Quarantined and deleted successfully."
    This however hasn't fixed the problem. Startup repair will tell me the computer cannot be fixed automatically, and if i use a recovery disk, Startup repair will tell me it can't find a problem. System restore will tell me there are no restore points (and it lists my HD as being in unit D:, when i'm positive my drive's unit is C: ).
    I've gone to the command prompt and tried the following:
    -Chkdsk --> Found no problems
    -sfc /scannow --> It doesn't run, says "system repair pending, please restart" (i've restarted a million times and it still won't run).
    -bootrec.exe /fixmbr --> Completed successfully.
    -bootrec.exe /fixboot --> Completed succesfully.
    The problem has remained unchanged, when i try to load Windows i get the Windows logo while it's loading, then a BSOD for a few tenths of a second (too fast to read, but something about drivers) and it restarts.
    I don't know what else to do, i can only do a repair install from within Windows, so i guess that's not an option.
    I've also read that this virus infects the boot sector, so formatting wouldn't help.
    And i'm out of ideas, i've run Startup Repair more than 20 times now, the reference to ci.dll is gone, but the problem stays the same. I'm really hoping someone can help me!
     
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    If it is a driver, have you tried Safe Mode and update or remove or disable any devices that might be affected.

    Some times in the bios you may be able to disable onboard systems, like sound to see if that helps.

    In the repair senario, it looks at partitions and not Windows drive letters. D: is probably just the second partition if you have the system partition (100 mb) on your system.

    Many viruses and other types of malware have a way to replace themselves if only parts are removed.

    Do you have a backup image? What log are you looking at to see the corrupted ci.dll file.

    From where are you running the System File Checker?

    Edit: You can turn off the automatic restarts from the repair senario.

    You can also try "last known good", if you haven't already.
     
    #2 Saltgrass, May 1, 2011
    Last edited: May 1, 2011
  3. Iropan

    Iropan New Member

    Joined:
    May 1, 2011
    Messages:
    6
    Likes Received:
    0
    Safe Mode is inaccessible, when i try to boot with no recovery disk i get 2 options, go to repair mode, or load windows normally.

    I have no backup image.

    I saw about the ci.dl file in Startup Repair the first time it ran it, there's an option to get more information on the problem, and there i saw it.

    I'm running System File Checker from the command prompt. This is what i see --> X:\Windows\System32>sfc /scannow

    I don't exactly recall if i've tried "Last Known Good Configuration", but if it's in WinRE then i have and it failed.
     
  4. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    I would not think that a trojan would cause you system to go down. But strange things do happen. Perhaps when the error occurred, some of your files were damaged.

    Right now all I might suggest is to try to replace files you believe to be bad. You know the ci.dll is bad and because you have another install of Win 7 with all the replacement files you might need, I will refer you to this Microsoft site to see if you can get it replaced. It may not be the only damaged file, but if you can replace it, maybe some progress can be made.
     
    #4 Saltgrass, May 1, 2011
    Last edited: May 1, 2011
  5. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    More research, more possibilities! :)

    I entered the repair environment and tried running the System File Checker to see what happened. As you can see from the attachments, I got the same response as you when just run from the command line. I typed in SFC /? to see if there were any switches that might help and found some to try.

    As you can also see from the attachments, running SFC using the additional switches allowed it to complete. Hopefully the same will work for you. But you need to know for sure where you Win 7 install is. If you have more that one drive, be careful, and make sure you have the right one. In my case, d: is the correct drive as I checked to make sure with the dir command showing the correct folders.

    I then typed in the command (copy and paste from the earlier printout) and did a /scannow with the additional boot directory and windows directory information. Let us know what happens with this change. You might also use the VerifyOnly switch since it does not attempt any repairs and may complete if the scannow does not. Be advised, it will take several minutes to complete and the only way I knew it was working was by watching the hard drive access light.

    Edit: I just checked my CBS.log, and perhaps it did not work as well as I first thought, but try anyway.
    Edit to the Edit: Although I was not able to get anything to work using the OffBootDir commands with /scannow, I was able to repair a file on another non-active Windows install, using the suggested command for repairing a specific file.

    sfc /SCANFILE=d:\windows\system32\xxxxxxx.dll /OFFBOOTDIR=d:\ /OFFWINDIR=d:\windows (d: being non-active install)
     

    Attached Files:

    #5 Saltgrass, May 1, 2011
    Last edited: May 2, 2011
  6. Iropan

    Iropan New Member

    Joined:
    May 1, 2011
    Messages:
    6
    Likes Received:
    0
    I tried replacing ci.dll with the affected HD plugged in as an external, but the destination folder won't grant me access...

    I tried SFC with the new commands you proposed, but again i got the message about a repair pending and i needed to restart...

    Btw the hypertext you posted on the Microsoft Sites doesn't open for me, could you repost it?

    Thx a bunch for all your help so far!
     
  7. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Sorry, I have replaced the URL. The site describes how to replace a file.
     

Share This Page

Loading...