Windows 7 wont rebuild my index

Discussion in 'Windows 7 Help and Support' started by moondy, Sep 18, 2010.

  1. moondy

    moondy New Member

    Sep 18, 2010
    Likes Received:
    Hi All,

    Let me inform you first about what ive already tried:

    1. Changed indexing folder
    2. Rebuilding
    3. Googleing
    4. Searching this forum
    5. Restarted Windows Search service
    6. Removed shareing for Users folder
    6. Ensured all folders i want indexed have System security on it with Read/Write access.
    7. System restore

    Nothing seems to be working.

    Its been a problem for about 3-4 weeks now and of course i restart my laptop every few days.

    When i search, it only searches Program Files and Control Panel.

    Below is a screenshot of what i mean.

    It has worked in the past. For example my Music folder has about 14000 files. I clearly type in ‘Don’t Stop’ and it doesn’t find it.

    Anyone have any ideas?
  2. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Aug 28, 2007
    Likes Received:
    Googling found this....

    OK this worked for me. Credit for the Regedit part goes to Samhrutha G S at Microsoft Support. [​IMG]

    Important: The instructions below contain steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information view the article in the Microsoft How to back up and restore the registry in Windows

    1. Click Windows + R (Opens run window)
    2. Type regedit and press Enter.

    3. In registry editor, windows locate: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Search[/COLOR]
    In the right pane, right click on SetupCompletedSuccessfully and click on Modify.

    NOTE: If SetupCompletedSuccessfully is not there, then in the right pane, right click on a empty area and click on ‘New’ select ‘DWORD (32 bit)’ Value and type SetupCompletedSuccessfully and press Enter.

    4. Type 0 and click on OK.
    NOTE: This is the number zero.

    5. Close
    6. Restart the computer.
    Resetting the registry to 0 will also remove the drivesfrom the list of “Included Locations” you may have set previously in Indexing Options.
    So you will want to add those back in through the “Modify” button. > Show All Locations > Check the drives you want indexed.
    Next in Indexing Options you can click through > Modify> rebuild new index.

    I did one more step just to make sure before rebuilding the index. I went into Control Panel Indexing Options and created a new location and new folder for the index.
    I then deleted the old index through explorer.

    Then I hit the rebuild index button.

    I had a suspicion that simply rebuilding the index was not creating a whole new data set; for one thing, the index was being rebuilt too fast, like in under a half hour on a machine with 700 Gigs of files. Second, it wasn’t changing anything for the better.
    So out went the old index.

    My theory was that Win 7 may be “borrowing” the possibly corrupt data from the first file to build the new index as quickly as possible. But I have not tried this procedure without making a new index folder to see whether deleting the old one is necessary after resetting the SetupCompletedSuccessfully value.

    About 3 hours later, the index was rebuilt and indexed search for files and folder contents is working.

    It’s good to be aware that there is another place where Windows has search settings. In Control Panel > Folder Options > Search Tab. Make sure the box is clear for “Don’t Use The Index While Searching The File System”. Also choose other options you want there. I selected “Include Subfolders” and “Find Partial Matches”.
    Ref: Search Index Broken, Rebuilding won't help - Windows 7 Forums
    #2 kemical, Sep 18, 2010
    Last edited: Sep 18, 2010
  3. moondy

    moondy New Member

    Sep 18, 2010
    Likes Received:
    Hi kemical,

    Thanks for replying.

    I followed what you posted to the letter...and its still stuck on "1 items indexed. Indexing complete".

    Searching in a music folder with 1 mp3 file, still comes up as 'No items matched your search'.

    I've let it sit idle for 45 minutes and it hasnt budged.

    Any other ideas?
  4. Mitchell_A

    Mitchell_A Excellent Member

    Feb 7, 2009
    Likes Received:
    Have you tried the "Troubleshoot search and indexing"?
    Try clicking that link from within the index window, an automated troubleshooter will start.

    Alternatively, you should also run CMD as admin and type "sfc /scannow" to ensure it's not an integrity violation and it never hurts to delete the index manually.
    Here's a quick tutorial on how to do that: Index Locations - Add or Remove - Windows 7 Forums
  5. moondy

    moondy New Member

    Sep 18, 2010
    Likes Received:

    I tried what you said but i still havnt made any progress.

    Guess a clean install is what is required.

  6. Chin Yit

    Chin Yit New Member

    Nov 17, 2010
    Likes Received:
    I have EXACTLY the same problem with you.
    Solved the ENTIRE problem by Uninstalling my current Bitdefender Antirivus 2011;
    The indexing was restarted successfully. Searching began working well.
    Currently using McAfee Antivirus 2010 with no problems.

    SUGGESTION: Try Uninstalling All your Antivirus and (external) Firewall programmes to try first. You would be surprised and pleased when the Indexing started to work when you click on "REBUILD INDEX" after uninstalling those potentially problematic Antivirus products.

    Hope it works. Let us know if it helps at all....
    Best wishes.

Share This Page