Windows networking fixed!!(w7 to xp)

#41
rugger:
The "network path not found" or similar error is generally caused by third party applications like firewalls, Zone Alarm, Comodo, etc. and or third party Antivirus / Internet Security Suites running some type of firewall applet. I have even seen it caused by remanants left over from an apparent but not complete uninstall. Here is a check list for you to run through, I know you've probably done most of it, but it never hurts to double check. Even the Windows firewall can sometimes cause this, if you've done anything to change it, including the dreaded clicking the "Restore Defaults" link. If you need any help with any of these post back, and by the way LMHosts file is for netbios information, not HOSTS so to really force the netbios information you need to create and LMHosts file (no extension) that contains the IP address netbios name and the #PRE comment, you can use the LMHosts.sam (sample file) as an example)
Click start and type services.msc in the search box
Or hold down the windows logo key and hit the R key and type services.msc in the run dialog box
Make sure the following services are running and set to automatic on all machines.
1. Computer Browser
2. DHCP Client unless you are manually assigning static ip addresses to your machine
3. DNS Client unless you have manually assigned static DNS server addresses on you machine
4. Server
5. TCP/IP Netbios helper
6. Workstation
7. Look for Bonjour service and temporarily set it to manual or disable and stop. Also check services near the top for a

peculiar string containing numbers and or special characters, something like this
"##Id_String2.6844F930_1628_4223_B5CC_5BB94B87 9762 ##" disable and stop.
8. Make sure all machines have the same workgroup name "Workgroup" is fine.
9. All network nodes must be unique, make sure there are no machine name conflicts, and as strange as it may sound

make sure there are no missing or conflicting mac addresses.
10. Make sure Network Discovery is turned on, on the Win 7 machines
11. Under the network and sharing center, change “Advanced Sharing Settings” intelligently to suit your needs. Turn on

network discovery, turn on file and printer sharing, turn on pulic folder sharing, turn off password protected sharing,
and at the bottom Use user accounts and passwords to connect to other computers.
12. If your problem is with down level clients like XP and Vista and your Windows 7 machine is in a homegroup, leave it

and disable IPv6 in the properties of your network adapter.
13. Make sure NetBios over TCP/IP is enabled in the properties of IPv4 on you network adapter.
14. Make sure file and printer sharing is enable on both and that local firewalls are supporting it.
15. Temporarily uninstall any third party firewalls or Internet Security Suites that may include some type of Firewall

applet (you can always reinstall them later) temporarily disconnect your home network from the internet if this steps
makes you say Whoa!!
16. Clear DNS cache at a command prompt type ipconfig /flushdns
17. Clear netbios name table cache at a command prompt type nbtstat -R
18. Use the ping command, ping each machine from the other by IP address as well as netbios name if either of these fail

you may have skipped over step #15 or the embedded windows firewall may have a problem so turn it off too,
temporarily for testing.
19. Then examine the netbios name table cache at a command prompt type nbtstat -c make sure that each netbios name

is identified correctly by it's proper IP address
20. Disable any network adapters that are not in use
21. Make sure that you have the most current up to date drivers for your network adapter(s) from the hardware device

manufacturer's website
22. Make sure you have the latest firmware updates for your router from the router manufacturer's website
23. In the case of an addon card insure you adapter is seated properly and is identified properly in device manager
24. In the case of a hardwired cable connection inspect the diagnostic lights at both ends of the cable usually amber or

green, steady when connected and flashing when activity is detected, yours may very, don't hesitate to swap out a
suspect cable or swap to a known good port on the router / switch.
Sorry to quote this large list, but for systematic help, for me this was exceptional. Thank You, Trouble.
 


Trouble

Noob Whisperer
#42
It is rather long isn't it. I'm very glad that you found it helpful and hope others do as well. A lot of it's basic boiler plate networking help but sometimes just having a list to go by is helpful. Thanks very much for the compliment.
 


#43
Здавейте, при вече Ñ￾ъздадена мрежа в полето Network виждам компютрите, но при опит да направÑ￾ връзка ми дава Ñ￾ъобщение: "Error code: 0x80070035 The network path was not found"
 


ruggb

Honorable Member
#44
Not withstanding the previous list - here are more things to look at. The previous list is basic stuff, this list contains things unique to W7.

There are a lot of things to short circuit network functionality.
This is a list of things assembled from my experience and other sources. One thing to really drive you crazy is that it all worked before you RE-installed W7. Just another M$ joke. See #2.

Homegroup problems -
1. can't create homegroup
2. can't join homegroup
3. can't delete homegroup

XP networking issues
1. can't see XP
2. XP can't see W7
3. W7 can't see XP
4. can't share XP

The problems are generated when moving from XP (and maybe Vista) to W7.
AND also upon RE-installations of W7.
They are centered around what W7 sees as WORKGROUPS, file OWNERSHIP, corrupt control files, SHARING issues.

Most people know by now that the Workgroup names MUST be identical. You could get away with them not identical in XP. I never used Vista so I can't comment. But W7 is VERY picky about security.

"Homegroups was easy the first time around - Then things turned bad". I see that a lot and experienced it myself.
HERE is why----------
W7 is a lot more modular. Useta was, you could share a drive and that was it. BUT NO, W7 can't do that.

So here are some answers:
1.........
Now sometimes I hear that people (including me) can't create a homegroup. One cause is that control files get created or corrupted (not sure) and need to be deleted.

"C:\Windows\ServiceProfiles\LocalService\AppData\Roaming\PeerNetworking\idstore.sst"

I deleted both .sst files and was now able to create a homegroup.


2.............
OK so you have a homegroup created and it says, "just go to the other system and join it by entering the password".

AAHH, easy for you to say....... It just keeps telling me there are no homegroups on the network.

Well, strictly speaking, that isn't so - just another M$ joke. The truth is there isn't anything in any other Homegroup on the network for you to join to. In order for a system to SEE another Homegroup on the network, the Homegroup MUST have at least one of its folders shared. If no folders are shared (only a drive shared) then the Homegroup does not exist yet, even though it is defined.

OK, how about that sharing menu.........
You need to be specific about who gets to share this. The quick/Easy is to add EVERYONE with all permissions.

Can't seem to set permissions??? OH!!! you are wondering who that "undefined" person is on the list and why they are listed as an owner???????????

Turns out, that will mess you up also - the system can't get permissions from an undefined owner. It is the result of a W7 reinstallation. The 'undefined" owner is really you in a different life. - the previous incarnation of your OS.

SOOOO - first you must go thru and take back ownership of all those files. (Look for a "take ownership" registry tweak).
Then you must go thru those folders and remove the rest of the undefined people.
Then you can properly assign permissions - actually, you can do it at the same time you remove the undefined users.

OK, finally, now you see the Homegroup and share files as you want. (read or read/write only)
WHAT!! You still can't connect - OH, OH, -- HO HO. Did you go an shut off that IPv6 protocol on your adapter so that it would work better for another issue?????????? Well, you CAN'T DO THAT. Homegroup MUST have IPv6 active to be able to function.

NOW REJOICE - maybe..... I can't think of any other issues to connecting - butt I'll bet there is more lurking....

3............................
OH, I made a mistake - I want to delete that Homegroup. I haven't run into a problem deleting a Homegroup and I haven't read the posts of people who have, but it MAY just be that they don't realize that to delete it all you have to do is to "Leave the Homegroup" on the system that created it.

XP <> W7........................
All of the XP issues have something to do with the above issues and the "long" list - Mostly it is the Workgroup issue - and DON'T ask about getting the XP system to join the Homegroup. The Homegroup operation depends on IPv6 which XP does not have and never will.

If you share a drive, XP will show it but will not be able to connect. (The same as Homegroups). It will show shared folders and will connect to them.

NOW you have MOST of the answers................Except for the following post................
 


Last edited:

ruggb

Honorable Member
#45
I am currently chasing one more that is requiring a log-in to my XP system from my W7 machines.

I have 2 XP and 2 W7 machines. Homegroup works as does XP workgroup networking.

EXCEPT that where XP1 can be seen and accessed by ALL other systems, AND can see and access all other systems itself, the other XP2 system requires a logon from the W7 systems.
XP2 can see and access all other systems.

Repeat: (all of this is via Windows Explorer)
XP1 and XP2 communicate just fine both ways.
XP1, W7-1, W7-2 communicate just fine both ways.
XP2 can communicate with W7-1, W7-2
HOWEVER, W7-1, W7-2 are both showing a logon screen when I try to access XP2.

So where is the problem????????????????
 


#46
DOUBLE-CHECK YOUR WORKGROUP NAMES - In Windows 7 it will show the wrong name if you have changed it but not yet re-booted (stupid).

But I found another solution....

I was finally able to do this after I tried EVERYTHING. I was able to connect when I uninstalled the McAfee virus protection on the XP computer. And I mean I had disabled homegroups on Win-7, done all windows updates, changed all the computer names and workgroups (don't use HOME as a computer name).

Finally - I believe there was ANOTHER firewall in McAfee, or else a hang in the program, that was blocking me. I am not sure, but I do know uninstalling McAfee was the answer.

I am posting this because few people ever post solutions when they find them.

PLEASE POST YOUR SOLUTIONS TO THIS SO COMMON PROBLEM!!!!

Furthermore, after I did this I was able to restore the Windows firewall and still connect to this XP computer.
 


#47

That's the best I could do with a software translation. .
I grabbed the sense when reading but answering in English would not help.

This forum's default character encoding is set wrong for international fonts - set it to UTF-8 and it looks much better.
 


#48
Using windows 7 Ultimate (Build 7600, version 6.1). I shared the Win7 D: drive. XP machines saw it but could not access the D:\. I left the room for several hours (I know it can take network settings a long time to propagate). I came back and I did the above steps except:
1. I belong to a homegroup
E. for "E" (I allowed win7 to manage Homegroup settings). The 2 XP Pro and 1 XP home that I tested worked (they could open files on the Win7 machine).

P.S. Also the firewall is on (the default I did not change it), I am running Microsoft Security Essentials, Workgroup is "Workgroup", same user on all machines, no password required.
 


#49
........
You need to be specific about who gets to share this. The quick/Easy is to add EVERYONE with all permissions.

.......
Just to add to the MS security confusion - adding Everyone permissions to an user's folder can be done BUT you will not be successful to write to that folder (as Everyone)..writing/changing/deleting will be constantly rejected!

Workaround?

move that folder out of the user's area and it will be fine - no more problems after renaming that folder into something else.

I found that nastiness when trying to write from my VM to a 7 folder which was impossible even after Everyone/write permission had been granted.
 


Last edited:
#50
On my machine it was not a firewall issue. On the Windows 7 computer I had to go to the Networking Properties of the connection from Control Panel\All Control Panel Items\Network and Sharing Center and turn off AGN Filter Interface (64-bit).
 


#51
Hello all,

Just registered with the forum,it seems very complete and alive.
I'd like to bring here my experience with Windows 7 and networking.

OK, I have a home network, composed of:
1. Windows XP Professional SP3, used as a file server for my media (video, music, personal video and photo backup, etc.)
2. Two laptops (mine and my wife's one), both with Windows XP Professional SP3
3. Current HTPC, running (guess what?) XP Professional SP3 and MediaPortal

The hearth of the network is a Linux-based (Samba) wireless router/AP/switch, a Pirelli one, with a modified firmware, sharing a printer on a USB port.

Everything is running fine, I can access all the shared resources from all of the PC connected on the network.
One of the two laptops uses a wireless connection, while the other, when at home, uses a wired connection, through its docking station.

I'm now in the process of building a new HTPC, a E2180 Pentium class machine, a ASUS G31M-S 775 motherboard with a HD5450 videocard and everything else needed to run as I need.

To use the latest video acceleration (DXVA2, needed for HD videos and TV) I decided to install Windows 7 on the new HTPC.
I Installed the OS for the first time, and everything gone perfectly; I can access the server and the others PCs, I can stream my videos/music and play them from my new HTPC.
Unfortunately, the videocard I was using in first place suddendly died (GeForce G210), so I decided to buy a new one (the HD5450, slightly better, for my needs).
Just to avoid problems (LOL) I re-installed Windows 7 after the video card swap, in manner to have a new, fresh driver, codec (SAF 5.00) and Mediaportal installation.

Well, after the second installation of Windows 7 I cannot access anymore to my server and to the other PCs shares.
I can access the Router, which shares my network printer (Samsung ML1640) and I can print from it.
From the laptops I can access Windows 7 shares (I shared a complete disc and a single directory, just to try it).
There's no way I can access the server (the most important function, for my HTPC) from Windows 7, I constantly receive a "permission denied" message.

Please note I cannot access the whole PCs, I can see them in the network PC list (they are visible), but if I double-click on one of them I'm stuck with the user/password dialog.

The workgroup is the same, I have disabled HomeGroups in Windows 7, I have defined exactly the same user/password I had in the previous installation.

Any idea?

I've read the thread and perhaps it could be a sort of "network memory" (?) related to the fact I installed Windows 7 twice, with the same licence and same user; the first time it worked out of the box, the second time there's no way I can make it work.

Any idea? Do I have to tweak the XP server registry, or do I have to change anything on its side?
From the others XP machines (laptops) I can continue to access the server with the same user/password I'm used to, but not with Windows 7.

Do I have to change user account for Windows 7?

I'm giving up, and I'm quite disappointed, cause I really want to use Windows 7 for its claimed improvements in playing video...
It is really ridicolous a so advanced OS behaviours so bad with networking.

Last though: I'm trying to use Windows 7 Home premium, would Professional or ultimate work better than that?
At work we have almost 100 PC connested to the same network, usign XP Professional SP3 and Windows 7 professional/Ultimate, without any issue.

Please help me.

Ciao,
Giovannni
 


Last edited:

ruggb

Honorable Member
#52
Giovanni!

Welcome to the world of W7 vs XP

Actually, everything affects this arrangement - and it all comes back to security.

On my network - everything breaks when I connect my new HP LT if I have password on it. Right now I have no passworded logons on any unit.

without a password the net mostly works - for some reason it takes a while for the computers to find one another.
I now have one XP LT and 3 W7 units. They all talk to whatever I have shared.

BEFORE u do this: reset any shares u may have created for drives and folders to unshared. If u have reinstalled W7 OS on any unit find and dnld the TAKE OWNERSHIP registry tweak and run it to insure that u are the owner of eveything on ur systems. Reinstalling W7 messes this up.

1. make sure all systems are set to the same workgroup name.
2. make sure none of the systems have a logon using a password.
3. make sure ur server has the drive u want to share shared with EVERYONE and EVERYONE has full access. Check BOTH the SHARING and SECURITY tabs in the sharing window for drives. At this point do not specifically share folders.
4. make sure the W7 systems Advanced Sharing are set to:

Turn on Network Discovery
Turn on file and print sharing
Turn on sharing so anyone................
Use 128-bit encription........................ >> make sure XP system is set the same.

5. do not join a Homegroup on any W7 system - it doesn't work on XP systems.

If u want to access the other units FROM the server u need to share whatever on those units.

At this point turn the server on first - then boot the rest - u may have to wait 5 - 10 min for the network to find everybody and I don't know why. On my net this varies a lot and I am still searching for that answer.

good luck

Once u get that working - u can try to config it differently RE sharing, but it might break.
 


#53
Thank you ver much,ruggb

Well, at the end I got it, everything seems to work, now!
Well, what I did:
I unjoined the default homegroup in W7, set my network connection as clearly explained in the thread, but nothing worked; at the end, I discovered that the date/time on my W7 machine was wrong (don't ask me why, I don't know; I bought the motherboard used, and really didn't care of it, I just fired it up an went with W7 installation).
To make it short, the date was set to January, 2009; I set it to the right date/time, copyuing them from the server, and voilà, everything now works!
So, if it can help you, please check carefully date and time of your PCs; if they differ, it could be the cause (it was for me) you can't access to other PCs in the network.
What a stupid thing!
Any way to sincronize date & time automatically from a server? I would be glad if you can help me in such task, just to be sure everything will work in the future.

Ciao,
Giovanni
 


#54
Hi all,

I have been having problems with getting my Win 7 computer to access XP computers on our network. Initially I could not even see any computers (Win 7 or XP) except my own, then suddently today all computers appeared in the Explorer view (it seems like it can take a long time for a renamed or new computer to appear on a network). I can access the shared folders on the Win 7 computers, but are denied for the ones running XP. All other Win 7 and XP computers can access my Win 7 computer.

When I directly enter an IP address I can gain access to the shared folders on XP machines, but this is only temporary as when I close and re-open Explorer it is back to the same problem where I can see all the names but are denied access to those running XP.

I have checked all my network settings, workgroup, etc., and searched over the Internet. It appears there is a real problem with Win 7 accessing XP, however there does not seem to be any common reason or thread as far as I can tell. Have been trying to fix this for a couple of days with no luck so any suggestions would be really appreciated.
 


ruggb

Honorable Member
#55
i've been trying to fix this for months.
everytime i think i have figured it out and have it fixed - something breaks and i am going around in circles again.
right now I cannot see my XP computer. It worked yesterday.
I just turned on another W7 computer and it appeared in the WE almost immediately - sometimes it does not.
I just rebooted my XP and it appeared. the XP was on the net prior to waking the W7 - so the W7 didn't recognize it as being there (i guess).
the other w7 was shutdown so it was a cold boot.

SO maybe - the main system must be on prior to BOOTING (not just waking up) the other systems. But that should not be a requirement. It shouldn't matter the sequence.

I don't know as much as i should about this mechanism, but there is a service that is suppose to be keeping track of who is on the net and letting everyone know. LMHOSTS also has something to do with this but should not be required if the other service is functioning.
If someone can explain all this and how it is suppose to be setup and operate that would maybe help me and others.
There are no disabled net services on any system so why isn't this function seamless???????????
 


Trouble

Noob Whisperer
#56
If someone can explain all this and how it is suppose to be setup and operate that would maybe help me and others.
There are no disabled net services on any system so why isn't this function seamless?
I suspect that your present setup is for the most part all well and proper. But the NetBIOS service that provides the functionality that you are looking for can be a bit of a problem especially with workgroups that contain both Win7 and XP nodes, there is sometimes as you've discovered a bit of latency in updating the netbios name cache table on the individual client machines and this is often further delayed and complicated by the shutting down / rebooting of various workgroup members that may be maintaining the browse list and serving as the master browser for the workgroup.
Read this article for a little better explanation as to what's going on under the hood of your workgroup. He even has a downloadable tool to find your master browser(s). I have downloaded and used it so there isn't any virus or spyware in it and it may help you understand how, often times, it seems that XP machines always want to be the browse master. You may also want to take a look at the event logs on the client machines and inspect any reference to browser elections you see so you can better understand when these elections are taking place.
How to Determine the Master Browser in a Windows Workgroup | Scottie's Tech.Info
 


ruggb

Honorable Member
#57
thx trouble - that is what i was looking for.
Now to figure out why the script returns a system 53 error, but all the commands it issues work individually - net view, nbtstat, ping, etc.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.