Windows Update does not work!

#1
I have windows 7 home prem installed on my dell computer and after the last update i dont seem able to check for updates, whenever i try it says something along the lines of "the service is not currently working. Try restarting the system" This error has come up whenever i have tried since i did the update 2 days ago.

I've restarted my system and uninstalled the update which was done on that day to no effect. If anyone else is encountering this problem or had encountered it but solved it plz let me know.

Thanks in advance
 


Mitchell_A

Excellent Member
#2
Welcome to the Windows 7 Forums :)
Perhaps the service is actually not running? For whatever reason.
Open start and type in "services.msc" and click the only result, now scroll down to Windows Update, right click and select properties.
Under "Start-up Type", ensure it is set to automatic.
Click OK and try to Update again.
 


#3
Mate thx for the welcome, and the info! It works like a charm now, have no idea how it got turned off which is a little worrying but it works now!

Thanks again
 


Mitchell_A

Excellent Member
#4
Likely just a small bug in the update, either way it's fixed now, :D
Thanks for the reputation :)
 


Last edited:
This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.