Auto Play Options

Discussion in 'Windows 7 Help and Support' started by Josh, Nov 30, 2011.

  1. Josh

    Josh New Member

    Joined:
    Dec 8, 2009
    Messages:
    42
    Likes Received:
    0
    Ok here is an unusual problem which may or may not be a problem on my PC only. Basically Auto Play options do not work because my account is an Administrator account. :confused3: Yes i surely mean it; with my user account as Administrator and i insert a music CD in the drive it does not play and i cannot access the "Open Autoplay.." right click context menu on the drive. (Shift does not work also before someone suggests that). Also changing options in the CP have no effect. If i change my account to a Standard user the Autoplay works and the CD plays and i can change the autoplay options from right click or the CP.
    This is driving me mad and taken half a day of Googling without any success... somebody please help meeeeeeee!!

    OS: Win 7 Ultimate 64Bit
     
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Some questions, I suppose...

    When you change your user account Account to a standard user, who is left as Admin?

    Does this happen only on music CDs?

    Since you say you have tried all the options in the Control Panel/Autoplay, it would seem the registry is the next step. Any chance you could explain exactly what steps you took in the control panel, for example did you reset defaults?
     
  3. Josh

    Josh New Member

    Joined:
    Dec 8, 2009
    Messages:
    42
    Likes Received:
    0
    Saltgrass many thanks for some input - i was beginning to think i'd posted an impossible problem :tongue:
    Well all appears to be back to normal!!! But just to respond and provide others with advice => I had already checked the registry settings and also the Administrative Templates in the Group Policy editor. This was all correct, which is why I posted. What I neglected to inform you of is that prior to this issue I had been trying to read some old mp3 discs - you see some years ago I copied my CD's onto the PC and converted to mp3 so I could compile an mp3 disc for my car. As most will know you can get hundreds of mp3's on a disc but only 20ish tracks so this saves some unsafe disc changing whilst at speed! I digress - when I tried to read them in my drive, for some reason (scratches/degradation), they could not be read and impatiently I ejected them or right clicked for eject which occasionally caused 'explorer' to crash. After numerous attempts I logged on to my wife’s account (Standard User) and there was no issue?! I created a new account as Admin then changed my account to Standard and hey presto autoplay was available. I changed my account back and no autoplay. Still while waiting for a response to this thread I was trying to read some more discs and one would not eject at all so 'Mr Paper Clip' probed the ejection hole (oo er missus) and after several in outs (pwarrr) of the drive tray I put a normal music CD in and bang it played.
    I've been trying to replicate the issue by loading further unreadable mp3 discs but cannot replicate.
    So maybe some sort of drive issue - he clutches at straws :wink_smile: - the USB drive option window now appears also so i could say resolved but not in the manner which would provide some idea of what happened. Comments??
     
  4. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Glad you figured it out. Some of the information I found was that if Autoplay does not work, it might be because it cannot read the disc correctly... Don't know why you could read it on your Wife's computer, but that is a different drive.
     
  5. Josh

    Josh New Member

    Joined:
    Dec 8, 2009
    Messages:
    42
    Likes Received:
    0
    No same PC, different account. But I didn't have the mp3 disc in the drive just normal music CD and also USB on her account. I'm beginning to think that somehow some software routine was corrupted or was totally shot and my vigourous attempts to open drive reset it - i know that sounds ridculous but i have no other idea - well apart from those Gremlins! Still so many variables makes it nigh on impossible to recreate.
     
  6. Josh

    Josh New Member

    Joined:
    Dec 8, 2009
    Messages:
    42
    Likes Received:
    0
    Ok the problem is back - and i can't correct it?!?!
     
  7. Josh

    Josh New Member

    Joined:
    Dec 8, 2009
    Messages:
    42
    Likes Received:
    0
    [SOLVED] Re: Auto Play Options

    I am a numpty :stupid: even so I read "is there any conflicting software" in other posts etc I ignored this as the software I have was not active (Nero, CloneCD DVD etc). However, I have a Samsung MP3 Player and their media studio was loaded. I “exited” it and 'bingo' Autoplay is back TADA!! Further investigation and => in Samsung Media Studio (SMS) under Menu there is an ‘Environmental Settings’ option. On the window that opens, under the general tab, there is a checkbox => ‘Disable portable device autorun’. With this checked USB devices (including data type) don’t start autorun and strangely enough Music CD’s in the drive won’t autorun either - which must be a software bug. Uncheck this option and all is well. The reason my wifes account did not exhibit this is because SMS is not set to load for her account. The issue with the administrator issue i mentioned is probably because as a 'standard' user SMS did not load either though i haven't checked this.
    Still got there in the end - hope this helps others.
     
  8. Elmer

    Elmer Extraordinary Member

    Joined:
    Mar 5, 2010
    Messages:
    3,873
    Likes Received:
    284
  9. Josh

    Josh New Member

    Joined:
    Dec 8, 2009
    Messages:
    42
    Likes Received:
    0
  10. Medico

    Medico Senior Member

    Joined:
    Sep 20, 2011
    Messages:
    1,158
    Likes Received:
    65
    Re: [SOLVED] Re: Auto Play Options

    I have found that most apps, when installed, like to load at Windows startup and consume resources. This might have been the case with the manufacturer's "fluff" (trying to be politically correct using "fluff" instead of another word I wanted to use) I use an app called What's in Startup to check and nuke an app that does not need to run at Startup. I also used an app called PC Decrapifier (that's really the name) to get rid of much of the "fluff". Just do a Google search for either of these apps to get some relief for this "fluff" that comes preloaded and loads itself at startup.
     
  11. Josh

    Josh New Member

    Joined:
    Dec 8, 2009
    Messages:
    42
    Likes Received:
    0
    Re: [SOLVED] Re: Auto Play Options

    'fluff' - Yeah i know what you mean, i normally get rid of them but in this case i like SMS to be running so whan i connect my mp3 player it all opens. It's just that one setting that needs to be unchecked.
     
  12. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    Joined:
    May 25, 2009
    Messages:
    6,043
    Likes Received:
    300
    Re: [SOLVED] Re: Auto Play Options

    One of the most useful features of CCleaner is a tool to view and stop applications that load at start up in a easy to see and use interface that is easily reversible.
     
  13. Josh

    Josh New Member

    Joined:
    Dec 8, 2009
    Messages:
    42
    Likes Received:
    0
    Re: [SOLVED] Re: Auto Play Options

    Sorry for late reply - been on a winter break. I actually have CCleaner intsalled and never even thought to look at that :redface3: Still Christmas is here and they'll be lots of cheer!! :wink_smile:
     

Share This Page

Loading...