Cannot get Windows update to work


Senior Member
I am running a Gateway desktop with Windows 7 Premium 64bit. I have been trying to install sp1 but I keep getting errors (0x8007371b) I went to all the self help files and it wanted me to do an update of windows update. I also ran the microsoft fixit tool. Still nothing. I even went to the download center to get it. I also get error (80073712). I also ran the system readiness tool like they suggested. I always remember that live help for windows update was free so I was on the phone with a so called tech which was a waste of time. She then wanted to go into my system remotely for fee based help...My system is very clean and by the way I temp disabled my Avast while I tried to install the updates. What now?


Senior Member
Try it one more time on safe mode with networking.
If possible, uninstall the Avast first. Just install it back after.

I did that one time when i was installing a program. After one day of failure of trying to install a program, I uninstalled Avast the next day and the installation went through. No guarantee, but it's worth a shot.

Last edited:


Excellent Member
Microsoft Community Contributor
If you ran the readiness tool, there should be a log. Something like SRTrail or some such. Does it say anything about any problems it found?

There is a possibility the System File Check might help. Open an Administrative Command Prompt and type:

sfc /scannow

and allow it to finish. Let us know if it shows any unrepairable files.

In some cases, as BadRobot mentions, anti-virus programs can block the Update process from completing. If certain things are blocked for downloading or being available during a reboot, it might cause problems.

The two error messages are listed below. Maybe you can search for them and find some suggestions. Windows 7 does not seem to have a utility to repair damage to the component store, so all I know to do is to rename the SoftwareDistribution folder. One of the fixes you ran may have already done this, so if you want, look in the Windows folder for a WindowsUpdate.log and zip and attach it. You may have to copy it to the desk top to have access. I will check it to see if I can find anything.

14098 (0x3712)
The component store has been corrupted.

14107 (0x371B)
One or more required members of the transaction are not present.


Windows Forum Admin
Staff member
Premium Supporter
I also believe deleting the SoftwareDistribution folder will fix this as Saltgrass mentioned. "sfc /scannow" should stil be ran first however..

The proper procedure in doing so is as follows:

1) Stop "Windows Update" service
2) Stop "BITS" (Background Intelligent Transfer Service) service
3) Delete or rename the SoftwareDistribution folder found in your Windows folder
4) Restart the services we stopped earlier
5) Retry Windows Update

You may also be having issues with the cryptsvc,
1) Stop cryptsvc service
2) Navigate to Windows\system32 folder and renane catroot2 folder to catroot2.broken or something simular
3) Restart cryptsvc
4) Retry Windows Update


Senior Member
Thanks for all the help...I have been out of town and will follow the suggestion this week and reply.


Senior Member
Saltgrass, I did not find any log file in srtrail. I ran sfc it fould no integrity violations

Josephur, I followed all your suggestions with same results


Extraordinary Member
Premium Supporter
Going a bit outside but: when you open Control Panel\All Control Panel Items\System, can you in the bottom lines see "Windows is activated"? And then, a Product ID? 0x8007371b refers / may refer to activation problems.

Sometimes, the Product Key is faulty, and it causes a need to activate Windows again and again... I'm not saying this is your case, but it is somewhat my case, and that of many others. You may have a fully legitimate Windows, but something in the basics doesn't work.

A repair installation may be the right step, > Method 4. Or a clean installation - that's why I always recommend separate disks or partitions for own files; you have your own files in a different place > thus you can wipe out and reinstall Windows... when that inevitable day comes.

Best of all. :)


Senior Member
It shows activated and a product number


Senior Member
Thx for the replies. As I stated in my original post, yes I did run the fixit tool. I just tried it again with same results


Windows Forum Admin
Staff member
Premium Supporter
Can you attach a copy of your WindowsUpdate.log (zip it please), its located in your Windows Folder. Note you may have to temporarily stop the Windows Update service in order to zip the file as its always in use as long as the service is running. Maybe we can gleam some error code from it that will help point us in the right direction.


Windows Forum Admin
Staff member
Premium Supporter
Looks like there is a self update to Windows Update itself that's not applying correctly.

Is this the same troubleshooter the Fix It tried to run for you, if not can you run it please?

If that doesn't work it would appear that maybe re-installing the Windows Update agent itself may resolve the issue.
Windows XP users used to have nice packaged Windows Update self update installers, but in Windows 7 they are very sparse.

The last one I can remember is from
You would need to download the exe for your appropriate system (32/64-bit) and run it with the /wuforce switch at a command prompt.
This will install an older version of Windows Update, which hopefully will then be able to update itself. Try at your own risk.


Senior Member
I think it was the same fix but I did it was detected missing or corrupt files. I will try the installer link. Please explain the switch syntax..also should I turn on win update before?


Windows Forum Admin
Staff member
Premium Supporter
Shouldn't matter if the service is running or not, preferably leave it running and it should deal with it itself. The syntax is simply xxx.exe /wuforce

You can use Start, Run, and type in the full path such as: "C:\users\user1\downloads\file.exe" /wuforce

Or use an elevated (right click run as Administrator) command prompt to navigate to the folder and execute, for instance:
CD C:\Users\user1\Downloads
file.exe /wuforce

Replace file.exe with the name of the file you downloaded obviously.


Senior Member
I ran it and got the same error (80073712)...any other suggestions? I really want to install sp1...


Excellent Member
Microsoft Community Contributor
Not sure if this is any different than some of the others you have tried, but I also picked out the Windows Update Agent as not being updated. If you do actually correct the problem, it may take a while for it to correct itself. If we see the error messages changing, we will know something has been changed.

0x8024D011 WU_E_SELFUPDATE_REQUIRED Windows Update Agent must be updated before search can continue.


Excellent Member
Microsoft Community Contributor
I asked you earlier about a log you might have, but I was really thinking of the one below, which you should get after you run the System Update Readiness Tool.



Fantastic Member
Premium Supporter
Perhaps I missed something here but, the Windows Update log shows you running a different computer than a Gateway desktop:

*********** Report: Initializing static reporting data ***********
2013-07-22 17:29:45:311 356 13f8 Report * OS Version = 6.1.7600.0.0.66304
2013-07-22 17:29:45:311 356 13f8 Report * OS Product Type = 0x00000003
2013-07-22 17:29:45:330 356 13f8 Report * Computer Brand = Acer
2013-07-22 17:29:45:330 356 13f8 Report * Computer Model = Aspire M5802/M3802
2013-07-22 17:29:45:334 356 13f8 Report * Bios Revision = P01-A0
2013-07-22 17:29:45:334 356 13f8 Report * Bios Name = Default System BIOS
2013-07-22 17:29:45:334 356 13f8 Report * Bios Release Date = 2009-08-18T00:00:00

Your report shows you ran the log on an Acer Aspire M5802/M3802 which is a desktop PC, not a Gateway desktop PC as you indicated in your OP. This shouldn't make a big difference, and maybe you have more than 1 PC at home, and you ran this report on the wrong PC?? :eek:

I have never worked on an Acer desktop (in 30 yrs.), so perhaps they are not widely available here in the US, but I have worked on several Acer Aspire laptops, and they have plenty of issues. If I had direct experience with an Acer desktop, I could advise you to continue the repair. If your computer that actually has the problem really is a Gateway, I DO have plenty of experience with those, and I would advise you to continue trying to repair your Win7 windows installation.

However, based on what I've seen with the Aspire laptops, that does not inspire confidence in me that there is any chance at all of repairing your Windows installation. They have many problems with both their Motherboards and their hard drives. Your hard drive is in a machine that's probably around 4 yrs. old. Hard drives begin to fail as early as 2 yrs. in laptops and 3 yrs. or less in desktops. HAVE YOU RUN HARD DRIVE DIAGNOSTICS? Such as SeaTools for Seagate hard drives, or DLG for Western Digital drives? Some Aspire laptops I have worked on also come with built-in hardware diagnostics..have you run those on your hard drive? What was the result? :silence: While you are taking time to run the hard drive test, you should also ensure that the RAM memory also passes your built-in manufacter-supplied hardware diagnostics.

If your hardware passes muster, per above testing I suggest you could certainly pursue a Windows Installation repair, if you have the time and expertise. For me, that can take 1-2 weeks, and I've been doing for 30 yrs. as I said. And they are not always successful, and I have no idea how accurate those will be on a desktop I've never seen before or worked on. :skull:

My suggestion, and it echoes Pauli's recommendations, is to fall back, backup all your data to an external hard drive, flash drive, cd/dvd disc(s), and reinstall your Windows7 from either a built-in Recovery Partition, or use the Recovery discs that came with your computer. If you really have a Gateway and not an Acer; there is a good chance you received those discs in the box your Gateway came in. If you have an Acer; not one of the Acer laptops I've worked on in that last year came with those discs, so you may have to look for a Windows Utility program, maybe until "ACER" or "MAINTENANCE" and create the disc set yourself. They will typically be from 2-4 discs for the Windows7 OS, and perhaps more discs for the "APPLICATIONS AND DRIVERS" disc as well.

Lastly, if you go the route that Pauli and I are suggesting to you, that should resolve your ability to upgrade your Windows7 to SP1. :up: I have done this on many Acer Aspire laptops and many, many Gateway desktops. Make sure that you select "ERASE ENTIRE HARD DRIVE PARTITION" when you do this, and not the "REPAIR WINDOWS PARTITION" option that Windows Recovery Console may present you. If you have file corruption or undetected viruses on your hard drive, that may not fix your problem. Reinstallation and Partition/Hard drive wiping fixes your SP1 update problem in better than 90% of the cases. :partay:

If it still does not work, you most likely have a faulty hardware component, hard drive, or Motherboard that needs to get replaced. At that point, you may want to take your Acer or Gateway PC to a local Certified Computer Professional to help get it repaired. :(

Looking forward to your responses back. :nerves:



Senior Member
Checking System Update Readiness.
Binary Version 6.1.7601.21645
Package Version 20.0
2013-09-18 13:14

Checking Windows Servicing Packages

Checking Package Manifests and Catalogs

Checking Package Watchlist

Checking Component Watchlist

Checking Packages

Checking Component Store

Seconds executed: 761
No errors detected

This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.