can't delete 4 DLL files

franktheman7

Well-Known Member
#1
Hello,

I tried to uninstall Adobe Acrobat Reader 7 but I couldn't do it
so I went to the folder location and started deleting it folder by folder
and when I got to this folder called ActiveX with 4 DLL's in it called
(AcroIEHelper.dll AcroPDF.dll GbDetect.dll pdfshell.dll) so I dragged them
to the desktop and tried to delete them again with no luck.

Any help would be great, Thank you all much.

Frantheman7
 


davehc

Essential Member
Premium Supporter
#2
Two things to try.
You may find you have Adobe reader in MSconfig under the start Tab. First untick that and reboot and try again to remove the files.
But, I believe these files may be associated with Adobe Flash. You may find, if you uninstall Flash, in Programs and features, the files may then be removed. But before doing this, move those three files back where they belong.(You will be prompted to reinstall Flash again if needed in the future, which you can safely do)
Reinstall Adobe reader, with any extras, and try the standard uninstall again. Again, move those three files back where they belong first.
 


patcooke

Microsoft MVP
Staff member
Premium Supporter
Microsoft MVP
#3
If you still have problems deleting you may find booting into safe mode helps.
 


franktheman7

Well-Known Member
#4
Will nothing worked for me, thanks anyways, maybe i'll try a restore
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#5
You don't need a restore. Those 4 files are in a folder that transfers its permissions to the files. There has been some utility to remove files that I can't remember (maybe file assassin) that will probably remove them, or you can go into the folder and take ownership, OK all the way out and then go back and give yourself full control.

When the gold shields disappear, you have taken control.

I have never used File Assassin so I can give no guidance. Are you sure you have deleted all of Adobe Reader, those files are in a "Common Files" directory.

Edit: If you have an Adobe add-in to a browser, it might be involved. Possibly try disabling the plug-in.
 


MikeHawthorne

Essential Member
Microsoft Community Contributor
#6
Hi

After you run Malwarebytes go to the more tools tab and use File Assassin (as Saltgrass said) and see if that will remove the files.
You can also try and use Grant Full Admin Control and see if that helps.

Grant Admin Full Control

Take and Grant Full Control Permissions and Ownership in Windows 7 or Vista Right Click Menu « My Digital Life

Before doing a restore I would create a Ubuntu disk and just boot into Ubuntu from the disk and delete the files

Download | Ubuntu

I had to do this just last week do remove a folder that Windows just didn't want me to get rid of.
Then you will always have the Ubuntu disk around for emergencies, make the 32 bit version and it will boot anything.
Even if Windows crashes beyond repair you will be able to access your files and back them up before reinstalling.

Mike
 


franktheman7

Well-Known Member
#7
File Assassin didn't work
all of the Adobe add-in are disabled
how do ya take ownership
 


franktheman7

Well-Known Member
#8
I DLed the file GrantAdminFullControl.reg and WOW Mike, could you make it any easier,
this is great, this is really fantastic Mike, thank you so much, thank you all so much
.
Frantheman7
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.