Can't print with Windows 8 and Canon iX4000

Discussion in 'Windows 8 Installation' started by prtimmer, Mar 10, 2013.

  1. prtimmer

    prtimmer New Member

    Joined:
    Mar 10, 2013
    Messages:
    4
    Likes Received:
    0
    Hi
    Everytime I try to print with Windows 8 I get a print error state
    "Cannot communicate with the printer.
    Turn Enable bi-directional support on in the printer's Properties dialog box."

    When I find the checkbox I tick it, 'Apply', 'Save' but then it generates the same error, and when I go back the tick box is unticked.

    Can anyone suggest a fix?

    thanks
    Peter
     
  2. bassfisher6522

    bassfisher6522 Essential Member

    Joined:
    Aug 27, 2008
    Messages:
    4,878
    Likes Received:
    317
    Generally an uninstall and reinstall of printer software/driver usually fix's those kinds of errors.
     
  3. prtimmer

    prtimmer New Member

    Joined:
    Mar 10, 2013
    Messages:
    4
    Likes Received:
    0
    Hey Bassfisher. Thanks. I tried that and no joy. I have Googled and reinstalled drivers from Canon twice. I am confused about why it will not retain my checkbox setting that it tells me i need to enable!

    thanks for your time though. I hope we can sort this soon!
    Peter
     
  4. bassfisher6522

    bassfisher6522 Essential Member

    Joined:
    Aug 27, 2008
    Messages:
    4,878
    Likes Received:
    317
    When you uninstalled the software/driver, did you unplug the usb cable from the PC? It must be off and unplugged from the PC before reinstalling.

    Also, Cannon might have there own special uninstaller tool to completely remove it.
     
  5. prtimmer

    prtimmer New Member

    Joined:
    Mar 10, 2013
    Messages:
    4
    Likes Received:
    0
    Thanks Bassfisher, I disconnected, then tried to remove the driver package but it said.

    The following package(s) cannot be deleted:

    prnca00f.inf (x86)
    This package contains the following driver(s) that are in use:
    Canon Inkjet iX4000; This driver is used on:
    Canon Inkjet iX4000.

    The following driver(s) cannot be deleted:

    Driver Canon Inkjet iX4000 (x86) is in use. It is used on:



    Canon Inkjet iX4000.

    It's strange as it said this after I restarted the computer without the printer. So I then (without printer) tried to install the Canon drivers, reconnected the printer USB, and the problem is unchanged. It will not remember if I ticker the bi-directional support box. and I can't print.

    Any further help gratefully received.
     
  6. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    It seems strange the drivers appear to be in use. Almost like you have put something in the print Queue that is stuck.

    Have you tried uninstalling the printer, and checking the box that asks if you want to remove all the drivers?

    I assume this is a wired printer?

    You might also check the printer ports in Devices and Printers. Look at the Printer Prioperties in the middle of the context menu, not the Properties at the bottom.

    Is this a Multifunction device? Changing USB ports might also help.
     
  7. bassfisher6522

    bassfisher6522 Essential Member

    Joined:
    Aug 27, 2008
    Messages:
    4,878
    Likes Received:
    317
    You misunderstood me...you should have left the printer connected to the PC while uninstalling it. Then once its uninstalled, unplug usb cable from PC. Then reboot.

    Checking the Canon site, I don't see a removal tool either for it. You could look in the registry, after uninstalling it, finding anything to do with canon and deleting those folders. Look for the folders in the registry under these 2 places. HKEY_CURRENT_USER ... open the drop down arrow and select software, then look for anything Canon and delete. The do the same thing in HKEY_LOCAL_MACHINE, then reboot.

    This is why I tend to stay away from Canon, Epson and Brother printers because of their troublesome nature.
     
  8. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    You could also try stopping the (Print Spooler) Spooler service in Task Manager. Possibly even stopping then restarting might have an effect.
     
  9. Sonny

    Sonny Fantastic Member

    Joined:
    Nov 17, 2009
    Messages:
    1,258
    Likes Received:
    93
    Try calling canon support. They can walk you through it and give you the right drivers to download. That is what I ended up doing as when you using my disc that came with the printer was corrupt and gave me the same message you got. They had me up and running in just minutes.
     
  10. prtimmer

    prtimmer New Member

    Joined:
    Mar 10, 2013
    Messages:
    4
    Likes Received:
    0
    Thanks bassfisher6522.
    It solved the problem when I uninstalled with the printer connected. I can print again!
     
  11. bassfisher6522

    bassfisher6522 Essential Member

    Joined:
    Aug 27, 2008
    Messages:
    4,878
    Likes Received:
    317
    Glad to hear you got it sorted.
     

Share This Page

Loading...