check disk utility keeps running after every startup - Fixes applied without solving.

ztplru

Honorable Member
Hi Guys,

This one is really getting on my nerves as the check disk utility keeps running after every startup. Even after applying below solutions.
What else can you propose? Am i facing a failing SSD? It's an SSD that hasn't been used much.

C:\Windows\system32>fsutil dirty query c:
Volume - c: is NOT Dirty

C:\Windows\system32>chkntfs /X C:
The type of the file system is NTFS.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager key BootExecute is set to: autocheck autochk /k:C *
 

davehc

Essential Member
Premium Supporter
Which checkdisk utility is it ou are using? Have u, by chance got it running in the task manager- startuo tab? If do, disable it. There is really no need for a regular check on an ssd, unless it is giving problems
 

ztplru

Honorable Member
Which checkdisk utility is it ou are using? Have u, by chance got it running in the task manager- startuo tab? If do, disable it. There is really no need for a regular check on an ssd, unless it is giving problems
Hi Dave,
it's not in the task manager-startup tab!

i've run chkdsk command with some flags i found in an article to check for errors in the ssd, and since then it's always running at boot. but the check is really fast!

I need to get rid of it. And most articles i pulled from google pointed to the commands i already used!
 
Last edited:

davehc

Essential Member
Premium Supporter
If you are talking about the built in check disk utility (Start menu - Admin Tools - - Defrag and optimise drives) If it is ON, turn it OFF
FWIW. In my computers, all ssd, the key you mentioned reads "autocheck autochk *
Your second script does not exist.
As I suggested, if you are using a third party disk checker, or a script, try turning either off or reversing them.
 

ztplru

Honorable Member
Dear Dave,

It wasn't "Defrag and optimise drives". And i don't have any 3rd party disk checker, or a script.

It were this parameters /k:C in front of autocheck autochk in regedit, that caused the disk check after restart/boot to always happen!

There are a lot of IT articles in internet full of misinformation.
This 2 articles i just pulled (out of dozen others) state /k:C stops disk check from being performed on the C drive after restart/boot.


Now it has only autocheck autochk *, and disk check is gone! Why is that? It's odd!
 
Top