DVD Drives not visible in "My Computer"

Discussion in 'Windows 7 Help and Support' started by maninas, Apr 1, 2009.

  1. maninas

    maninas New Member

    Joined:
    Apr 1, 2009
    Messages:
    8
    Likes Received:
    0
    DVD Drives not visible in "My Computer" [Solved]

    Hi all,
    I've recently reinstalled windows 7 x64 (build 7057) on my computer, due to irrecoverable issues I've faced before. Although I had no similar problem on the previous windows 7 x64 (build 7057) installation (despite no internet access was available at the time of that install), this time for some reason my DVD and DVD/RW drives are not available in "My Computer". They both do are appear though, in Device Manager under "DVD/CD-ROM drives" tree, though marked with a yellow triangle with an exclamation mark icon.

    I 've already clicked "Uninstall" on them in Device Manager and then clicked on "Scan for hardware changes" and, as it should, I get a pop-up "Windows is installing drivers" which then fails for both drives and which brings me to the same state with the same yellow icon in Device Manager. I should add that internet was available this time both during windows installation and during the "Windows is installing drivers" phase. Also no drivers are available on the manufacturers' sites neither for the motherboard chipset (l don't think there's the issue) nor for any of the drives.

    Motherboard chipset is Nvidia Nforce4 ultra, and motherboard model is NF4UK8AA-8EKRS by FoxConn. The two drives as shown in Device Manager are:
    NEC DVD_RW ND-3550A ATA Device
    HL-DT-ST DVD-ROM GDR8164B ATA Device (that's an LG drive)

    I just can't get around this problem and I really don't want to get in the format/reinstal process for the third time, so any help would be really appreciated.

    Thnx all in advance!
     
    #1 maninas, Apr 1, 2009
    Last edited: Apr 1, 2009
  2. Radenight

    Radenight New Member

    Joined:
    Nov 16, 2008
    Messages:
    4,525
    Likes Received:
    108
    Ok, so first off is this the only build of Windows 7 you've used? Have you used build 7000 (the public beta) at all?
    It does sound like a driver issue but than again it doesn't.. ;) Not to confuse ya but... Are the drives SATA or IDE?

    This is a perfect example of why you shouldn't use daily/interim builds... They are not ment to be used by the general public.. many run into alot of problems just like this as a result of using them.... I know how tempting it is to download and install them but trust me, it's not always worth it.. The public beta (build 7000) is perfectly stable and rock solid, there's no reason not to be using it instead of a daily build.. The RC is just around the corner as well so it's not like you'd have to use build 7000 for a very long time either. It just gives you more of a guarantee that all your hardware will be useable "out of the box" than a daily build does.. Not to mention there aren't any drastic changes between build 7000 and build 7057 or even 7068 for that matter so why not use the tried tested and true version... :)

    What I would suggest (since you won't really be any further behind by doing this) is to do a clean install (Format your partition, than install a fresh copy) of the public Beta (Build 7000).. If you can be connected to the internet during the install than that's ideal.. if not than make sure you have all your mobo and any other drivers you'll need handy prior to the installation... ;) That should resolve the problem as your optical drives will install themselves during/prior to the installing process...

    I do remember reading about a bug in build 7057 too.. I can't quite remember exactly what it did or didn't do but I know it caused alot of problems for some users... I'm still using build 7000 until the RC comes out so unfortunately I can't really help you anymore than this....

    Hopefully this helps you out a bit.. I know it's a painfully tedeous task to reinstall OS's 3 of 4 times before you get a problem free installation but hey, it's worth it in the end isn't it to have a nice fresh/problem free installation...
     
  3. GomJabbar

    GomJabbar Senior Member

    Joined:
    Jan 25, 2009
    Messages:
    203
    Likes Received:
    2
    maninas and (deleted member) like this.
  4. maninas

    maninas New Member

    Joined:
    Apr 1, 2009
    Messages:
    8
    Likes Received:
    0
    @GomJabbar Many many thanks, my friend. Thanks to the link you've provded I've solved my problem! Σε ευχαριστώ! (thank you in Greek ) :)
    @Radenight Many thanks to you as well Radenight for your effort. Though all the info you asked for was already given on my initial post, where I also stated I wanted to bypass the format/reinstall solution, that I knew how to do myself already. Thanx anyway though, very nice of you to spare your time. :redface:

    Now for all those of you having the same problem:

    I followed this link, but the autofix didn't work. So I had to go Start->All programs->Accessories->Run and type "regedit" (without the ""). There I navigated to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318} and since there was no UpperFilters file, I deleted the file LowerFilters as instructed. Then restarted and voila!

    Hope that helps anyone else out there havfing the same problem.
     
    #4 maninas, Apr 1, 2009
    Last edited: Apr 1, 2009
  5. GomJabbar

    GomJabbar Senior Member

    Joined:
    Jan 25, 2009
    Messages:
    203
    Likes Received:
    2
    Great! Glad to hear that solution worked for you!:)
     

Share This Page

Loading...