External Hard Drive Persmissions Problem

Discussion in 'Windows 8 Help and Support' started by shoog, Aug 12, 2013.

  1. shoog

    shoog New Member

    Joined:
    Apr 22, 2010
    Messages:
    6
    Likes Received:
    1
    Alright, here's the story. My original hard drive died a few days ago in which I just replaced.

    Once everything was back up to what it was before, I found that my external hard drive had some issues to permissions. I couldn't access any files on it and so I went in and tried some things. Eventually I ended up in a position where the only available identity it had was that the owner was set to "Everyone" while there are no permission entries what so ever for any other user.

    [​IMG]

    Clicking on "Change" or anything that is relevant to adding a user will generate this window below:

    [​IMG]

    And will follow up with this:

    [​IMG]

    With those things I tried googling all over the place, such as "ADVirtualDisk" but come up with nothing. Any ideas would be appreciated.
     
  2. Josephur

    Josephur Windows Forum Admin
    Staff Member Premium Supporter

    Joined:
    Aug 3, 2010
    Messages:
    1,019
    Likes Received:
    125
    Try these commands at an elevated command prompt:

    takeown /R G:\
    cacls G:\* /c /e /t /g everyone:F
     
    shoog likes this.
  3. shoog

    shoog New Member

    Joined:
    Apr 22, 2010
    Messages:
    6
    Likes Received:
    1
    Thanks for the reply.

    No dice on that.

    [​IMG]
     
  4. Josephur

    Josephur Windows Forum Admin
    Staff Member Premium Supporter

    Joined:
    Aug 3, 2010
    Messages:
    1,019
    Likes Received:
    125
    Sorry, try
    "takeown /f G:\ /r /a"
     
    shoog likes this.
  5. shoog

    shoog New Member

    Joined:
    Apr 22, 2010
    Messages:
    6
    Likes Received:
    1
    No go on that.

    [​IMG]
     
  6. Josephur

    Josephur Windows Forum Admin
    Staff Member Premium Supporter

    Joined:
    Aug 3, 2010
    Messages:
    1,019
    Likes Received:
    125
    Hmmm that should have worked, I just tested it with a flash drive. No matter what permission issue that should have granted Ownership to Administrators. Have you tried using another computer, or OS (such as Ubuntu/Knoppix) to read the drive?

    Also have you attempted to run "chkdsk /f /r" on it?
     
    shoog likes this.
  7. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    bassfisher6522 and shoog like this.
  8. Josephur

    Josephur Windows Forum Admin
    Staff Member Premium Supporter

    Joined:
    Aug 3, 2010
    Messages:
    1,019
    Likes Received:
    125
    Looks like that could resolve issues with the ADVirtualDisk explorer addon, however I do not believe that is going to fix your permissions. If you have another computer try it out on there, see if its the drive itself or your computer. Process of elimination...
     
    shoog likes this.
  9. shoog

    shoog New Member

    Joined:
    Apr 22, 2010
    Messages:
    6
    Likes Received:
    1
    Bingo, that's the thing that was blocking me from adding any permissions. What a weird thing for a minor program to do that.

    I simply uninstalled adobe drive CS4 since I don't need it. The thing about that addon was that it was a forced application to be included with the installation of photoshop cs4.

    I had to go back to uninstall photoshop, then when the wizard came up to uninstall it gave me an option to remove certain parts, in which it let me uninstall the cs4 drive application by itself.

    With that removed, I could go into the interface of windows and add a new user to the external drive using windows explorer, in which i just simply put in "everyone" permission with full access and now I can at least access the files from the hard drive.

    Initially though what I tried before that was josephur's suggestion in which I should try adding permissions through another computer. When I tried that it worked easily which lead into Trouble's research which indeed ended up being the reasoning as to why I couldn't do much of anything on my problem computer because of adobe drive cs4.

    With that I'd like to thank you two for the help and suggestions. Good stuff.
     
    Josephur likes this.
  10. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Excellent. Glad to hear that you were able to resolve your problem. Thanks for posting back and updating your thread with your solution.
     

Share This Page

Loading...