Fonts not showing up

Discussion in 'Windows 8 Help and Support' started by Juc1, Jul 5, 2014.

  1. Juc1

    Juc1 New Member

    Joined:
    Jul 5, 2014
    Messages:
    2
    Likes Received:
    0
    Hi all,

    I have pasted some English alphabet OpenType font files into control panel / appearance and personalisation / fonts but they do not show up in the fonts folder. If I try to paste the files again it tells me "the gotham light file font is already installed - do you want to replace it?"

    So if the font files are installed why can't I see them in the fonts folder?

    I have tried unchecking "hide fonts based on language settings" but that does not seem to help. The fonts do not show up in Microsoft Word or Adobe CS6 and I get the same problem on my Windows 7 machine.


    Any ideas please?


    Thanks...
     
    #1 Juc1, Jul 5, 2014
    Last edited: Jul 5, 2014
  2. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    Joined:
    May 25, 2009
    Messages:
    6,051
    Likes Received:
    302
    Hi

    Well I was going to answer this, but when I checked I found that the whole install fonts thing has changed.
    It used to be that there was an add fonts option accessible from the fonts icon in control panel.

    But this option seems to be missing now.

    The reason that I just figured this out is, that as a graphic designer I have my master fonts folder (about 700 fonts other then the standard Windows fonts) carry over, from install to install for many years (decades actually).

    When I set up a new computer I just merge my master fonts folder into the C:\Windows\Fonts folder and all of my fonts are installed along with the standard Windows fonts for that version of Windows, so that I can open any job I've ever done and the fonts are there.


    To get back to your problem, the way I add fonts it to copy the font directly into the C:\Windows\Fonts folder.

    You may have to reboot before the font shows as installed.

    But you should be able to right click on the font file in Windows Explorer and see the option to install the font. You can batch select the fonts and install multiple fonts at the same time.

    Alternately if you double left click on the font a preview window should open, at the top will be an Install button.

    If you don't get the preview window to open, open properties for the file and change the open with setting to "Windows Font Viewer".

    If you don't see the install option it is probably because the file isn't a legitimate font file (i.e Adobe fonts have several extensions and only one of them will install in Windows for example) but ".otf" files shouldn't be a problem.

    I recommend a free application called "Font View OK", I've used it for many years, it will display all of your installed fonts and let you compared them side by side with what ever text you want.

    It will confirm what fonts are installed and working.

    http://download.cnet.com/FontViewOK/3000-2316_4-10807693.html

    If none of this helps, come back and we'll look at more options.

    Mike
     
    #2 MikeHawthorne, Jul 5, 2014
    Last edited: Jul 5, 2014
    ussnorway likes this.
  3. ussnorway

    ussnorway Windows Forum Team
    Staff Member Premium Supporter

    Joined:
    May 22, 2012
    Messages:
    2,538
    Likes Received:
    316
    @Mike Hawthorne, yes Microsoft likes to change things once people get used to them.

    To be clear,
    1. The correct path for fonts is "C:\Windows\Fonts"... assumes windows is in the default drive but works in 7&8.
    2. After placing them in that folder you open 1 at a time and click the install button.
    3. Windows will see the font now and Cs6 etc should pick up the new fonts after a system restart.

    font.
     
  4. Juc1

    Juc1 New Member

    Joined:
    Jul 5, 2014
    Messages:
    2
    Likes Received:
    0
    Thanks for replies. I have restarted in the two machines but I still have the same same problem. Please see the attached screenshots.


    The 26 fonts I am trying to install.

    1.


    My Windows/fonts folder shows only Gotham (Gotham-XLightItalic etc is not there)

    2. [


    Message "Gotham-XLightItalic is already installed"


    3.


    The Gotham fonts previewing in Fontviewok under "installed system fonts"


    5.


    MS Word (Gotham only)


    6.


    Font folder = Gotham only


    7.


    right click / install on font file


    8.


    font file properties

    9.


    Message "Gotham-XLightItalic is already installed"


    10.


    previewing a font in Windows Font Viewer


    12.
     
    #4 Juc1, Jul 6, 2014
    Last edited: Jul 6, 2014
  5. ussnorway

    ussnorway Windows Forum Team
    Staff Member Premium Supporter

    Joined:
    May 22, 2012
    Messages:
    2,538
    Likes Received:
    316
    1. Un-install the fonts you had before… just ones from other folders will do.

    2. Put the new fonts into the windows folder c:- windows-fonts

    3. Install them

    Adobe Cs6 should see the other fonts but Word is a crap Microsoft product and will only look in the default folder i.e. if you install a font from somewhere else then word won’t see it.
     
  6. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    Joined:
    May 25, 2009
    Messages:
    6,051
    Likes Received:
    302
    Hi

    Yes, just copy the fonts to the fonts folder.
    Adobe Type 1, True-type or Open Type, should all work.

    [​IMG]

    Something you might want to do is once you have everything working, make a copy of your fonts folder and save it some place, (I have copies of my fonts folders going back many computers, because as a graphic designer the most frustrating thing is not being able to find a font, from a previous job) I just name them Fonts used on my computer, with a date.

    You can always merge the folders to add anything that has come up missing over the years.

    Mike
     
    #6 MikeHawthorne, Jul 7, 2014
    Last edited: Jul 7, 2014

Share This Page

Loading...