Windows 10 How do I permanently un-check "Connect automatically" for Wifi?

Discussion in 'Windows 10 Help and Support' started by jwal, Sep 12, 2016.

  1. jwal

    jwal New Member

    Joined:
    Sep 12, 2016
    Messages:
    2
    Likes Received:
    0
    Two questions:

    Why does un-checking "Connect automatically" spontaneously re-check?

    How do I permanently un-check "Connect automatically" for Wifi?

    Please note:
    Under my WIFI tab, available networks can be uncehcked, but they never remain unchecked. I can not interact with this list by right clicking, other to uncheck the "connect automatically" tab.

    Under Manage WIFI settings, Manage Known Networks lists ONLY the one network I use. Available networks displayed above aren't listed here.
     
  2. BIGBEARJEDI

    BIGBEARJEDI Honorable Member
    Premium Supporter

    Joined:
    Jan 28, 2013
    Messages:
    1,803
    Likes Received:
    219
    Hi and welcome to the forum :up:

    Sounds like you have a setting or two turned off in your wireless network settings. Take a look at these suggestions:

    *************************************************************************************************************************************
    Try this first:
    TRY SETTINGS-->WIRELESS NETWORK CONNECTION-->MAKE THIS PC DISCOVERABLE; SET TO ON.

    If you don't get the list of other wi-fi networks try these:
    TRY MANAGE WI-FI SETTINGS-->WI-FI SENSE-->CONNECT TO SUGGESTED OPEN HOTSPOTS; SET TO ON.

    TRY MANAGE WI-FI SETTINGS-->CONNECT TO NETWORKS SHARED BY MY CONTACTS; SET TO ON.

    TRY MANAGE WI-FI SETTINGS-->PAID WI-FI SERVICES; SET TO ON.
    *************************************************************************************************************************************

    You'll notice that first setting, "Make This PC Discoverable" if not set to "ON", your list of available networks in your area (neighbors Wi-Fi networks) will disappear. Turning this on and off and on again may fix it. It works on my W10 laptop (Sony).

    If that doesn't work, you may have a virus/malware infection and you should scan with your installed AV program; and remove all found viruses. Then download the free MALWAREBYTES antispyware from Malwarebytes.org and scan/remove all found spyware viruses. Retest your Wi-Fi. It should now be fixed as above. :up:

    If it doesn't you could have some kind of windows system file corruption or a hard drive failure. If you try the above and get to this point in my post, you can post back for further help on what to do.. In the meantime, I WOULD MAKE CERTAIN YOU HAVE ALL YOUR PERSONAL DATA (LIBRARY FOLDERS) BACKED UP TO EXTERNAL MEDIA TO AVOID IRRETRIEVABLE DATA LOSS BEFORE PROCEEDING WITH FURTHER REPAIRS!!

    Let us know how it goes.
    <<<BIGBEARJEDI>>> :encouragement:
     
  3. jwal

    jwal New Member

    Joined:
    Sep 12, 2016
    Messages:
    2
    Likes Received:
    0
    Hi, thanks for the help.

    I've had 'discoverable' toggled off for some time, and toggling them on or off doesn't seem to change things. Available connections are still listed on my task bar (including, periodically, that of my neighbours), and also under the settings > WIFI tab.

    The superfluous connections aren't listed under "Manage Known Networks", because i removed them previously, hoping my computer would no longer try to connect to them.

    The only trouble I have is that I believe my computer is trying to connect to the listed networks, which results in frequent drops from the network I do use. The list has "connect automatically" options, which should solve the problem, only the box will not remain unchecked.

    Before posting this, I searched and found many similar complaints expressing the same problem, so I don't think it is a virus. The responses, however, even by official reps were vague, incorrect, unfinished and didn't actually seem to understand the problem, or offered unreasonably complicated workarounds requiring third-party software. I am wondering, if its an actual recognised bug with Windows10, and what the official work around is, or if its not, then what has gone wrong.

    Cheers.
     
  4. Neemobeer

    Neemobeer Windows Forum Team
    Staff Member

    Joined:
    Jul 4, 2015
    Messages:
    2,418
    Likes Received:
    366
    "Make this computer discoverable..." only makes your computer discoverable to other computers, the inverse is not affected.

    The "Connect Automatically" should be SSID specific, which means it is going to be checked only for a given network.

    I would turn all of these off. It could be you're getting wireless profiles from a contact.
    TRY SETTINGS-->WIRELESS NETWORK CONNECTION-->MAKE THIS PC DISCOVERABLE; SET TO ON.

    If you don't get the list of other wi-fi networks try these:
    TRY MANAGE WI-FI SETTINGS-->WI-FI SENSE-->CONNECT TO SUGGESTED OPEN HOTSPOTS; SET TO ON.

    TRY MANAGE WI-FI SETTINGS-->CONNECT TO NETWORKS SHARED BY MY CONTACTS; SET TO ON.

    TRY MANAGE WI-FI SETTINGS-->PAID WI-FI SERVICES; SET TO ON.

    Wireless profiles are stored at C:\ProgramData\Microsoft\Wlansvc\Profiles\Interfaces Each folder in here represents a wireless network interface if you have more than one. Each xml file in an interface folder is a SSID you have connected to and has been saved.

    Within each saved SSID is the setting
    <connectionMode>auto</connectionMode> this tells Windows to automatically connect or
    <connectionMode>manual</connectionMode> for manual connection
     
  5. BIGBEARJEDI

    BIGBEARJEDI Honorable Member
    Premium Supporter

    Joined:
    Jan 28, 2013
    Messages:
    1,803
    Likes Received:
    219
    @neemo: If all these settings are turned off, he won't be able to see the list of available networks including his own Wi-Fi router SSID. Not sure if this is a bug in W10 or not, but these settings work pretty much the same in W7 and W8/8.1. (they have slightly different names however in W10).

    @jwal: It's probably worth trying neemo's suggestions. I don't believe that will fix your problem. It's more likely that there's a problem with your particular computer. Are you on a laptop or desktop PC? Either way, do you have a friend that will let you connect to their home Wi-Fi network with your computer to test your W10 with? If it works differently, and you get some options that allow you to keep your connection always on in his home Wi-Fi, you may have to reset your W10 on that device; as you may have other Windows corruption at the registry level or a faulty RAM or Hard Drive.o_O Have you tested your Hardware on that device??:question: If you get the identical result on your friend's home Wi-Fi network, there might indeed be a bug with W10...but we would need more users to join in this thread and post back their results in a substantiated manner which is not easy to do here, as many users view us asking for complete system specs as an invasion of their privacy. Nonetheless, if you try what I suggest, and do get a fix on your friend's home network, it identifies a problem specific to YOUR device, then you can take the appropriate remediation steps. Post back if you need a link to comprehensive hardware/software testing and repair.

    Best,;)
    BBJ
     
  6. Neemobeer

    Neemobeer Windows Forum Team
    Staff Member

    Joined:
    Jul 4, 2015
    Messages:
    2,418
    Likes Received:
    366
    Not true, I have them all turned off on all of my Windows 10 systems and I can see and connect to any available SSID.
     
  7. Neemobeer

    Neemobeer Windows Forum Team
    Staff Member

    Joined:
    Jul 4, 2015
    Messages:
    2,418
    Likes Received:
    366
    I have pretty much every discovery service turned off and I connect just fine.
    services.PNG
     
  8. BIGBEARJEDI

    BIGBEARJEDI Honorable Member
    Premium Supporter

    Joined:
    Jan 28, 2013
    Messages:
    1,803
    Likes Received:
    219
    Interesting...mmmm. I'll have to take a look at that. :)
     

Share This Page

Loading...