Japanese text suddenly became squares.

Discussion in 'Windows 7 Help and Support' started by ZeraX, Oct 28, 2013.

  1. ZeraX

    ZeraX Senior Member

    Joined:
    Feb 12, 2010
    Messages:
    103
    Likes Received:
    2
    Hi all
    i have been facing a problem from 2 days ago which is never happened before.

    my Windows Explorer hadn't problem displaying Japanese Characters in Folder and Files name until recently.

    like in this image

    [​IMG]

    it also gives sqaures instead of ► in folders.

    is there any fix for this ?

    appreciating any help
     
  2. Josephur

    Josephur Windows Forum Admin
    Staff Member Premium Supporter

    Joined:
    Aug 3, 2010
    Messages:
    1,018
    Likes Received:
    125
    It sounds like your Japanese font has come up missing. Go to Control Panel->Region and Language Options and add the Japanese Keyboard and Japanese Microsoft IME and see if that resolves the issue.
     
  3. ZeraX

    ZeraX Senior Member

    Joined:
    Feb 12, 2010
    Messages:
    103
    Likes Received:
    2
    Thanks for your reply, but no it didn't resolve the problem.

    can i re-install the default fonts that come with the installation of Windows 7?
    i think it might be problem of modified or corrupted fonts.

    also, when i changed System Locale to Japanese, the characters appeared properly but switching back, the characters became squares again.
    so i think the problem is with the fonts files.
     
  4. Josephur

    Josephur Windows Forum Admin
    Staff Member Premium Supporter

    Joined:
    Aug 3, 2010
    Messages:
    1,018
    Likes Received:
    125
    It is possible if you run a command prompt as an Administrator and use "sfc /scannow" it should replace any corrupt system files.
     
  5. ZeraX

    ZeraX Senior Member

    Joined:
    Feb 12, 2010
    Messages:
    103
    Likes Received:
    2
    Hi again
    first sorry for the long reply, we had a problem with the internet from the ISP, it's now fixed fortunately.

    and no "sfc /scannow" didn't help, i also tried to copy the fonts from Windows 8 from the laptop and paste into Windows 7.
    no result though.
    i noticed that somtimes, after restart, the fonts appear properly, but some times later, they back to squares.
     

Share This Page

Loading...