Killer E2200 Gigabit Ethernet Controller

Discussion in 'Windows 10 Networking' started by Sanctaidd, Feb 25, 2016.

  1. Sanctaidd

    Sanctaidd New Member

    Joined:
    Feb 25, 2016
    Messages:
    1
    Likes Received:
    0
    Hello,
    Last fall I upgraded my MSI GS70 2PE laptop from Windows 8 to Windows 10 with a clean install. There were a few speedbumps with drivers and what-else, but I got everything to work - including my Local Area Connection ethernet port.
    Last month, I stopped being able to recieve an internet connection through this port, regardless of the network, after a windows update. This is frustrating because I prefer LAN for gaming and also when the college wifi network is acting up.
    So if I troubleshoot this lack of connection, through the network troubleshooter, the first message I recieve is "One or more network protocols are missing on this computer". If the troubleshooting is attempted again, there is no result. Under additional details, it is listed that "Windows Sockets registry entries required for network connectivity are missing."
    After some research online, these socket entries are related to the Winsock / Winsock2 registry keys. I have read people online fix my issue through applying old Windows 7 keys over the new non-functional Windows 10 versions. I attempted a similar fix, by deleting the keys and reinstalling them, and had to 'restart' (restore) windows because it ruined something in my registry.
    I do not wish to mess with the registry again, not have to fully clean install windows, as I wouldn't have my computer for an extended period of time besides having to backup or lose data.
    I have tried the newest drivers provided by the windows updater, as well as MSI's older windows 8 drivers, for the adapter. I have tried resetting my IP address through c-prompt. I have tried disabling IPV6, as well as a few other settings. None seem to fix my ethernet adapter. There is a permissions issue regarding these registry keys that will not allow my troubleshooter to fix them.
    I am hoping that after more than a month Microsoft will patch this issue, but I am starting to doubt it.
     
  2. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,841
    Likes Received:
    1,568
    I know this driver can be affected by installed security.
    When removing or installing it's recommended that all security is disabled. Try disabling your security when removing the currently installed driver and then install the version available from the lappies website (laptop drivers are almost exclusively supplied by the manufacturer apart from some gpu drivers). Double check each time you remove and install that security is disabled. I know from experience that it can really be affected and the error given when troubleshooting is 'one or more network protocols are missing on this computer' which sounds pretty similar to the issue your getting. Anyhow give it a try you never know. Here's your driver page:
    MSI Global | Notebook - The best gaming notebook provider

    Oh and when you re-install the driver, right click it and run as administrator.
     

Share This Page

Loading...