Local network only- Cannot access router. Tomato firmware?

Discussion in 'Windows 7 Networking' started by BNCole, Feb 19, 2009.

  1. BNCole

    BNCole New Member

    Joined:
    Feb 19, 2009
    Messages:
    6
    Likes Received:
    0
    Hey guys,

    I'm using a dual boot machine with windows xp / windows 7.

    I just loaded up windows 7 and am having serious networking problems. It is displaying "local connection only," and failing to connect to the internet. Windows is detecting my adapter fine.

    When I did network diagnostics it said "invalid IP configuration in local area connection".

    At that point i found my adapter and adjusted the IP 4 settings to my router settings,

    ip-192.168.1.160
    sub- 255.255.255.0
    gateway- 192.168.1.1

    I ran the diagnostics again and it said "invalid gateway". This are the exact setting i use under my XP install.

    I'm using linksys wrt54GS with TOMATO FIRMWARE 1.23.

    Unforunately I think the tomato firmware may be the cause... but I am hoping otherwise. Has anyone ran into any similar problems and does anyone have any fixes?

    And yes, I've tried the small stuff like resetting the router. I even just updated the tomato firmware.



    Any help would be greatly appreciated!

    Thanks!

    -Bryan
     
  2. jimbo45

    jimbo45 New Member

    Joined:
    Jan 20, 2009
    Messages:
    1,208
    Likes Received:
    41
    Hi there
    1) Any reason not to use DHCP -- set the network properties to Get IP and DNS automatically.
    2) If XP works fine then it's not the firmware -- very rarely is the firmware at fault unless you have a really OLD router.
    3) are you running 32 or 64 bit version of W7. Some network cards won't work properly with 64 Bit W7 even though the drivers load OK and no error shows in the Hardware manager.

    In general if the XP version works then the 32 bit version of W7 should be fine as well.

    cheers
    jimbo
     
  3. BNCole

    BNCole New Member

    Joined:
    Feb 19, 2009
    Messages:
    6
    Likes Received:
    0
    hey.


    I switched it back to DHCP. It is not connecting. It gives me local connection only. I can immediately switch back to winxp 32 and gain internet access.

    I am running windows 7 32 bit.

    I also just installed new drivers for the network card, it is onboard nforce 430. I used windows vista 32 bit drivers. Is this correct? Also, before i just updated, i was using the drivers that were auto detected with windows 7.


    Still no go.

    *grumble*
     
  4. jimbo45

    jimbo45 New Member

    Joined:
    Jan 20, 2009
    Messages:
    1,208
    Likes Received:
    41
    Hi there
    It's still then a W7 problem -- not a hardware one per se. You could try looking for "yet more firmware" although I doubt if that will fix the problem.

    There are some issues with various Router / Network card combinations --some may be caused by the gradual adoption of IPV6 instead of IPV4 others --simply that the hardware / software mix is incompatable.

    You might have more luck connecting a wireless card to your PC.

    I've got a similar problem with a VIA Velocity family ethernet card -- this just won't work on ANY Windows 64 bit OS even though windows says driver is fine etc etc. (Open Suse 11.1 64 bit Linux works fine however !!). Works fine on the 32 bit OS'es however.

    I've also found as a get around a cheap USB===>LAN device works fine as well as a PCI express card (on Local LAN gives 1000 mb 10X faster than current network card assuming your router can handle it).

    BTW these fast cards won't make any difference to the Internet speed --that's still controlled by your ISP / Cable provider).

    I think you'll just have to try another network / router combination -- but unfortunately there isn't any definitive list yet as to what combination works and what doesn't.

    For me the most important thing on a Laptop is that WIRELESS works --so far I've been lucky - including W7 x-64.

    On a 32 Bit OS you could perhaps try installing the XP driver "in compatability mode".

    Also another solution is to do an upgrade from XP==>Vista>W7. This should take care of most driver problems.

    If your VISTA 32 bit system works then just upgrade from there.

    (For XP HOME ==> W7 you can upgrade via VISTA HOME PREMIUM or ULTIMATE, if you have XP PRO then you have to use VISTA ULTIMATE to perform the upgrade -- don't activate the VISTA after the upgrade --just do a windows update and then upgrade directly to W7).

    Bit of a pain but this IS Beta testing and to get stuff to work you sometimes have to do "strange tricks and a bit of poodlefakery".


    Cheers
    jimbo
     
    #4 jimbo45, Feb 19, 2009
    Last edited: Feb 19, 2009
  5. BNCole

    BNCole New Member

    Joined:
    Feb 19, 2009
    Messages:
    6
    Likes Received:
    0
    Thanks :)

    I'll probably do that, picking up a 10-15$ card is probably way easier then trying to find some crazy workaround involving regedits and things that probably won't help!
     

Share This Page

Loading...