Lost all my network adapters - network icon is X'ed out but still online

Discussion in 'Windows 7 Networking' started by merk, Apr 7, 2010.

  1. merk

    merk Honorable Member

    Joined:
    Aug 11, 2009
    Messages:
    88
    Likes Received:
    1
    Windows 7 x64 - little backstory to explain how i got here...

    This was a vista machine that i upgraded to Windows 7. Everything worked after the upgrade except for hamachi (version 1). I did a reinstall of that and it fixed it, except i had 2 hamachi network interfaces listed in device manager, one of which was showing up as broken (yellow exclamation mark). Since everything was working i left it alone.

    Fast forward to today - i tried to upgrade hamachi to hamachi 2. Seemed to work ok but i couldn't connect to any peers. Looking into it it said the hamachi adapter was faulty and looking at my network connections there was no hamachi adapter listed.

    I opened device manager and there was just one hamachi nic listed and it was the broken one. I selected uninstall - checked the box to remove the driver and it uninstalled.

    I then manually installed another instance of the hamachi network adapter. Hamachi still cant connect to peers - same error msg about the network adapter.

    Only now, ALL of my network adapters are missing in the network connections folder. And the network status icon in the status tray is showing a red X as though it's not connected, even though this PC is online (i'm connecting to it through RDP).

    I've already tried rebooting - no effect. So any ideas where all my network connections/adapters went and how to get this all sorted?

    One more piece of info - if i right click on the network icon in the status tray and select troubleshoot, having another problem, specific adapter - on that screen it then lists 3 network adapters. Tried letting it diagnose all of them but no effect.

    And if i open the network connections folder and go to help, advanced options, i get an 'unexpected error'
     
  2. merk

    merk Honorable Member

    Joined:
    Aug 11, 2009
    Messages:
    88
    Likes Received:
    1
    So as a test i re-enabled the onboard NIC from the mobo. After re-enabling it, device manager indicated it was working. I then tried uninstalling it completely, including checking the option to uninstall drivers.

    I downloaded the latest drivers and tried reinstalling the NIC after a reboot - now windows is saying it's not working.

    So i'm really hesitant to uninstall the other NIC since i'm worried it too will also show up as not working and then i'll be screwed.

    Anyone have any suggestions?
     
  3. qazdawg

    qazdawg New Member

    Joined:
    Apr 23, 2010
    Messages:
    26
    Likes Received:
    2
    I have 2 suggestions.

    1. Go to network adapters in network and charing center and if you have LAN and a Wireless one, message me and ill guide you from there.
    2.AFTER trying the first one, if they are not there then put all your files on a disk or flash drive and then re-format your computer. <---LAST RESORT
    -ChriS, ComputeR WiZ In TraininG
     
  4. merk

    merk Honorable Member

    Joined:
    Aug 11, 2009
    Messages:
    88
    Likes Received:
    1
    Like i said - there's nothing in the nothing in the network connections - none of the adapters show up. (not using wireless).

    And i think i'll hold off on reformatting the whole pc just for this issue. There has to be a way to fix this.

    thanks
     
  5. qazdawg

    qazdawg New Member

    Joined:
    Apr 23, 2010
    Messages:
    26
    Likes Received:
    2
    Are they gone from your network and sharing center - adapter settings folder
    or are you talking about the Network folder?
    -ChriS, ComputeR WiZ In TraininG
     
  6. merk

    merk Honorable Member

    Joined:
    Aug 11, 2009
    Messages:
    88
    Likes Received:
    1
    I right click on the network icon and select network and sharing center, i then click on change adapter settings - and that screen is completely blank. And again - my network connection is so far working fine even though that screen makes it look like i have no network adapters.
     
  7. roblem

    roblem New Member

    Joined:
    Aug 17, 2010
    Messages:
    16
    Likes Received:
    2
    I have exactly the same issue. If I click on "Change adapter settings" in the "Network and Sharing center" nothing shows up.

    THe little network icon in the system tray shows an X. I have both a wirelss network adaptor and built in 10/100 adapter. They both work and get ip addresses and allow for websurfing.

    Howerver I cant configure any part of it.
    The issue started sometime around either installing (or uninstalling) whippein or hamachi2

    I have tried to uninstall everything and reinstall, but when I tried that I totally lost all network conectivity - that forced a system restore. (thank god for that feature)..

    I have found some guides that suggest flushing different things, but to date still have "no network adapeters"


    HELP!!!

    very frustrating

    Rob
     
  8. merk

    merk Honorable Member

    Joined:
    Aug 11, 2009
    Messages:
    88
    Likes Received:
    1
    i fixed this problem, but the fix isn't pretty.

    I was on the phone with ms tech support for several hours trying to resolve this. Their solution was to do an inplace upgrade - basically reinstall windows on top of itself. Seems like a completely ridiculous solution since there must be some way to reset the network settings. but thats what i eventually had to do to resolve it.

    The downside - it took several hours for the inplace upgrade to complete. The upside was i didn't really need to reinstall much of anything after it was done.

    So when you get fed up enough with this problem, i'd pop the windows 7 install disc in and do the upgrade and go take a nap for a few hours.
     
  9. roblem

    roblem New Member

    Joined:
    Aug 17, 2010
    Messages:
    16
    Likes Received:
    2
    Merc, thanks for that suggestion. I will give it a go and reply to the thread.

    It is amazing what i have tried so far. (most comming from one or another technet/microsoft site/forum) None of it has helped. I have had to do atleast 2 system restores. One "fix" i tried had me change a service's start up account, when then wouldn't start as "other services" that were part of it's group didn't use the same account (but the process wouldnt tell me which those services were.....)

    An inplace upgrade will most likley take much less time than i have already invested.!

    Rob
     
  10. roblem

    roblem New Member

    Joined:
    Aug 17, 2010
    Messages:
    16
    Likes Received:
    2
    wouldn't you believe it.. IT still didn't work :) I even did an inplace upgrade from windows home premium to windiow ultimate.


    ARGH!!! - back to hacking the registry (maybe) - and system restores (probably)

    I have started (yesterday) performing steps outlined in kb825826 - didn't get to the part where I deleted a subnode from a registery key yet, but i think that is the next.

    Good luck anyone else with this issue (report if you have success - and what you did - it might allow someone else to keep their hair!)
     
  11. TorrentG

    TorrentG Banned

    Joined:
    May 31, 2010
    Messages:
    7,814
    Likes Received:
    372
    Here ya go man.

    Open an elevated command prompt. Copy/paste these commands one at a time then hit enter after each. Reboot.
    Code:
    netsh int ip reset c:\resetlog.txt
    
    Code:
    netsh winsock reset
     
  12. roblem

    roblem New Member

    Joined:
    Aug 17, 2010
    Messages:
    16
    Likes Received:
    2
    Same.. :(

    Any other thoughts are more than welcome!!!
     
  13. roblem

    roblem New Member

    Joined:
    Aug 17, 2010
    Messages:
    16
    Likes Received:
    2
    I still have the Red X - but now I can actually see (and configure) my network adapters!!!


    solution (from KB-825826) advanced options..
    1. Click Start, click Run, type regedit, and then press ENTER.
    2. Locate and then click the following registry subkey: HKEY_LOCAL-MACHINE\SYSTEM\CurrentControlSet\Control\Network
    3. Right-click this subkey, click Export, and then save the selected branch in a file.
    4. Click the Network subkey again, and then delete the Config entry. Do not delete the Network subkey. The Config entry will be reconstructed when you restart the computer.
    5. Restart the computer. You may have to manually turn off the computer.
     
  14. roblem

    roblem New Member

    Joined:
    Aug 17, 2010
    Messages:
    16
    Likes Received:
    2
    hahaha rotflmao -> now ie 8 won't stay running :) thank god for firefox etc..

    wtf
     
  15. roblem

    roblem New Member

    Joined:
    Aug 17, 2010
    Messages:
    16
    Likes Received:
    2
    It just gets better :)

    IE wont start, Right Click My Computer ->Properties ->Error
    System Restore only has a single restore point. (hoping using it will show more - or atleast give me back ie and computer properties etc..)

    (but I can configure my network adaptors and the red x has gone..)
    I have even uninstalled and reinstalled ie8 (remove windows components) - but that didn't help.
    ................................................................
    Now at 5 hrs today.
     
    #15 roblem, Aug 18, 2010
    Last edited: Aug 18, 2010
  16. roblem

    roblem New Member

    Joined:
    Aug 17, 2010
    Messages:
    16
    Likes Received:
    2
    Ok.. Things I have learned. (and i do have it working)

    1. Always make a restore point before you start something like this. I believe the inplace upgrade that I performed earlier removed the last few days (months) of restore points. Fortunately I had uninstalled something after the upgrade, so there was a restore point to go back to, that did allow me to do a system restore to earlier today when alot of things were working..

    2. Be happy with what you have.. even if it isnt perfect, it might be better than what you get. (good life lesson for all sorts of things - including your job - life parter etc..)

    3. After you do something like this - test your system tools and needed applications - dont assume that because you have fixed one thing - everything else is working also. (if it takes weeks to notice something, putting it back might be impossible.)

    Currently (and i will need to reboot again just to make sure..) I have IE, Properties for my computer and I can configure Network Adaptors - I still have a red X - but who cares about that.

    ------------------------WORKING---------------------------------------
    After the system restore I went back and performed the deletion of the reg key again. This time it doesn't seem to have backfired.
    -----------------------------------------------------------------------

    Again - backup registrys - create system restore points and check everything.
    (second reboot seems to be a total success - x is gone - ie starts - network adapters are back!!)

    phew
     
    #16 roblem, Aug 18, 2010
    Last edited: Aug 18, 2010
    Trouble and (deleted member) like this.
  17. jpintado

    jpintado New Member

    Joined:
    Dec 28, 2010
    Messages:
    2
    Likes Received:
    0
    This worked for me.

    Thanks.
     

Share This Page

Loading...