microsoft edge won't open

rogerdc

Well-Known Member
when i click the edge icon the edge screen opens for just a second and goes away. is there a fix for this ?
i read the post by DavidESP but was unable to follow what he did to solve the prob. has there been any recent updates to address this ?
 

davehc

Essential Member
Premium Supporter
There was oine there that seemed successful. You tried it? Delete:

C:\Users\Username\AppData\Local\Packages\Microsoft.MicrosoftEdge_8wekyb3d8bbwe\AC\MicrosoftEdge\User\Default
and log off or reboot.

Otherwise, I read this on the Technet pages:

open a command prompt (Admin)
Copy and paste:

DISM.exe /Online /Cleanup-image/Scanhealth

then, when it has finished:
DISM.exe /Online /Cleanup-image/Restorehealth
 

Radu

New Member
Hi Guys,

You got blue screen with logo when opening edge and than suddenly crash? The fixing is very simple:
Disconect your laptop/desktop from any internet conection (cable or wi fi or others) and than start edge. You will get a message you are not connected to the internet. Close the edge windows, reconnect to internet and start edge again. Voila!

good luck
 

Neemobeer

Cloud Security Engineer
Staff member
  • Navigate to %LOCALAPPDATA%\Packages
  • Append .old to the Microsoft.MicrosoftEdge_8wekyb3d8bbwe folder
  • Press the Window key and type powershell, right click and select Run As Administrator
  • Type the following command
  • Code:
    Get-AppxPackage *Edge* | Foreach { "$($_.InstallLocation)\Appxmanifest.xml" | Add-AppxPackage -Register -DisableDevelopMode }
 

diverG

Honorable Member
Thanks for all the suggestions, unfortunately non work.

W10 is a clean install from around last September. I have images taken after this install and another prior to the major update last November. If I restore the original image both network & edge work.

Between the original install and the November image an update caused the network connection to be erratic (depending upon which machine was switched on first) but Edge was still available but not used daily.

After the November update all network connections functioned correctly but I doubt Edge was checked as I like the ‘favourites’ options in Firefox & IE and which were not available in edge last time I checked (Nov 2015)

As W10 is working well then I will manage without it. Just a great pity it cannot be uninstalled.

PS. Prior to a W10 clean install a W7 to W10 was made. This ‘upgrade’ installation still functions correctly with Edge so I guess my best option is to simply carry on without Edge using the clean install.

Again thanks for all the suggestions they are appreciated.
 
Top