Network Printer Error

Discussion in 'Windows 7 Networking' started by Caronbot, Apr 14, 2015.

  1. Caronbot

    Caronbot New Member

    Joined:
    Apr 14, 2015
    Messages:
    2
    Likes Received:
    0
    Hello! (first post woo)

    I have a small business network setup with two networked printers on separate floors. My problem is that there is a single laptop which cannot print to the networked printers.

    Every end user in the business uses a lenovo laptop, and all laptops are connected through ethernet. This particular laptop does not have connectivity issues with the network, and can print just fine to USB printers connected to it.

    I have tried completely removing all printers from the laptop, and then reinstalling them. They install and configure snappy and with no problems. I have investigated the spooler and it is working just fine. I have tried downloading and installing drivers directly--the printer is recognized and drivers are installed with no problems, but I still cannot get it to print.

    Test pages go to queue and disappear but do not print. Other jobs hang in the queue forever. There is no difference in configuration or setup of this laptop to any other on the network, and it used to be able to print. I started at this position just about a month ago, and the issues apparently started a week before I started at the job--so unfortunately I don't have a specific change that took place.

    Any suggestions?
     
  2. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Hello and welcome to the forum.
    I had this problem once and believe it or not I had the wrong IP address for the printer port and the job was actually going to another printer on another floor in the building.
    It never produces an error at all??

    Is there anything unique about this particular computer? Does it have a security suite that is not present on other computers? Does it have any other software packages like LogMeIn, Citrix, some type of network manager that the other computers do not have?
    Does the printer have a static IP address? If not then perhaps you might want to set that up.
    My suggestion would be to create a new standard IP port on the computer (using a the manually assigned, static IP address of the printer(s), making sure that there are no conflicts with other IP addresses on the subnet).
    IF the computer is not having any problem installing drivers or printing to USB printers when attached, then there is not likely any problem with the print process or spooler service on the computer and it's down to the network or some third party rogue software, process or service that is likely causing the problem.

    You might want to try a clean boot of the system https://support.microsoft.com/en-us/kb/929135 just to see if it might be associated with third party products.
    Good luck and keep us posted.
     
  3. Caronbot

    Caronbot New Member

    Joined:
    Apr 14, 2015
    Messages:
    2
    Likes Received:
    0
    Thank you for the quick response!

    No it did not produce an error, which was what was making it such a headache to troubleshoot.

    The printer has a static IP, and when I would view the configuration settings on it it was in fact sending jobs to the correct printer's IP address.

    HOWEVER! Your suggestion worked :) Manually creating the IP Port did the trick. It's weird in that all the configurations seem to be the same in properties, but this way works. Thanks a lot.
     
  4. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Good to hear that you've managed to resolve your issue and thanks for posting back and updating your thread with that information.
    I've noticed before, that on some occasions when installing a network printer on a Windows machine that the generic network port installed by the native "network printer installation wizard" is not always optimal and that sometimes installing your own Standard IP Port on the machine to use for the network printer often times will resolve the issue.

    Thanks for taking the time to join our community and we hope to continue to see you around.
     
    Caronbot likes this.

Share This Page

Loading...