No access to directory

PaulSp

Member
I have run into an interesting situation. I have a directory that I cannot do anything with always receiving an "access denied" response. Going into the security tab of properties gives me the message "You must have read permissions to view the properties of this object". Then "click advanced to continue". Clicking the advanced tab yields a window which says "unable to display the current owner". Below it says again "You must have read permissions to view the properties of this object". There is a "Change" option to its right as if I could possibly change the owner. When I click on the "change" it again says "you do not have permissions to view the properties of this object". I've tried to go into the command prompt to add read permissions to the directory but to no avail. So I have a directory which I, as an administrator, cannot manipulate.
 

Neemobeer

Windows Forum Team
Staff member
You need to first open an elevated command prompt, right click 'Command Prompt' and select 'Run as Administrator', then you can take ownership and grant access

takeown /F C:\americascardroom\handHistory /A
then grant yourself access
icals C:\americascardroom\handHistory /grant <username>:f
 

PaulSp

Member
No it was not a hidden directory. I tried to delete it yesterday and of course couldn't. Now I've deleted the americascardroom directory so everything is good. I just don't know what happened to make handhistory disappear. As you can see, it existed as of 12:06 AM. I don't believe I've rebooted since then. I just put the computer to sleep. Perhaps some process had it accessed? I don't know. It's a mystery :rolleyes:

What is the icals command? I typed icals /? and my computer didn't recognize the command.
 
Top