No Connection to LAN?!

Rainer Bielefeld

Honorable Member
A Friend works in a club office. His WIN7-PC was connected to local network and Internet with an USB-WLAN-Stick to a Fritz!Box. Always worked fine, until some day WLAN connection got lost. I tried to help and checked:
  1. Something wrong with the USB-WLAN-Stick? No control light on the stick, suspicious extension cable, ... I tried Stick directly at the USB Port, we had contorl light, but noWLAN connection 😥
  2. We tried a different USB-WLAN-Stick. Nothing doing, did not work. 😥
    Stick Worked perfectly with my WIN10-Laptop
  3. I disabled Firewall: no progress 😥
  4. We tried Cable LAN connection (which worked perfectly with my WIN10 Laptop): no connection. 😥
  5. I checked LAN adapter: all I saw on screen looked perfect, it was active, ...
No I am a little stumped.

Any ideas concerning possible roots for a complete networking loss? Or what I should check additionally?

CU

Rainer
 

Neemobeer

Windows Forum Team
Staff member
Run this script on the computer "Run as Administrator" when the problem is back and upload the results.

 

Rainer Bielefeld

Honorable Member
Hi, attached you will find 3 test results from affected PC.
1 from yesterday, without USB-WLAN-Stick and without LAN cableconnection.
2 from today, one with cable only and one with USB-WLAN only, see file names.

Strange thing: comparedto by test 3 weeks ago no calble LAN connection worked fine, internal Net and WWW available.
Anything in the results which cna explain wy Stick works at my laptop, but not at affected PC?

CU

Rainer
 

Attachments

  • 2020-08-27_01network_information_WithoutLANcableWithoutStick.txt
    9.5 KB · Views: 14
  • 2020-08-28_01network_information_WithLANcableWithoutStick.txt
    11.5 KB · Views: 12
  • 2020-08-28_02network_informationWithoutLANcableWithStick.txt
    10.1 KB · Views: 13

Neemobeer

Windows Forum Team
Staff member
Yeah there is a glaring problem. Might require some more digging.
In the WithoutLANWithStick under the ARP cache the default gateway says Invalid.

Within a LAN devices communicate at layer 2 (MAC) since it doesn't have a valid MAC for the gateway it won't be able to communicate to the gateway which would also mean it can't get outside the LAN which would include the Internet.

From an elevated command prompt you can try deleting the cache entry with
arp -d 192.168.178.1
It should repopulate on it's own

The other workaround is figure the MAC for the gateway and set it statically
arp -s 192.168.178.1 00-11-22-33-44-55 (replace the end with the real MAC)

Double checking the WithStick I also don't see the USB wireless listed at all although I don't exactly speak german. Can you double check that the usb WLAN card is properly detected and look in device manager to see if there are any yellow ! or red X on the device.
 

Rainer Bielefeld

Honorable Member
Both tricks failed. For one of the 2 WLAN Sticks we tested it was not possible to find a driver, the other one fails without any visible reason.

We decided to switch to Powerline WLAN.

Thx for Help

Rainer
 
Top