problems with my Epson Stylus Office BX300F all in one printer since upgrading from win 8pro

#1
I I`m having problems with my Epson Stylus Office BX300F all in one printer since upgrading from win 8pro to win 8.1pro it says Check all connections and make sure all devices are on. To cancel printing, click the [Cancel] button. It does not now display ink levels either. I do believe that it is down to driver update which I have subsequently done but does not make any difference, still same display. Having said that the Scanner part is recognized and works fine, just not the printer side of things. I would also like to add that when I initially installed windows 8pro some time ago I went to driver upgrade and it said not compatible with windows 8 but gave me option to continue anyway and press run which I did and from there on the printer worked fine with win 8 pro. But I am afraid not so with win 8.1pro. As this is a perfectly good printer that has never given me any trouble and only 4 years old approx. I do not want to discard and purchase new one. Can anyone give me a solution too this Problem please. WM
 


Trouble

Noob Whisperer
#2
Check here.
Select your operating system from the drop down list (Windows 8 32 or 64 bit). I would expect those drivers to work.
If not perhaps use the Windows Update feature while installing the printer and see what might come your way from there.
 


#3
Check here.
Select your operating system from the drop down list (Windows 8 32 or 64 bit). I would expect those drivers to work.
If not perhaps use the Windows Update feature while installing the printer and see what might come your way from there.
Tried both already sorry no good but thanks anyway
 


#4
Check here.
Select your operating system from the drop down list (Windows 8 32 or 64 bit). I would expect those drivers to work.
If not perhaps use the Windows Update feature while installing the printer and see what might come your way from there.
I have since uninstalled all Epson drivers and then used the windows feature again and it has worked first time many thanks for the advice .All the best. WM
 


Trouble

Noob Whisperer
#5
Very glad to hear you managed to sort it all out. Thanks for posting back and updating your thread with your solution. Much appreciated.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.