Really Strange Mouse Issues

Discussion in 'Windows 7 Help and Support' started by George Ramsey, Mar 10, 2013.

  1. George Ramsey

    George Ramsey New Member

    Joined:
    Mar 10, 2013
    Messages:
    8
    Likes Received:
    0
    I've been working on this for weeks so shall try to make it succinct.

    System: Lenovo laptop, Windows 7 64 bit, Logitech wireless mouse; no changes of any kind since weeks before problem started

    Problem: wireless mouse acts very strangely. Cannot use (at random - sometimes it works) Windows minimize/resize/close buttons. Nothing happens when you click on them. BUT if you open TaskManager - just open it, not do anything with it - then close it, mouse will work for several clicks. Then you start all over again. I also cannot move down through menuboxes except with arrow keys. If a pop-up box opens with options like OK, Cancel, Save, etc., you cannot access any of the buttons with the mouse without the whole 'open TaskManager' routine. I do a lot of work on my laptop, so this is really chewing up time while I'm trying to get work done, besides being absolutely infuriating by this time.

    Steps I have taken:
    1) Tried different brand wireless and wired mice - no change
    2) Ran all the normal tools: defrag, scandisk, antivirus (malwarebytes, Avira)
    3) Paid tech to clean registry, run more malware cleaners, etc., and anything else he could think of - no change
    4) Uninstalled almost everything not directly needed for work (I mostly just use LibreOffice pro suite) - no change

    I am completely stumped at this point. Thank you for your time with this lengthy post.
    George
     
  2. Twinnii

    Twinnii Well-Known Member

    Joined:
    Aug 10, 2012
    Messages:
    107
    Likes Received:
    0
    I would make sure keys aren't being pressed. One other thing is to go to device manager by right clicking on Computer, properties, Device manager, find the mouse and uninstall it there as long as it has something to do with Logitech and also uninstall Logitech software or drivers.
    Try just using the lapotp's touchpad and make sure there isn't any incompatibilities with it. See if things work with just generic Lenovo mouse pad.
    See what happens, then make sure you are only isntalling WIN7 64 bit driver if available. BTW, please put model number of wireless mouse. Is it possible that there is bluetooth interference?
     
  3. George Ramsey

    George Ramsey New Member

    Joined:
    Mar 10, 2013
    Messages:
    8
    Likes Received:
    0
    Thanks so much for your reply. I have tried Microsoft and Dell mice, both wired and wireless, and have the same issues. The touchpad is working. The model number of the mouse is Logitech M310, but at the moment I'm using a Microsoft mouse with the same problems I mentioned above.
     
  4. Twinnii

    Twinnii Well-Known Member

    Joined:
    Aug 10, 2012
    Messages:
    107
    Likes Received:
    0
  5. George Ramsey

    George Ramsey New Member

    Joined:
    Mar 10, 2013
    Messages:
    8
    Likes Received:
    0
    Thank you for your help. The thing is, it doesn't matter what brand mouse I'm running: Microsoft, Logitech, and Dell are three I have tried. I have uninstalled all of them, plus any 'extras' they install in auto updates. I installed a couple of optional Windows updates for mice and keyboards, and that seemed to help a little, but after a couple of hours it was back to same old - same old.
     
  6. Twinnii

    Twinnii Well-Known Member

    Joined:
    Aug 10, 2012
    Messages:
    107
    Likes Received:
    0
    Ok, then I would suggest disabling the touchpad on your laptop to see if it's actually going bad and leave your wireless mouse settings as is. I think it's sensing a false touch possibly.
     
  7. George Ramsey

    George Ramsey New Member

    Joined:
    Mar 10, 2013
    Messages:
    8
    Likes Received:
    0
    That did seem to help! I'm still having some problems (using the mouse in drop-down menus, for one) but I'm not having to open TaskManager to open and close windows and dialog boxes. Thanks so much - I can live with the situation now, and I guess just hope that a Windows update eventually fixes it?
     

Share This Page

Loading...