Remote Desktop Issues (Blocked Ports?)

Discussion in 'Windows 8 Help and Support' started by Xavier Lin, Jan 27, 2015.

  1. Xavier Lin

    Xavier Lin Member

    Joined:
    Jan 27, 2015
    Messages:
    2
    Likes Received:
    0
    Hi everyone, I encountered a weird problem while connecting to a PC with rdp.
    I have a Windows 8.1 PC (say its public IP address is a.b.c.d), but recently it somehow got wrong that I can ONLY connect to this PC on the same domain, i.e. a.b.xxx.xxx. It worked fine before (I can do rdp connection to this PC anyplaces). I'm sure that I've turned off firewall and anti-virus software.

    And I tried something like:
    (1) Change the default rdp port from 3389 to 13389
    (2) Change PC's IP (Change to a.b.c.e for example)
    (3) Use a notebook and set its IP to a.b.c.d and try to connect to the notebook.
    The result is I can connect to the PC on either (1) or (2) but failed to connect to the notebook on (3).

    Accordingly, I doubted that "whether the port 3389 of the IP a.b.c.d is got blocked?"

    So next I tried using WireShark to capture some packets and got the results as follows:
    (I changed the rdp port to 13389)

    [​IMG]
    Fig.1: The situation I can connect to the computer
    (Scenario: Try to connect to the computer -> prompt a window to enter user/pwd -> close the window)

    [​IMG]
    Fig.2: The situation I CANNOT connect to the computer
    (Scenario: Try to connect to the computer -> prompt a window with error messages)

    As a result, we can see that both situation the packets are sent to the computer with corresponding ACK packets. So the port 13389 is NOT blocked? OK, then... can anyone tell me why I can't connect to the PC? Why the [RST, ACK] packet is sent immediately after I request a rdp connection?

    P.S. For situation 2, after I got problem with port 3389, I changed the rdp port to 13389 and it worked fine without any problmes. But after some days it again got blocked... So now both 3389 and 13389 are blocked.

    Thans a lot for your help!!
     
  2. bassfisher6522

    bassfisher6522 Essential Member

    Joined:
    Aug 27, 2008
    Messages:
    4,884
    Likes Received:
    318
    MS has convoluted the RDP so much so that it's a PITA to use for me personally. I just use Teamviewer for any off site access I may need to help some one with.
     
  3. ussnorway

    ussnorway Windows Forum Team
    Staff Member Premium Supporter

    Joined:
    May 22, 2012
    Messages:
    2,540
    Likes Received:
    318
    Sounds to me like your service provider is “helpfully” blocking ports… the test is only useful if:

    1. Test rdp works on a new port… if yes do step 2.

    2. When new port starts being blocked… test laptop can still rdp into your system from within the network I.e. from a wifi/ cable to your poe router and into your system without trying to leave the localized network under your control.

    If the connection now works then obviously the blockage is downstream at your buildings firewall proxy or your service provider.

    Off topic: Microsoft is driving the process of scrapping the old remote desktop protocols and remote management is replacing much of yesterday’s network traffic… how much time you have will depend greatly on the country you live in as not everywhere will rush out to replace the way their cable network is organized but the days of old rdp are numbered.
     
  4. Xavier Lin

    Xavier Lin Member

    Joined:
    Jan 27, 2015
    Messages:
    2
    Likes Received:
    0
    Thank you all very much!!
    My department's network administrators somehow locked the port (caused by QoS...) and now it's solved.
     

Share This Page

Loading...