Windows 10 [SOLVED] On-board audio driver problem with UEFI

Pwntus

New Member
Hello!
I hope someone will take a look and help me with my problem as I cannot figure out it by myself.

Background
Upgraded Win7 to Win10 (64bit, build 10586.63).
Sound was working on Win7 with my headphones.
I also dual-boot Ubuntu and I can use my headphones there so I know it's not a hardware problem.


Problem
My on-board audio is not recognized in Win10 when I plug in my headphones (with built in mic).

My playback devices looks as following:


My device manager reports that I'm using a AMD High Definition Audio Device:



Hardware
  • Motherboard: GIGABYTE GA-X79-UD3
  • Graphics card: Asus HD 7950 Direct CU II

Own thoughts
To me it looks like Win10 tries to get audio from my monitors (and through the graphics card) when in fact I want to use my on-board audio device.
I've tried to install the Realtek High Definition Audio Codecs with no success.
It seems like there's a conflict between the graphics card and on-board audio whereas I try to use the on-board it gets switched back to using the graphics card.
I've also tried to plug in my headphones in the rear and front audio jacks.


Thank you for taking your time and tell me if you need more info to help a fella out!
 
Last edited:

kemical

Windows Forum Admin
Staff member
Premium Supporter
Hi,
have you tried disabling HDMI audio either on the card or in the control panel?
 

Pwntus

New Member
Hi and thank you for the reply,
I disabled every HDMI audio device in the device manager and I even unplugged my monitor that was connected with a HDMI cable.
I then proceeded with installing the Realtek High Definition Audio Codecs.
I can now see that there is no audio device connected.

It also looks to me as if the Realtek driver isn't installed correctly because it won't start and I can't find any Realtek-control program in the control panel. Also, as you can see, the Windows troubleshooter wants me to enable the AMD High Definition Audio Device as previously (I actually uninstalled this driver but it got installed again automagically).



My goals is to use the on-board audio device and not the AMD device, I do not use any separate audio card.
 
Last edited:

kemical

Windows Forum Admin
Staff member
Premium Supporter
Try using this driver from your motherboard support page:
w10.JPG

GIGABYTE - Motherboard - Socket 2011 - GA-X79-UD3 (rev. 1.1)

When you install it make sure your headset is removed and just your speakers are plugged in, also when installing the driver right click the start up icon and run as administrator. After the reboot go to your control panel and open Sound/Manage Audio devices and hopefully you'll see something like this:
sound.JPG
 

Pwntus

New Member
I do not use any speakers, I only use headphones.

I installed the recommended Realtek driver from Gigabyte and did a reboot (with headphones unconnected), still no success.
If I keep fiddling around with the device drivers (by uninstalling and installing Realtek) the generic Windows audio drivers or the AMD audio drivers will get installed automatically.

When I finally get the Realtek audio driver as the only one installed, it won't start and fails to reinstall.


Thank you for your time!

Edit: I've double-checked that the Integrated Peripherals-section in BIOS has audio device enabled, and as stated earlier I can use my headphones just fine when booting into Ubuntu. I'm starting to think this is a bug in Windows 10.
 
Last edited:

bochane

Extraordinary Member
But a headphone is not Digital, it is Analogue like a speaker, is not it?
And I don't see an analogue output device. What is below device 5?
 

Pwntus

New Member
bochane: that's right and that's part of my problem, I cannot get my analogue output device on my motherboard recognized by Windows 10. It only wants to show me HDMI devices from my graphics card.
Below device 5 is device 6 which is identical to the other ones, no speaker and/or headphone devices.
 

kemical

Windows Forum Admin
Staff member
Premium Supporter
I see, I did not read well. Have you ever tried to connect speakers and reboot.
I was thinking along the same lines Bochane but apparently Pwntus has only a headset.

Is it possible you can perhaps borrow a pair of speakers off a friend and regarding the UEFI side, if you boot into the bios and change to legacy mode (if you have the setting) then that should allow for added hardware.
 

Pwntus

New Member
Thank you bochane and kemical for your inputs, but I solved it now! :up:

Solution:
I was booting Windows 10 using UEFI firmware which is a new and better way of BIOS for devices such as tablets and phones. By using UEFI, certain on-board hardware would get ignored (in my case my on-board audio) and thus the problems I faced.

What I did: by using a tool called Rufus I created a USB installation drive and specified it to use the legacy BIOS (and not UEFI mode). After the installation my audio is back and my headphones get recognized!



I should mention that I tried enabling my audio device even if I was using UEFI mode, but there was no option for that so I did a fresh install.
Thank you for your time!

:peace:
 
Top