Windows 7 networking shouldnt be this difficult??

Discussion in 'Windows 7 Networking' started by Azim1980, Aug 20, 2013.

  1. Azim1980

    Azim1980 Member

    Joined:
    Nov 16, 2012
    Messages:
    11
    Likes Received:
    0
    ....or should it?
    It should be setting up a workgroup.
    Then enabling sharing on the folder(s)
    Then do the same on the other machines
    And there its done! Why the heck, doesnt it work???
    (might as well set up a domain to share files???)
     
  2. badrobot

    badrobot Senior Member

    Joined:
    Jun 14, 2012
    Messages:
    1,020
    Likes Received:
    102
    I had the same problem before.
    I uninstalled my Zonealarm firewall and used the native Windows Firewall. Problem solved.
    Are you setting up a homegroup with another Win 7?
     
  3. Azim1980

    Azim1980 Member

    Joined:
    Nov 16, 2012
    Messages:
    11
    Likes Received:
    0
    i'm not using homegroup and have no zonealarm installed. I'm just trying to setup a simple workgroup. It shouldnt be this awkward!
     
  4. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    It's actually not all that hard.
    You have to set permissions in the share's properties dialog box under both the sharing tab as well as the security tab, as when shares are accessed across the network share permissions are merged with NTFS (security) permissions and the most restrictive wins.... so mind your group memberships as a specific user can be granted full control, but if the "Users" group only has read then read is all he is going to get if he is a member of that group.
    Additionally when prompted for credentials you'll need to use the MachineName\Username format and tick the box that says remember credentials. Like ......
    MyWinMachine\MyUserName (MyWinMachine = The machine name hosting the share) (MyUserName = An account that exists on the machine hosting the share, that has appropriate permissions to access the share)
    Password (Password = The password word for that user, that he uses to log on to that machine that is hosting the share)

    Alternately place identical usernames and passwords on all network nodes acting as share hosts and set permissions appropriately locally and let Windows Pass Through Authentication handle the rest (you don't have to log on as those users they just need to be there for permissions sake).

    And it's not only Comodo or Zone Alarm that can cause network issues when it comes to sharing. I've done this stuff for nearly 20 years and just recently had my butt handed to me by AVG 2013. Took me close to an hour of trying everything I could think of until I finally removed AVG and like magic everything just worked again like it is suppose to. So if you are using any type of third party security suite consider removing it. At least until you have your networking issues resolved and then put it back and see what happens. Very often that's all it takes, uninstall, setup your network and make sure everything is working properly and then re-install. Some can take some more sophisticated tweaking to prevent it from interfering with Windows networking.
     
  5. badrobot

    badrobot Senior Member

    Joined:
    Jun 14, 2012
    Messages:
    1,020
    Likes Received:
    102
    I am not saying you have Zonealarm. I'm simply saying check your firewall setup.

    Do you have your Network Discovery enabled? (Click Start->Control Panel->Network and Sharing Center, click Change advanced sharing settings. Enable the option)

    I found homegroup to be much simpler to setup for network sharing. Cheers!
     

Share This Page

Loading...