Windows Update cannot check for updates

Discussion in 'Windows 7 Help and Support' started by bighex, Aug 18, 2012.

  1. bighex

    bighex New Member

    Joined:
    Aug 11, 2012
    Messages:
    12
    Likes Received:
    0
    Hello,

    I recently got some help with a BSOD problem on my machine. It appears to be solved, however Windows Update does not work. I get the message "Windows Update cannot currently check for updates because the service is not running. You may need to restart your computer." Needless to say, the restarts do not help. I also tried installing Windows Essentials for virus protection which could not receive updates. I have since uninstalled an am using Clamwin for virus protection.

    I have googled the problem and have tried numerous solutions. I am about to re-install windows but I'm hoping to avoid that process. I trust I will need to provide additional information to get any help. Please let me know what you need.

    Any help is greatly appreciated! Thank you taking the time to read this.

    Will
     
  2. Adamsappleone

    Adamsappleone U.S.Navy D.A.V.

    Joined:
    Aug 2, 2009
    Messages:
    1,662
    Likes Received:
    122
  3. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    If it says some service is not running, maybe we can find out which one. Windows depends on several, and one is Windows Update (wuauserv). Another is Background Intelligent Transfer Service (bits), which both start on a delayed Automatic start, and should be started. You can check by looking at the Services.msc panel. If one is not running we might be able to track it down.

    There are some other services involved with installing updates, like Windows Modules Installer (TrustedInstaller) that is started Manually and may not be running, but you should be able to start it.

    You might want to do a system file check in case something was deleted. Open an Administrative Command prompt window and type

    sfc /scannow

    and let it finish. If it comes back with cannot repair some files, let us know.

    If none of that helps, you might copy the WindowsUpdate.log from the Windows Folder to your desktop. Open it in notepad and copy the last 4 or 5 days of entries and paste into a .txt file. You could then zip it and attach using the paperclip. Maybe we can find something there.
     
  4. bighex

    bighex New Member

    Joined:
    Aug 11, 2012
    Messages:
    12
    Likes Received:
    0
    Thank you for your reply. I ran sfc/scannow and had no problems. I was able to start the Windows Modules Installer. I then got a new error when I tried to start windows update. Error 0x8007277a: The requested service provider could not be loaded or initialized." The Background Intelligent Transfer Service also would not start, telling me to view the system event log.

    I have attached portions of the windowsupdate.log as suggested.

    Oh, and Adamsappleone, I have tried Fixit. An error occured while downloading one or more components and could not be run.
     

    Attached Files:

    #4 bighex, Aug 19, 2012
    Last edited: Aug 19, 2012
  5. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    I will give you what I see in the log, and then I will have to do some research to try to find out what it means. Maybe someone else will know before that. But the log shows the first item and the error is shown in the second.

    I also found this:

     
    #5 Saltgrass, Aug 19, 2012
    Last edited: Aug 19, 2012
  6. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    I have been looking around, but all I can find about the network monitor might be something loaded on your system, or perhaps another system to monitor and record network traffic. Perhaps you or someone else you know might have info.

    There is a very long and detailed page about how to repair the Windows Update. You can try the fixit, if you haven't already, or open the fix it myself section and go through that. Remember you can copy text and paste into a command window by right clicking the command window to paste.

    How do I reset Windows Update components?

    But one command, which I think might be related is the netsh winsock reset command. The previous procedure states it differently and it will not run on my system if you put reset before winsock. So try this one yourself first, then restart your system. You will need to be in an Administrative command prompt window, which you can start by Winkey and type cmd then CTRL+SHIFT+Enter

    I will wait to see if any others have comments.
     
    Volsed likes this.
  7. bighex

    bighex New Member

    Joined:
    Aug 11, 2012
    Messages:
    12
    Likes Received:
    0
    I used the netsh winsock reset command. I was then able to run fixit without any problems. It resolved the update problem. Everything appears back to normal! I may try to re-install Microsoft Security Essentials now instead of Clamwin.

    I am very grateful. Thank you very much for your help Saltgrass!
     
  8. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    <:o) Glad it worked, I had no idea where to go next !!
     

Share This Page

Loading...