X1550 Drivers for Windows 7 Ultimate RC x64 cannot be sourced (or Vista x64)

Discussion in 'Windows 7 Hardware' started by CJS23, May 11, 2009.

  1. CJS23

    CJS23 New Member

    Joined:
    May 11, 2009
    Messages:
    2
    Likes Received:
    0
    Hi.

    I have a 512MB ATI Radeon X1550 PCI-E*16 GPU.

    Windows 7 x64 has automatically installed drivers for me saying I have X1600 series!

    I have tried versions 9.3 and 9.4 but both do not work.

    The error messages are pasted (badly)

    Sorry about the formatting or lack thereof - this is the error message for version 9.4 - same for 9.3
    ************
    Catalyst® Install Manager
    Installation Report
    05/11/09 22:04:37

    Hardware information NameATI Radeon Graphics ProcessorManufacturerATI Technologies IncDevice ID0x7140Vendor ID0x1002Class Code0x030000Revision ID0x00Subsystem ID0x3000Subsystem vendor ID0x1787Other hardwareExisting packages ATI Catalyst Install ManagerMicrosoft Visual C++ 2005 SP1 RedistributablePackages for install
    ATI Catalyst Install Manager Final Status:SuccessVersion of Item:3.0.719.0Size:20 MbytesATI Display Driver Final Status:FailVersion of Item:8.600.0.0000Size:90 Mbytes
    Other detected devicesVO3ÖîJŸ‚Þ T8ðÀ¬1Úç†zÌÙõåoµìG ManufacturerATI Technologies IncDevice ID0x7160Vendor ID0x1002Class Code0x038000Revision ID0x00Subsystem ID0x3001Subsystem vendor ID0x1787
    Error messagesDriver Install: the specified driver package was not installed for matching devices
    ***********

    I'm even having trouble locating Vista x64 Drivers for the X1550 - grateful for any help
     
  2. loathe

    loathe New Member

    Joined:
    Jan 16, 2009
    Messages:
    1,718
    Likes Received:
    66
    Well here are the Vista x64 drivers for X1550

    Id uninstall all the drivers you have tried so far, then try these in compatitibility mode. There is no supported Windows 7 driver on the Ati site for this chip.

    "Windows 7 x64 has automatically installed drivers for me saying I have X1600 series!"
    These didnt work?
     
  3. bernsteind1

    bernsteind1 New Member

    Joined:
    May 13, 2009
    Messages:
    2
    Likes Received:
    0
    Windows server 2008 r2

    Same problem here. only it gives no error other then a blank screen. To get by I use the generic driver :( .
     

Share This Page

Loading...