All of a sudden, constant BSODs

#1
This week I have started getting BSODs. As of yet I am unable to explain the cause, or reproduce them on demand. They simply seem to happen between 30m and 2 hours of booting my computer. At first I thought they were related to Eve Online, but I soon noticed they occur even when that program is not running.

When It starts, I'm typically not doing anything taxing on the system.
Whatever program I'm using starts to hang. The screen gets all white, the window title-bar says (not responding), and the cursor turns into the spinning blue circle. I have about 15 seconds where I can alt tab to other programs and control the mouse before the entire system freezes. After 1-5 minutes, it kicks to the blue screen. Note: about half the time, no minidump is generated, the BSOD itself freezes in one of the initializing steps. However, those minidumps that have been created are attached.

Things I have done to attempt to fix the problem:

Fixed Registry Errors with CCleaner
Updated Display drivers to current
Freed up space on my SSD, which has the OS installed on it.
Ran Windows Memmory Diagnostic Tool and memtest86+ (no errors found)
Downloaded a minidump analyzer, which pointed to some kernel process, but not sure if that's the culprit.
Read all the stickies in this subforum.

Help is appreciated. I consider myself a pretty savvy fixer, but analyzing these dump files is a bit out of my league, and I'd like some directed guidance rather than taking stabs in the dark for a month. Thanks!

Updating my BIOS seems like something I may need to consider, but I haven't felt like prying open my case (yet) to see which "revision" mine is, plus GIGABYTE doesn't provide great information on how to do this safely. Their BIOS utility that you can run in windows doesn't offer up much information. And I'd prefer not to screw everything up and make my problems worse.
 


Attachments

Last edited:
#2
UPDATE: The same crash just occurred while in safe mode with networking enabled. Once again, the BSOD screen froze on 'initializing disk for crash dump...' From what I've read here, this is a strong indicator of imminent hardware failure, yes?
 


GeneralHiningII

Honorable Member
#3
IF it crashes in safe mode then it's either a driver or hardware related problem.

Use driver verifier (verifier.exe in search bar) and leave it running.
If it causes a BSOD, then it means you've got a driver problem and we'll solve it from there.
If not, then we'll use some stress tests to determine which hardware is faulty.
 


#4
I turned on driver verifier (I'd never heard of this before). Its set to "verify all drivers installed on this computer." I am still running in safemode w/ networking. So far I've had one bluescreen, but again no minidump created. I suppose I'm waiting for another crash now? If verifier finds something to cause a crash where does it save that info?

Also, before I turned on verifier the first time, the computer failed to boot once and went to blackscreen. This was a warm restart following a successful boot. Once I rebooted (again), the system brought up the startup repair utility. After chugging for a bit, it concluded it could not correct the problem, and spat this info out at me before proceeding to boot.

ProblemEventName: StartupRepairOffline
Problem Signature 01: 6.1.7600.16385
Problem Signature 02: 6.1.7600.16385
Problem Signature 03: unknown
Problem Signature 04: 636
Problem Signature 05: AutoFailover
Problem Signature 06: 1
Problem Signature 07: NoRootCause
OS Version: 6.1.7600.2.0.0.256.1
Locale ID: 1033
 


GeneralHiningII

Honorable Member
#5
If verifiers finds something then it'll generate a minidump file, as if it caused a Blue Screen.


To answer a few things in your original post (apologies, was a bit tired when I did that):
1) How long did you run Memtest86 for?
2) Since your computer seems to be crashing during the BSOD initializing - try this: Control Panel > System and Security > System, left hand bar, Advanced System Settings > Startup and Recovery > Settings. Here, uncheck the box "Automatically restart" (if it's not already unchecked). Under "Write debugging information", change "Kernel memory dump" to "Small memory dump". Restart your computer and boot into Windows - this time, do what you usually do until the BSOD occurs (record what you're doing too).
3) Updating the BIOS could be an idea too - to find the make/model/revision/etc. of your motherboard, download and install CPU-Z - CPUID - System & hardware benchmark, monitoring, reporting . Open CPU-Z, and under the tab "Mainboard" you'll see your motherboard manufacturer, model (number and revision), chipset (number and revision) and southbridge (number and revision) information. [On the off chance that CPU-Z doesn't show these numbers, PC-Wizard - CPUID - System & hardware benchmark, monitoring, reporting should be able to. Under "Mainboard", you should be able to see all the details of your motherboard. If this still doesn't work then the only way I see it is to open up your case.]
From there, go to Gigabyte's support/driver page, find your motherboard and download (in this order):
BIOS
Chipset
SATA/RAID
Audio

UPDATE: Motherboard (GA-870A-UD3), BIOS (Award Modular BIOS v6.00PG) not sure if this will help or not
--------------------------------------------------------------------------------------------------------------------------------------------------------
Software/Hardware Problems:

One of your Network Adapters, Cisco VPN Adapter, is disabled.
Either remove the drivers and uninstall the device or enable the device.

Your USB controller drivers seem to be reporting some problem (although of which I'm not sure) -
nusb3hub.sys Fri Nov 20 21:15:57 2009 (4B066C5D)
NEC Electronics USB 3.0 Host Controller Driver (previous BSOD issues with 2010 version)
Driver Reference Table - nusb3hub.sys

nusb3xhc.sys Fri Nov 20 21:16:01 2009 (4B066C61)
NEC Electronics USB 3.0 Host Controller Driver (previous BSOD issues with 2010 version)
Driver Reference Table - nusb3xhc.sys
Follow the links and see if you can get an updated version of those drivers.

There are about 15 software errors pointing to EVE (which is, IMO, a horrible game that'll chew up half of your life just like WoW or CoD). You did mention thinking that these BSODs were related to EVE - while it's not 100% sure, try avoiding running the game for now.


You have Daemon Tools installed -
Alcohol 120% (and Daemon Tools software) are known to cause BSOD's on some Windows systems (mostly due to the sptd.sys driver, although I have seen dtsoftbus01.sys blamed on several occasions).

Please un-install the program, then use the following free tool to ensure that the troublesome sptd.sys driver is removed from your system (pick the 32 or 64 bit system depending on your system's configuration): [DEL] DuplexSecure - FAQ [/DEL] Link broken as of 21 Jul 2012
New link (15 Aug 2012): DuplexSecure - Downloads (pick the appropriate version for your system and select "Un-install" when you run it).
Alternate link: Disc-Tools.com
Manual procedure here: Registry and SPTD problems | DAEMON Pro Help

(quote from usasma [john])

to quote, follow the instructions provided to remove that piece of software.

These three drivers should be updated (follow the provided links)(as a rule of thumb, pre 2009 drivers are outdated):
Code:
purendis.sys                Tue Oct 28 15:31:28 2008 (490695A0)
Pure Networks, Inc. Network Magic NDIS Relay Driver
http://www.carrona.org/drivers/driver.php?id=purendis.sys
 
pnarp.sys                   Tue Oct 28 16:57:00 2008 (4906A9AC)
Pure Networks, Inc. Network Magic Address Resolution Protocol Driver
http://www.carrona.org/drivers/driver.php?id=pnarp.sys
 
dne64x.sys                  Tue Nov 11 12:01:24 2008 (4918D964)
Citrix Deterministic Network Enhancer Miniport or Cisco Systems VPN Client
http://www.carrona.org/drivers/driver.php?id=dne64x.sys
You have Norton AV installed.
First: Update it to the latest version, you've got currently 2009/2012 drivers, best to get them both up to date.
Second: I'd recommend Microsoft Security Essentials, if you could (just for debugging purposes):
Uninstall Norton (fully, including Symantec and any related software)
Install MSE.

--------------------------------------------------------------------------------------------------------------------------------------------------------
Dumps:

Code:
System Uptime: 0 days 0:32:37.055
BugCheck F4, {3, fffffa80098bab30, fffffa80098bae10, fffff8000357e470}
Probably caused by : wininit.exe
Bugcheck code 000000f4
PROCESS_NAME:  wininit.exe
BUGCHECK_STR:  0xF4_C0000005
DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT
FAILURE_BUCKET_ID:  X64_0xF4_C0000005_IMAGE_wininit.exe
¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨``
System Uptime: 0 days 0:22:17.421
BugCheck F4, {3, fffffa8008de5950, fffffa8008de5c30, fffff800035d4470}
Probably caused by : csrss.exe
Bugcheck code 000000f4
PROCESS_NAME:  csrss.exe
BUGCHECK_STR:  0xF4_IOERR
DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT
FAILURE_BUCKET_ID:  X64_0xF4_IOERR_IMAGE_csrss.exe
¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨``
System Uptime: 0 days 1:03:55.277
BugCheck F4, {3, fffffa80093c1060, fffffa80093c1340, fffff800035ce470}
Probably caused by : wininit.exe
Bugcheck code 000000f4
PROCESS_NAME:  wininit.exe
BUGCHECK_STR:  0xF4_C0000005
DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT
FAILURE_BUCKET_ID:  X64_0xF4_C0000005_IMAGE_wininit.exe
¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨``
System Uptime: 0 days 1:02:49.869
BugCheck F4, {3, fffffa8008093060, fffffa8008093340, fffff800035d2470}
Probably caused by : wininit.exe
Bugcheck code 000000f4
PROCESS_NAME:  wininit.exe
BUGCHECK_STR:  0xF4_C0000005
DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT
FAILURE_BUCKET_ID:  X64_0xF4_C0000005_IMAGE_wininit.exe
¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨``
System Uptime: 0 days 15:45:37.987
BugCheck 9F, {3, fffffa8003fff060, fffff80000b9c518, fffffa80048774b0}
Probably caused by : atapi.sys
Bugcheck code 0000009F
DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT
BUGCHECK_STR:  0x9F
PROCESS_NAME:  System
FAILURE_BUCKET_ID:  X64_0x9F_3_IMAGE_atapi.sys
¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨``
The last dump points to atapi.sys -
This driver is Microsoft's IDE/ATAPI Port Driver. A BSOD with this usually means that there's a problem with one of your drives. HOWEVER, Alcohol 120% and Daemon Tools are programs which create virtual drives on your system. At this point, I'd say that the cause of this dump is from Daemon Tools, so uninstall it.

Dumps with wininit.exe -
There are different ways to solve crashes relating to wininit.exe.

Part 1: Modify win.ini file
a. Click Start, type win.ini and hit enter.
b. When you hit enter, a notepad file should open.
c. Find the line that begins with "load=", and then type a semicolon (;) at the beginning of this line.
d. Click Close, and then click Yes to save the file when you are prompted.
e. Restart your computer for the changes to take effect.

Part 2:
Step 1: Perform startup repair
a. Insert the Windows 7 installation disc in the disc drive, and then start the computer.
b. Press a key when you are prompted.
c. Select a language, a time, a currency, a keyboard or an input method, and then click Next.
d. Click Repair your computer.
e. Click the operating system that you want to repair, and then click Next.
f. In the System Recovery Options dialog box, click Startup Repair
g. Once the startup repair completes, click Finish to restart the computer.
h. Remove the DVD and restart the computer to see if the system starts fine.

Step 2: If the issue still persists, follow Step 1 and select System Restore on System Recovery Options menu to perform system restore.
Dumps with csrss.exe -
These dumps say that a crucial process was terminated unexpectedly.
In your case, you have an IO error. This means that data can't be read from one of your drives (hard disk, solid state or virtual).
Since you also have Daemon Tools installed, I'll point my finger once again at that.
HOWEVER, also try these diagnostics Hard Drive Diagnostic Procedure.

csrss.exe and wininit.exe dumps could also be trojan viruses hiding as those processes.
I'd download and install Malwarebytes : Solve your malware problems with our help and scan the system just to be sure.
 


Last edited:
#6
Thank you for the comprehensive reply, this gives me a lot to work on. For now I'll disable verifier so I don't get extra crashes while addressing these other issues.

There seems to be a version of the USB 3.0 drivers that are newer than what I currently have. http://www.gigabyte.us/products/product-page.aspx?pid=3786#driver shows there's a december 2010 version. I'm surprised I don't already have this, since I built the computer in July 2011.

Should updating my BIOS and related mobo drivers be a high priority?

I'll adjust the system and recovery settings and hope that results in my BSODs generating dumps again.

I ran memtest86+ for whatever the default was, so perhaps about 2 hours. I'll try a longer test if I'm still getting BSODs after addressing some of these other issues.

Cisco VPN Adapter - This probably came from some software I got at work to allow me to use remote desktop with my work computer. I can remove this. I'm guessing the three outdated drivers you listed are related to this. Unfortunately the links on carrona.org resolve to cisco and linksys websites. If uninstalling the VPN doesn't remove these, I'm not sure what I should do about them, save calling up Cisco.

Daemon Tools - Haven't used or modified this in months. I'll get rid of it, as well as the pesky driver that requires special removal. I've seen this cited in other threads but I had figured the continued crashes in safemode ruled this out.

I'll get rid of Norton and switch to MSE.

I'll look into the winit.ini fix, running malwarebytes, and running some hard-drive checks.

CPU-Z wasn't showing the model revision of the board, so I'll check out PC-Wizard.

Again, thanks.

UPDATE: Turned off verifier, replaced Symantec with MSE, removed daemon tools, accidently re-installed sptd.sys and removed it again, uninstalled that VPN client (although I'm not sure if the associated drivers were removed automatically), made those changes to the recovery dump. After all of those things, I had just finished up the Malwarebytes scan and my system crashed crashed again (i was not in safemode at this time). Once more, no minidump was generated.

I rebooted and started looking into hard drive diagnostics, where I noticed that my SSD manufacturer, Crucial, had no such built-in diagnostics. While doing a bit of searching, I ran across a number of posts/articles saying that my line of SSDs, Crucial m4's, had a firmware fault that, without upgrade, would cause the SSD to become unresponsive about 1 hour after power on, causing BSODs. This would explain much if not all of my issues. It would explain the regularity of the crashes, it would explain why the computer would not reboot after a BSOD without a complete power cycle (it would not boot if i pressed the reset button on the case), it also explains why only a few of the crashes were able to generate minidumps. The fault only kicks in after 5200 hours of use or so, and considering when i built my computer and how much i've used it, this even explains the timing of this BSOD coming out of nowhere at me. I upgraded the firmware, and for the moment everything seems to be running perfectly. If this proves to have solved the issue, I will post back in a few days to confirm it resolved.

I do plan to follow up on your other suggestions to improve my system's stability.
 


Last edited:

GeneralHiningII

Honorable Member
#7
Even if you built your computer in 2011, the motherboard was installed with the drivers in 2009 or 2010, and stuck with those drivers from that year. That's probably why.

Updating your BIOS and mobo drivers should be on your priority list at 3 or 4 (1: AntiVirus, 2: Backup). It's essential to get the latest drivers for your motherboard since they can contain fixes to certain problems with previous drivers, and can improve stability and speeds of your computer.

Memtest should be run for at least 7 hours, or overnight (that's how much I like anyway). Another way of testing your RAM would be with Prime95 (link to download in my signature). Run it, and select Blend test. Leave it for about 2 hours, monitoring your temps (I prefer RealTemp, or CPUTemp if you have an AMD proc).

Try uninstalling the drivers for the VPN Adapter anyway. The carrona.org links are links that come as a template with the debugging software I use, sometimes they may help, other times they'll be a guide for you to get drivers yourself.

Continued crashes in safe mode would rule this out, except one of the dumps also suggests Daemon Tools so as an extra measure I suggested you to uninstall it.

If you're not sure if the drivers were fully removed, try Guru3D - Driver Sweeper and run it (in Safe Mode) to clean out all your drivers for the particular device.

Crucial M4 SSD's (in fact, all SSD's for that matter) - I myself have only heard of these problems too, and about once or twice have I actually dealt with SSD faults. However, I found a short help paragraph that may help:
There's not a whole bunch available to test SSD's. The "easiest" test is to remove the SSD, install a platter-based hard drive, install Windows and test for stability that way.

Here's some suggestions:
- Update the SSD's firmware to the latest available version (VERY IMPORTANT!!!)
- Update the motherboard controllers drivers to the latest available version from the controller manufacturer (NOT the mobo manufacturer unless you can't find any on the controller manufacturer's website). Be sure to update ALL controllers on the motherboard! ISTRONGLY suggest not using controller drivers older than mid-2012 with SSD's.
- Slow the memory (RAM) down to the next slower speed (I've only seen one person who claimed that this worked for them).
- Use any manufacturer's utilities that you may have. If you don't have any, then try this free one (I haven't used it myself): Crystal Dew World
....NOTE: Recently (Nov 2011) we had BSOD issues with the Marvell 91xx controller and an SSD. You may have to switch controllers also.
- Replace the SSD with a platter based hard drive and see if that stops the BSOD's. If it does, then it's likely that there's a problem with the SSD OR an incompatibility with your system.
06 Dec 2011 - This post tends to confirm issues with certain SSD chipsets and certain controllers - [SOLVED] cant find the cause of BSOD F4 - Tech Support Forum
05 Jan 2013 - very interesting post about difficulties with the Marvell controllers even when not connected to the SSD drives:https://www.eightforums.com/bsod-cra...tml#post169956
27 Feb 2013 - I'm starting to see much better reliability with SSD's using current (mid-2012 and later) storage drivers. I have withdrawn my objections to using these devices in everyday systems.
from usasma (john).
Although you updated the firmware for your SSD, it's good to try out the help above in case.

Glad to see that everything's running smoothly so far!
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.