BUGCODE_USB BSOD on shutdown

Discussion in 'Windows 7 Blue Screen of Death (BSOD)' started by mishagale, May 9, 2009.

  1. mishagale

    mishagale New Member

    Joined:
    May 9, 2009
    Messages:
    62
    Likes Received:
    2
    Hi there,
    New to Windows 7 and these fora, just hoping someone could help me out with my annoying crash problem.

    I recently installed Windows 7 RC (clean install, empty partition), but whenever I shutdown or restart, after installing updates and the "Shutting down..." screen it crashes to a bluescreen, giving the error BUGCODE_USB. Have been sending the minidumps to MS, but if they fix it I imagine it'll be some time before we see the patch, so hoping someone here has some info.

    Here's some info from the problem report:

    Problem signature:
    Problem Event Name: BlueScreen
    OS Version: 6.1.7100.2.0.0.256.1
    Locale ID: 2057

    Additional information about the problem:
    BCCode: fe
    BCP1: 0000000000000008
    BCP2: 0000000000000006
    BCP3: 0000000000000006
    BCP4: FFFFFA8007C1D000
    OS Version: 6_1_7100
    Service Pack: 0_0
    Product: 256_1

    And my specs:
    AMD X2 3Ghz
    6GB 800Mhz DDR2 RAM (2x1GB, 2x 2GB)
    Asus M2N32-SLI motherboard
    NVidia GeForce 9800GT 1GB

    As for USB devices, I'm using a microsoft keyboard and mouse, so pretty sure there's proper drivers for those in 7, but I am also running an internal Akasa card reader, plugged direct into the motherboard USB socket. Card reader is working fine though.

    There's also an unknown device listed in my device manager, but not too sure what it is, possibly something to do with ACPI? (Hardware IDs: ACPI\AWY0001, *AWY0001). I could download latest motherboard drivers from Asus, but they don't have windows 7 drivers listed yet, should I just use the Vista ones?

    Any help or advice greatly appreciated, will be happy to post additional info if it'd help.

    Regards,
    Misha
     
  2. progster

    progster New Member

    Joined:
    Jan 25, 2009
    Messages:
    16
    Likes Received:
    0
  3. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    Hello Misha,

    Welcome to the Windows 7 Forums,

    If it occurred after the updates, choose System Restore to go back before the updates wee applied.

    See if everything works OK with out the updates.

    Here are some other options.

    Do you have a PS/2 mouse and keyboard that you could hookup? I'd also remove the card reader just to help isolate the problem.

    For the unknown device, I'm assuming it under the Universal Serial Bus controllers, correct?

    You can download this freeware utility to identify that unknown device:

    Unknown Device Identifier - Freeware Download

    If the problem is fixed I'd go back to Windows Update, but check to see what updates are being installed before you actually install them.
     
  4. mishagale

    mishagale New Member

    Joined:
    May 9, 2009
    Messages:
    62
    Likes Received:
    2
    Hi guys,
    thanks for the suggestions so far, will try them out and get back to you. On my end, I think it *might* be a BIOS related issue: I upgraded to the very latest BIOS (2205) which made the system so unstable it couldn't get through the login screen without freezing up, same in XP. So I downgraded (although not all the way back to the original version, 0706, as it wouldn't allow me to downgrade that far) and system stability returned, but now when I shutdown it just hangs on "Shutting down..." screen, apparently forever.

    I'll try gradually upgrading the BIOS, hopefully there is a "golden" version between this one and 2205 which fixes the shutdown problem without making the system unusable. Failing that, I'll start removing USB devices and see if I can isolate the one causing the problem.

    Oh, almost forgot, there's also a hauppage WinTV Nova-500 DVB-T tuner card in my machine, it doesn't seem to be working too great, so I'll probably try removing that and seeing if that helps.

    Reghakr: The problem has been there since the initial installation. The Unkown Device is listed under "Other Devices", Location: "On Microsoft ACPI-compliant System". Thanks for the tip on that utility, but no joy - trying to run it (even as admin) gives me a "privileged instruction" error.

    Progster: Mouse and KB both wired.

    Thanks again, will keep you posted.

    Misha
     
  5. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    Misha,
    Are you using the 64-bit version by chance?

    ACPI allows the operating system to communicate with the computer's BIOS and instruct the BIOS to power down peripherals. For instance, when your computer goes into hibernation mode, the operating system is using the ACPI specification to control the power to the internal components.

    This should have being installed by default.

    Did you perform an upgrade from XP or was it a "clean" install?
     
  6. mishagale

    mishagale New Member

    Joined:
    May 9, 2009
    Messages:
    62
    Likes Received:
    2
    reghakr: Yes, it's the x64 version of Windows 7. I did a clean install into an empty partition, but I've still got XP and Ubuntu installed.

    Not sure why there aren't drivers for this ACPI device already, I've tried to update them, but no luck. Like I said, Asus haven't released any Windows 7 drivers, but the Vista drivers that are available for my mobo don't seem to cover ACPI or the chipset in general.
     
  7. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    Like I said earlier, it should have been automatically installed by default.

    There is no 3rd party driver. this explains it a little further:

    Microsoft supplies the ACPI driver as part of the operating system. On systems that have an ACPI BIOS, the HAL causes the ACPI driver to be loaded during system start-up at the base of the device tree, where the driver acts as the interface between the operating system and the BIOS. The ACPI driver is transparent to other drivers.
     
  8. mishagale

    mishagale New Member

    Joined:
    May 9, 2009
    Messages:
    62
    Likes Received:
    2
    OK, here's the latest, made some progress:
    The mysterious "Unknown Device" turns out to be the AMD Away Mode driver, pretty harmless and useless, but found a driver for it and my device manager no longer flags any problem devices.

    I tried diverse BIOS versions, none of which made any difference.

    Then I started yanking USB devices - KB, Mouse, card reader and even disabled the USB controller in the BIOS setup, all to no avail. Finally, I yanked the WinTV card and lo and behold, the computer could shutdown! I reinstated all the USB devices and it still shutdown OK.

    So it seems the problem is the TV card, and I'd quite like to be able to plug it back in. I'm using the most up-to-date drivers from the Hauppauge website. It's just possible the hardware is faulty - sometimes the hardware isn't detected on boot up, but a restart or 2 makes it reapear.

    Any ideas for a fix or a workaround greatly appreciated, as is all the advice so far.

    Misha
     
  9. DaedalusK71

    DaedalusK71 New Member

    Joined:
    May 15, 2009
    Messages:
    2
    Likes Received:
    0
    Driver Location

    Mishagale,

    Where did you find the away mode driver for Windows 7? I have the same issue and cannot find it.

    thanks
     
  10. mishagale

    mishagale New Member

    Joined:
    May 9, 2009
    Messages:
    62
    Likes Received:
    2
    Hi Daedelus,
    It was on the AMD website somewhere I think, I can't seem to find it again now, but the file is attached to this post. You may need to install it in compatibility mode. As far as I can see, the only benefit to installing this driver is just to get rid of the little yellow triangle in the device manager, it doesn't really do anything very much.
     
  11. mishagale

    mishagale New Member

    Joined:
    May 9, 2009
    Messages:
    62
    Likes Received:
    2
    usbehci.sys

    It seems there is a solution to this problem on the Hauppauge boards, involving replacing the usbehci.sys driver with a version from Vista. Unfortunately, I don't have access to a Vista installation, and can't find the right version of this file. If anyone happens to have version 6.0.6001.18000 of \windows\system32\drivers\usbehci.sys from Vista, could they please post it?

    See: Crazy Windows 7 bug - Page 3 - Hauppauge UK Forum
     

Share This Page

Loading...