Civilization V constantly crashing with "video_scheduler_internal_error"

kemical

Windows Forum Admin
Staff member
Premium Supporter
Microsoft MVP
#21
Code:
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

Use !analyze -v to get detailed debugging information.

BugCheck 101, {18, 0, fffff80280d22180, 0}

Probably caused by : Unknown_Image ( ANALYSIS_INCONCLUSIVE )

Followup: MachineOwner
Hi,
the above dump file means a secondary processor became hung up or stopped working. Just to go back to my last post for a second, did you manage to run this test:
'Run a stress test of the gpu using Furmark. Watch the temps in case it starts to overheat'.
FurMark: VGA Stress Test, Graphics Card and GPU Stability Test, Burn-in Test, OpenGL Benchmark and GPU Temperature | oZone3D.Net
Please post any results.
Regarding the above dump file as the analysis was inconclusive you'll need to run the driver verifier.
In order to run the verifer you will also need a recovery disk/USB. This is just in case the verifier causes a blue screen loop on start up. If it does you can then use the recovery disk/usb to boot into the recovery console, enable safe mode and then turn the verifier off. Hopefully by that point the culprit will have been caught and written on the dump file.
Recovery drive
Creating a recovery drive - Windows Help -
Safe mode
4 Ways To Boot Into Safe Mode In Windows 10
Driver verifier
How do I fix a Blue Screen in Windows using Driver Verifier?

Post any new dump files. Any problems post back.
 


#22
The results of the GPU stress test:

min:44C - max: 53C

I did the Driver verifier....well, at least I hope I did it correctly. Here's the dump file.
 


Attachments

kemical

Windows Forum Admin
Staff member
Premium Supporter
Microsoft MVP
#23
Code:
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

Use !analyze -v to get detailed debugging information.

BugCheck C4, {2004, ffffe001cad72218, fffff80085200218, ffffd00084b7e030}


Could not read faulting driver name
Probably caused by : ntkrnlmp.exe ( nt!VerifierBugCheckIfAppropriate+3c )

Followup: MachineOwner
Hi,
frustratingly the verifier still couldn't read the faulting drivers name. The fact your gpu finished the stress test with reasonable temps probably means that it's fine hardware wise.
One quite important issue is that you have no Windows 10 driver support. Drivers for your model stop at Windows 8 and i have to wonder if there is a compatibility issue here? Your support page is quite clear:
Product not tested for Windows 10 upgrade
Dell is not testing or developing Windows 10 drivers for this product. If you choose to upgrade, some features, applications, and connected devices may not work as expected.
Would Civilisation V run ok in your last os before you upgraded?

Has the game at any point run properly in windows 10?

Have you tried running the game in compatibility mode? To do this you need to right click the games icon and choose properties. Look across the top of the revealed box for compatibility and you'll see a drop down menu. Try running it in Windows 7 mode.

You can also find some diagnostic tests which might useful:
test.JPG

To find these tests, look on the left hand side of the screen, near the top you'll see 'Diagnostic' at the top of a list. You need to click that and then 'Choose a diagnostic test' lower down the page.
Try running the full test and see what turns up.


Hmm... I just did some searching to do with your issue and apparently this is pretty widespread with this model. Users have found a way to stop the crashing and that is by lowering the clocks on the gpu slightly so it's not running so fast.
Dell XPS 15 (L502X) crashes during gameplay - General Hardware - Laptop - Dell Community
So despite what I've written above I would definitely try this first. You will need to use an application that allows you access to the gpu clock settings. I found a youtube vid which should help. All you need to do is downclock the engine or core speed by say 20MHz. Do the same for the memory too.
Test the game again and if it still locks up drop the clocks further but only by 20MHz each time. You may find that eventually the game will run stable. If however you've downclocked to around 100MHz and it's still crashing then post back with any new dump files of course. :)
This is the youtube vis:

MSI Afterburner
Afterburner - MSI Gaming Series

Best of luck. Any issues post back.
 


#24
I underclocked to 40mhz and the game crashed, but my pc did not freeze. I took a screenshot of what popped up and attached it below.
 


Attachments

kemical

Windows Forum Admin
Staff member
Premium Supporter
Microsoft MVP
#25
Hi,
when you underclocked was it both core and memory speeds you changed or just one?

You need to change both.

I would also try underclocking further. Simply keep going and see if at any point the game runs without crashing. As I said above if you get to around 100mhz underclocked then stop.
 


#26
It was both. I'll try going further.
 


kemical

Windows Forum Admin
Staff member
Premium Supporter
Microsoft MVP
#27
Ok, will wait on your next update. Hope all goes well.
 


#28
Hi Just a little chuckle here.:D Then I'll be good. My seniors here; that I help at Golden Oaks, don't over clock or play these high powered games, so I don't see many BSODs.:rofl::up:Sorry @kemical I just couldn't resist!:devil_smile:
 


kemical

Windows Forum Admin
Staff member
Premium Supporter
Microsoft MVP
#29
Civilisation V high powered? I don't think it's ever been considered a high powered game. System requirements are below.
CPU: Intel Core 2 Duo 1.8 GHz or AMD Athlon X2 64 2.0 GHz
CPU Speed: Intel Core 2 Duo 1.8 GHz or AMD Athlon X2 64 2.0 GHz
RAM: 2 GB
OS: Windows XP SP3/ Windows Vista SP2/ Windows 7
Video Card: 256 MB ATI Radeon HD 2600 XT or better, 256 MB NVIDIA GeForce 7900 GS or better, or Core i3 or better integrated graphics
DirectX version: DirectX® 9.0c
Sound Card: Yes
Free Disk Space: 8 GB Free
Also there's no over clocking going on here.
 


#30
Hi,
when you underclocked was it both core and memory speeds you changed or just one?

You need to change both.

I would also try underclocking further. Simply keep going and see if at any point the game runs without crashing. As I said above if you get to around 100mhz underclocked then stop.
Sorry I'll bow out now;):(. I'm out of my pay grade. Was just having fun. I know better!
 


#32
Thanks @kemical This stuff is all foreign to this old man. I'll read the post and try to learn some thing new!;)
Might not remember!:rofl:however!
 


#33
Underclocked to 100 and it still crashed and then froze up with my second monitor going into a weird red and black patterned screen.
 


Neemobeer

Windows Forum Team
Staff member
#34
When you said the second scan returned error 87 did you mean the DISM scan and if so can you upload the DISM log. C:\Windows\Logs\DISM\dism.log
 


#35
After I did a clean install of Windows 10 I ran those scans again and while there were no errors that time around, they also found nothing.
 


kemical

Windows Forum Admin
Staff member
Premium Supporter
Microsoft MVP
#36
Underclocked to 100 and it still crashed and then froze up with my second monitor going into a weird red and black patterned screen.
I reread some of the link I posted and it seems that the core has to be around 600MHz so if need be drop down even further. If you read page 2 and 3 of the above link there is a lot more info about clock speeds and even a modded bios.

You could also try disabling the 540GT via the bios and using your other gpu. See if the game will run, if it does then you at least have a good idea of the culprit.

Do you still get a crash with the second screen unplugged?

Ultimately you may want to consider the bios update but do check that link thoroughly as there's lot's of info.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.