Critical Process died BSOD.

Discussion in 'Windows 10 Blue Screen of Death (BSOD)' started by JohnW, Apr 8, 2016.

  1. JohnW

    JohnW Member

    Joined:
    Apr 8, 2016
    Messages:
    32
    Likes Received:
    1
    Hello, recently I've getting getting numerous errors with my PC, and at first I thought it was hard drive related, however now I am not so sure. I will list problems in order from when they started happening to what's happening now (after a clean system restore)
    C:120G D: 1TB
    (SSDSC2CT120 120G SSD)paired with (WDC WD10EZEX-OOBN 1TB) < Possibly failing?

    Problem 1. When playing games that boot from my secondary hard drive, they would run fine for a given time (anywhere from 30 minutes to a few hours) then I they would freeze, and a error box would pop up saying Microsoft Windows has stopped responding would you like to close? And it would either A. Resolve itself after a period of time in witch I would return to my computer with my D: drive would be disconnected. (A computer restart would usually resolve this).
    Or B. End in a BSOD.
    Games that caused it (that I played that were on my D: drive) Rocket League, The Division, Dying Light, World of Warcraft.

    Problem 2. In addition to problem 1. I was also getting the occasional blue screen caused by this issue that was either Critical Process Died (being the rarer one) or something to the extent of a kernal impage error. (both of witch seemed to happen randomly in conjunction with the freezes however random in witch BSOD I received.

    Problem 3.Eventually I was able to do a clean reformat of my PC (the long one) and get everything re downloaded and reinstalled. However I was still having issues, only now the only BSOD I seem to get is Critical Process Died. I decided to move my Rocket League over to my C: drive so that I could play it without issues (because I can play CS:GO and LoL, without any problems both being on my C: Drive. However even with it moved it still causes the BSOD, while the other games do not. I would also like to note that I replaced the sata cables on both my disks as I believed that to be the issue originally.

    I have tried Memory Diag, checked my disks for errors, and done general diagnosing to the best of my ability, I can normally fix these kind of things myself With the help of google of course, however there seems to be a unlimited number of possibilities witch are caused by this BSOD as well as the other issues.

    I have included a SystemReport file below that I created using PowerShell any help would be greatly appreciated.
     

    Attached Files:

  2. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,833
    Likes Received:
    1,566
    Code:
    *******************************************************************************
    *                                                                             *
    *                        Bugcheck Analysis                                    *
    *                                                                             *
    *******************************************************************************
    
    Use !analyze -v to get detailed debugging information.
    
    BugCheck C5, {100000000, 2, 0, fffff80113ab9840}
    
    Probably caused by : Pool_Corruption ( nt!ExDeferredFreePool+a0 )
    
    Followup: Pool_corruption
    
    Hi,
    the above bugcheck is usually caused by a driver corrupting the system pool. Unfortunately the dump file doesn't say which driver although i can see in the call stack that it may be possibly network related.
    Looking through your drivers for possible suspects a few spring to mind:

    avgmfx64.sys Mon Mar 07 12:38:58 2016: AVG AV has been known on occasion to cause the odd issue. Please uninstall and just use the onboard Defender as this is very stable. (you can always re-install AVG later)

    ESEADriver2.sys Sat Mar 26 11:50:52 2016: ESEA client please uninstall to test. (I have a hunch that this driver is the culprit)

    rt640x64.sys Wed Oct 07 16:03:55 2015: Realtek NICDRV 8169 PCIe GBE Family Controller driver. I think this driver is actually incorrect for your machine. Please uninstall and install the Realtek LAN driver found on your motherboard support page under windows 10 64bit:
    GIGABYTE - Motherboard - Socket AM3+ - GA-970A-UD3 (rev. 1.0/1.1)

    If after making the above changes the bsod continues then try running the driver verifier. First however you will need to create a recovery disk/USB. This is because the verifier stresses each driver on start up and if it bsod's it can sometimes lead to a bsod start up loop. If this occurs one boot's from the recovery disk/USB, enters safe mode and turns the verifier off. Hopefully the offending driver will have been caught in the dump file.
    Creating a recovery drive - Windows Help -

    How do I fix a Blue Screen in Windows using Driver Verifier?

    Post any new dump files.
     
  3. JohnW

    JohnW Member

    Joined:
    Apr 8, 2016
    Messages:
    32
    Likes Received:
    1
    Thanks for the quick response! I will get to work testing out these fixes. Will report back shortly with each test.
     
  4. JohnW

    JohnW Member

    Joined:
    Apr 8, 2016
    Messages:
    32
    Likes Received:
    1
    Well, none of the first 3 steps worked, only thing left to test now is the driver verifier. I will have to try and find a flash drive big enough to backup my OS. Will try and post back with more results.
     
  5. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,833
    Likes Received:
    1,566
    Thanks for the updates John. Don't forget that recovery disk/USB if your going to use the verifier.
     
  6. holdum333

    holdum333 Banned

    Joined:
    Mar 27, 2016
    Messages:
    1,244
    Likes Received:
    147
  7. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,833
    Likes Received:
    1,566
  8. holdum333

    holdum333 Banned

    Joined:
    Mar 27, 2016
    Messages:
    1,244
    Likes Received:
    147
    Yes sir! I just added "How to create a repair CD" I have both, and the MCT!:worship: They can all get you to the repair mode!;) W10 has several ways to recover. My favorite is the in place repair install.
    Cool, you only lose the windows up dates with that.
     
  9. JohnW

    JohnW Member

    Joined:
    Apr 8, 2016
    Messages:
    32
    Likes Received:
    1
    So, my computer did get stuck in a loop, as you thought it might Kemical however I just gave it a day and came back to it and I was able to get my computer into safe mode and disabled it, I don't believe it actually even got to run. As it was saying Driver verifier detected violation. And rebooting.
    (Saved a trip to walmart to grab a usb stick) So, I was thinking of going amd reinstaling windows again, with my D: Drive disconnected to check if it is the hard drive causing the problems, unless you have something else for me to try?
     
  10. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,833
    Likes Received:
    1,566
    Hi John,
    is there any dump files from the verifier? If so please post them and I'll have a quick look before you try the re-install.
     
  11. JohnW

    JohnW Member

    Joined:
    Apr 8, 2016
    Messages:
    32
    Likes Received:
    1
    Oops, forgot to even check. I figured it didn't even run sense it kept BSODing. Had to change permissions of the folder just to attach them. The only ones there are from this morning, hopefully there's something there that's useful.
     

    Attached Files:

  12. JohnW

    JohnW Member

    Joined:
    Apr 8, 2016
    Messages:
    32
    Likes Received:
    1
    The problem with those .dmp files though, is those BSOD weren't cause by the issue. They were caused by the driver verifier. So not sure if there useful at all.
     
  13. JohnW

    JohnW Member

    Joined:
    Apr 8, 2016
    Messages:
    32
    Likes Received:
    1
    If I recreate the BSOD (witch I can do 99% of the time just by trying access the drive heavily) would it create another .dmp file in the smae folder that I could link?
     
  14. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,833
    Likes Received:
    1,566
    Code:
    *******************************************************************************
    *                                                                             *
    *                        Bugcheck Analysis                                    *
    *                                                                             *
    *******************************************************************************
    
    Use !analyze -v to get detailed debugging information.
    
    BugCheck C4, {2000, fffff80148b2114f, 0, 5254454b}
    
    *** WARNING: Unable to verify timestamp for rt640x64.sys
    *** ERROR: Module load completed but symbols could not be loaded for rt640x64.sys
    Probably caused by : rt640x64.sys ( rt640x64+114f )
    
    Followup: MachineOwner
    
    Hi,
    the verifier did indeed do it's job and the driver in question is Realtek NICDRV 8169 PCIe GBE Family Controller driver. This is the driver you downloaded from the support site yes? If so this has me a little confused as this driver isn't for the chip installed on your motherboard. You have a RTL8111E chip which you can see under 'Lan' in your specifications:
    GIGABYTE - Motherboard - Socket AM3+ - GA-970A-UD3 (rev. 1.0/1.1)

    Ok now make sure you have a copy of the lan driver found on the Gigabyte support page saved somewhere as you might need it later.

    Now download the version which should be for your chip here:
    Realtek
    (second download down)
    Once you've downloaded the driver uninstall the original that's on the system and then try the new driver you just downloaded. If for whatever reason it doesn't work use the driver from the support page you saved earlier.

    Let me know how you get on and post any new dump files.
     
  15. JohnW

    JohnW Member

    Joined:
    Apr 8, 2016
    Messages:
    32
    Likes Received:
    1
    Well, I downloaded it from the link you specified and it defaulted to wanting to repair the current realtek driver I have, It updated the driver version to 10.7. Going to attempt a few games of rocket leauge and will let you know if it crashes again. If so that's one step closer.
     
  16. JohnW

    JohnW Member

    Joined:
    Apr 8, 2016
    Messages:
    32
    Likes Received:
    1
    Welp, couldn't even get into a game before "Microsoft Windows" The application is not responding again.
     
  17. JohnW

    JohnW Member

    Joined:
    Apr 8, 2016
    Messages:
    32
    Likes Received:
    1
    In fact I'm sitting here typing this waiting for my computer to crash. As it's only a matter of time once I lose functionality of my system.
     
  18. JohnW

    JohnW Member

    Joined:
    Apr 8, 2016
    Messages:
    32
    Likes Received:
    1
    So, what I don't quite understand is in the past it was just games on my HDD that would cause the numerous errors, wow/rocket league/dying light/division
    I could play CSGO and League for hours on end without having any issues (On my ssd). Then it went from blue screening once every few weeks, to every couple days (usually the blue screens being paired with the drive disconnecting) Then I get new sata cables, and am no longer having the "disconnect issue" now it's only the blue screen. Every time in place of the disconnect it blue screens. So I thought moving the game off of my HDD to my SSD would fix it, yet Rocket League STILL causes the blue screen to happen almost on command. Even after moving it.
    And although it has blue screened for seemingly no reason with nothing running, it's not a normal thing, in fact, I think it only happened twice, both of witch yesterday. And I think that was before I disabled one drive sync with my D: drive. Everything goes back to my D: drive, yet Rocket League Witch was moved to my C: (SSD) is still causing it.

    Sorry for the wall of text, just trying to get all the information out there, because I literally cannot wrap my head around this.
    Also I can get it to BSOD just by opening battle.net and attempting to launch the unfinished download of the wow alpha (despite it saying playable) and the last time I did it gave me an interesting error. Witch I will type below.
    (Inside of a little windows error window)
    TITLE: World of Warcraft: WowB-64.exe - Bad Image
    C: Programfiles/Logitech Gamingsoftware/SDK/LCD/x64/LgLcdApi.dll is either not designed to run on Windows or it contains an error. try installing the program again using the original installation media or contact your system administrator or the software vender for support. Error status 0xc0000020.

    I uninstalled my logitech mouse software and booted up rocket league, and it BSOD almost instantly. (The crash I reported above this post).
     
  19. JohnW

    JohnW Member

    Joined:
    Apr 8, 2016
    Messages:
    32
    Likes Received:
    1
    I downloaded a registry key string to create a .dmp file. Going to make it BSOD and post it here.
     
  20. JohnW

    JohnW Member

    Joined:
    Apr 8, 2016
    Messages:
    32
    Likes Received:
    1
    As listed above I usually can use battle.net to cause it. However now the client is saying I don't have any games downloaded, and when I direct them to the install path it says This folder doesn't contain the correct version of this game. please check the installation path and try again. Possible Drive corruption?
     

Share This Page

Loading...