DHCP Client Service FAILS TO START!

Discussion in 'Windows 7 Help and Support' started by alebcay, Jul 13, 2012.

  1. alebcay

    alebcay New Member

    Joined:
    Jul 3, 2012
    Messages:
    96
    Likes Received:
    5
    Hello,

    On July 12th 2012, my computer installed updates. After rebooting and waiting for me on the login screen, I gave it a hard shutdown to check on the BIOS settings (for a little side project, in the end I did not save any changes). After booting and logging in again, I find that many services are not running. I ran a very thorough check for malware and viruses (took over 24 hours to complete), and still no solutions. I have uninstalled/reinstalled my Broadcom 802.11g Wireless Driver several times.
    I now look in the Event Viewer and find that the DHCP Client service is not running! It is set to automatic start in Services.msc, but when I try to manually start it, it gives me error 1075 (some dependencies do not exist or are marked for deletion). Running ipconfig, I notice that my system is using an APIPA-formatted address (169.254.x.x), indicating that the computer couldn't find a DHCP server.

    My Event Viewer is peppered with:
    ------------------------------------------------------------------------------------------------
    Event 7003, Service Control Manager

    The DHCP Client service depends the following service: Afd. This service might not be installed.
    ------------------------------------------------------------------------------------------------
    Event 7001, Service Control Manager

    The WinHTTP Web Proxy Auto-Discovery Service service depends on the DHCP CLient service which failed to start because of the following error: The dependcy service does not exist or has been marekd for deletion.
    ------------------------------------------------------------------------------------------------

    And that keeps repeating many times in a minute (about 30-40 cycles of it).

    Has anyone experienced this before, and does anyone know how to fix this (and in the end, may this require a reinstall of Windows)?
     
    #1 alebcay, Jul 13, 2012
    Last edited: Jul 13, 2012
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    I found several threads about the Ancillary Function Driver (afd.sys).

    Some things you might try, I suppose. Open Device Manager and under the View menu, select "show hidden devices". Then look at the Non-Plug and Play Drivers. The first one should be the one you are looking for. Right click and check properties, and on the Driver Tab, there may be an option to start or stop the driver.

    Ancillary Function Driver for winsock failed to start

    If that doesn't work, possibly go to the Windows\System32\drivers folder and see if afd.sys is listed. If it is, try right clicking and select restore previous.

    If it is still out, you might want to open an administrative command prompt and type sfc /scannow to check your system files. Let us know if it shows any file not recoverable.

    We will see what happens after the above....
     
  3. alebcay

    alebcay New Member

    Joined:
    Jul 3, 2012
    Messages:
    96
    Likes Received:
    5
    OK, I have some bad news...

    I did not find a file named "afd.sys" inside C:\Windows\System32\drivers. I did, however find "afd.sys.mui" inside C:\Windows\System32\drivers\en-US, not that its much help.

    I'll check out the Recycle Bin as well as run an sfc...any ideas on where to go from here (will sfc hopefully get me back my missing driver)?

    [UPDATE] I am not able to run sfc /scannow (error encountered, "Windows Resource Protection could not perform the specified request.", but I am able to run sfc /verifyonly.)
     
    #3 alebcay, Jul 13, 2012
    Last edited: Jul 13, 2012
  4. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    You may be having more problems that you think. Possibly something has gotten corrupted on your system.

    All I can suggest, is to try to run SFC from offline, according to the link. Or you might just go ahead and do a repair install where you start an upgrade install from within the OS. That should repair all your files and leave your installed programs alone.

    But, there is always a chance for a problem, so backup whatever you can.

    How to Run the System File Checker (Sfc.exe) Offline in Windows 7 and Vista - The Winhelponline Blog
     
  5. alebcay

    alebcay New Member

    Joined:
    Jul 3, 2012
    Messages:
    96
    Likes Received:
    5
    Hello,

    I've tried running SFC from offline. When I only use the /scannow parameter, it keeps telling me that there is a system reboot pending. When I use the /offboot=<drive letter found from diskpart> /offwindir=<drive letter found from diskpart>\windows, I still get "Windows Resource Protection cannot complete the requested operation." I don't think I have a Win7 Home Premium OEM disk (thats my Win7 version). I do have a Win7 Ultimate disk, and I don't have any more activation keys.​ Do you think I can still do the repair install?
     
  6. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    You can download a Home Premium w/SP1 for the link. You can try doing a repair install using it, but I have asked several times and no one has confirmed it can be activated with an OEM key. I suppose you are in a situation where that no longer matters, unless you can get some install DVD form the OEM.

    Download Windows 7 ISO (Official 32-bit and 64-bit Direct Download Links) « My Digital Life

    If you need to recover data, you do have an option of getting a new hard drive to install Windows 7 and then access the current drive another way. A repair install might work fine, but think about it.
     
  7. alebcay

    alebcay New Member

    Joined:
    Jul 3, 2012
    Messages:
    96
    Likes Received:
    5
    Thanks. I decided just to reinstall with the current disc I have. I now have Win7 Professional on my laptop ^_^. The problem seems to be fixed, and thanks for all your time. I've learned my lesson about the power button.
     

Share This Page

Loading...