Need Help with Desktop PC

#1
This has been going on for a couple months, and it hasn't gotten in the way but now it is as it's preventing me from opening certain files and games i want to use, such as Skype, and Bioshock Infinite. Whenever i start up my computer or open specific programs, it says : "C:/Windows/system32/d3d11.dll is either not designed to run on Windows or it contains an error. Try installing the program again using the original installation media or contact your system administrator or the software vendor for support." There's also an issue where if this doesn't happen, the program will instantly not respond forcing me to close it. I've tried installing numerous programs that would help fix this, but whenever i try to open them, it instantly doesn't respond. Programs i can recall instantly becoming unresponsive are Skype, Catalyst Control Center, and DirectX which are pretty important, as i recently installed Bioshock Infinite but it says I need to update my Video drivers as well as DirectX in order to play, but whenever i try to download it, it instantly becomes unresponsive. I'm not sure what to do, i'm not really good with computers either and i'm hoping someone out there knows what went wrong and can help me. Thanks.
 


Fixer1234

Senior Member
#2
It appears that d3d11.dll is a Microsoft DLL for Direct3D 11 Runtime and that it has become corrupted. There are numerous DLL download sites that offer a free download (google the filename). I'm hesitant to recommend a specific one because I'm not familiar with which sites are reliable and I know that some of these sites are risky. It may be possible to fix it with SFC /scannow. If that doesn't work, do a little research on trustworthy sources or perhaps another member can recommend a specific site.
 


#3
Thanks for the info and heads-up, i tried a few recommended sites already to see if it would fix it, but about halfway through installation the program went unresponsive and every time i try to run it, it does the same thing. Not sure what i can do at this point, guess i'll keep looking. Thanks for your time and help though!
 


Fixer1234

Senior Member
#4
Try running SFC /scannow. I'm not sure whether it fixes DLLs. If it does, you will be in luck, or it may find some other problem underlying the difficulty you're experiencing. Another resource would be Microsoft's Fixit resource center: http://support.microsoft.com/fixit/ The web site is a self-guided wizard for fixing a broad range of Windows problems.
 


#5
Still seeking resolution or anything helpful/ideas.
 


Fixer1234

Senior Member
#6
Does that mean that SFC and Fixit did not fix the problem?
 


whs

Extraordinary Member
#7
I have this .dll. Will try to attach it to this message. Just replace it in C:\Windows\System32
 


Attachments

Fixer1234

Senior Member
#8
Are you sure there is just one version of the DLL for all versions of Windows?
 


whs

Extraordinary Member
#9
Not sure, but it's worth a try. Copy the one that is currently on the system so that you can backpaddle.
 


#10
SFC /scannow said it found corrupt files but could not fix them,
I tried replacing the file but it said i needed administrative permission, any ideas?
 


Pauli

Extraordinary Member
Premium Supporter
#11
If your computer is otherwise working fine, why not go backwards a step or two: either use a recovery point, Control Panel\All Control Panel Items\Recovery

or perhaps, uninstall programs you've lately installed. Then re-install DirectX.

And, your system fills the requirements of Bioshock Infinite?

Administrative permissions are usually bypassed simply by clicking "continue", or by right clicking the file and choosing "run as administrator". Of course, you must be logged in as administrator. That you can check in Control Panel\All Control Panel Items\User Accounts

Hope you get it running.
 


rbeldua

Honorable Member
#12
- you also have a copy in folder WinSxS /x86_microsoft-windows-directx-direct3d11_31bf3856ad364e35_6.2.9200.16384_none_ec635ab79f12dc23
- then you need to take ownership of the file to be replaced with (usually the one in 0kb) in sysWOW , then copy one from winsxs and paste into sysWOW.
- follow this steps on how to delete a system file in windows 7/vista http://www.howtogeek.com/howto/windows-vista/how-to-delete-a-system-file-in-windows-vista/
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.