Strange file access permission issue

Hi,

I have Linux Ubuntu instal, latest long term version, anyway, I can access some potographcs from my shard partition which I share as an NTFS betwen Liunux and Windows installation, however, although one program in Linux Geeqie can open a file, when I go to open it with Gimp it does not and quotes file permission as an issue. Any idea as to how this has come about? I wasn't aware permissions were down to speific programs, I though the user itself broadly speaking has the file access as granted. Thanks in advance.
 

Neemobeer

Windows Forum Team
Staff member
Permissions are set at the OS level and not by program; however, depending on what permissions are actually set and in what mode a program opens files in may be an issue. I would validate you can add, delete and modify files on the NTFS share.
 
Permissions are set at the OS level and not by program; however, depending on what permissions are actually set and in what mode a program opens files in may be an issue. I would validate you can add, delete and modify files on the NTFS share.

I can confirm I can create, edit and delete a txt file in target drive and the target folder. The target files show the same permissions too.
 

Neemobeer

Windows Forum Team
Staff member
You may need to debug the application with something like strace, or file a bug with the respective program developer.
 
You may need to debug the application with something like strace, or file a bug with the respective program developer.
I shall try uninstall and reinstall first.

Edit OK well uninstall and reinstall didn't work.

Not sure this is worth the hastle. Any other good linux image manipulation programs? I can always boot into windows to make up an image.
 
Last edited:
OK well I just tried to place a tmp directory onto the same drive as I was doing something in Audacity and it made the filesystem in linux run out of space. I got another permissions error and so I opened up the disks program and here is the set of permissions for the drive, I don't understand why Thunar and navigate it, write files, edit or delete them yet I cannot use Audacity to create a directory to have as a tmp location. Anything wrong with this setting? I'll add in fstab too. The drive is called Data, which on another note, I would like to load up automatically on start up. Thanks for your help.

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
# / was on /dev/sda1 during installation
#UUID=657d4d9a-58fb-43d7-81e6-b21a21e18fbd / ext4 errors=remount-ro 0 1
/swapfile none swap sw 0 0
UUID=31b0798c-adc4-4254-b5a5-401a4752ca4f / ext4 errors=remount-ro 0 1
LABEL=Data /mnt/Data ntfs-3g nosuid,nodev,nofail,umask=000,rw 0 0
 

Attachments

  • Screenshot at 2021-01-15 18-15-03.png
    Screenshot at 2021-01-15 18-15-03.png
    57 KB · Views: 28
Here you can see Media is accessible by Thunar yet not accessible to put a tmp folder in by audacity??
 

Attachments

  • Screenshot from 2021-01-15 18-39-44.png
    Screenshot from 2021-01-15 18-39-44.png
    121.4 KB · Views: 28
  • Screenshot at 2021-01-15 18-39-01.png
    Screenshot at 2021-01-15 18-39-01.png
    124.4 KB · Views: 31
The ntfs partition is mounted at /mnt/Data not /media

Sorry, yes, this was a separate example of drive access issues on another partition, I should have been clearer, I now however have found what is possibly the 'root' of the problem lol... Which annoys me thoroughly because they got rid of 'root' users a few years back and wanted people to have sudo group instead. However this doesnt really explain why I can create edit or delete files in a particular drive or see a picture file with one program but not another? How do I change this so everyone can access it?
 

Attachments

  • Screenshot at 2021-01-15 19-22-35.png
    Screenshot at 2021-01-15 19-22-35.png
    34.2 KB · Views: 25

Neemobeer

Windows Forum Team
Staff member
Root has never gone away. Sudo is the preferred and safer method of running a Linux distro. If that is an NTFS partition you can just change the umask to 000 for granting access to it
 
Root has never gone away. Sudo is the preferred and safer method of running a Linux distro. If that is an NTFS partition you can just change the umask to 000 for granting access to it

Can someone login as root then? as per fstab I copied umask is 000.

Thanks for the link.
 
So yesterday I eventually got to do the thing I wanted to do which in vovled stipping the audio from a mk4 file to a .awv file which was huge, and the drive showed error of running out of space... but anyway, after deletion and a reboot I now find when I turn the ubunut system on it takes liek 10-15 seconds for the items on the desktop to appear. Any ideas? Can I make a new desktop and not reset my entire profile?

Edit I just went to open up a small program and it seemed to take 20-30 seconds.
 
Last edited:
Ok well I think I am a little closer to sorting the porblem out, if not, I will have to reinstall linux.

So I wanted to reinstall the Mate desktop environment, however it wold not let me do this in Mate, bizarre, so I logged out and went to the normal Ubuntu standard login, this would crash after not much start up time of its desktop environment. I could not uninstall it from snap store or synaptic package manager as both crashed. I later decided to go back into Mate Desktop and backup stuff for the possible reinstall and I get an error message appear shortly before disappearing and it went on about virtual memory or something. Anyhow, this kind of makes sense because my endeavor to take audio from a large file resulted in huge wav files gbs long. So the question is, how do I go about resetting the systems memory settings for virtual or paged memory so it thinks its now hunky dory? Thanks in advance.

In the mean time I will try disabling and re-enabling the swap file.


Edit: I cant seem to find any programs that will let me change the memory settings, I wonder if Mate has not installed properly?
 
Last edited:
So I turned the swap off and on again using this command however the slow loading desktop still persists.

sudo swapoff -a
sudo swapon -a

Are thre any other cleaning or optimisation programs I can run besides bleachbit that might help?
 
OK well after uninstalling and reinstalling MATE I have the same problem.
I run the memory test no the startup for the RAM and it stopped on the vert first test within seconds of it starting at 47%
However upon testing each stick separately they all passed with no errors. I put the ram back in where they were and it errors at 47% again. I tried shuffling the sticks to find on another it stopped at 58% and then I worked out with just one stick left, luckily 4gb, I could see it pass the first test without an issue. So, kinda strange, its obviously not the ram causing the MATE issue but for some reason they suddenly don't like being with each other. Even when I had two of the same branded sticks together. I'll run HDD check to see if that's got any errors.

Edit the HDD extended test run fine.
 
Last edited:
Top