Sytem Repair Pending which requires reboot to complete not repairing?

Discussion in 'Windows 7 Software' started by Timster12, Mar 28, 2012.

  1. Timster12

    Timster12 New Member

    Joined:
    Mar 26, 2012
    Messages:
    10
    Likes Received:
    0
    I just tried sfc/scannow and I got the following message:

    There is a system repair pending which requires a reboot to complete. Restart windows and try sfc again.

    I'm thinking this repair pending is from the chldsk/r I completed previously. This is great, except when I reboot, the repair does not startup and the system just goes back to the Windows Error Recovery screen I had earlier. How do I get the repair to complete?
     
  2. Mike

    Mike Windows Forum Admin
    Staff Member Premium Supporter

    Joined:
    Jul 22, 2005
    Messages:
    8,488
    Likes Received:
    783
    Is there any way for you to stop booting up into the Windows Error Recovery environment? Ultimately, you want to get to CBS.log in the Windows system directory to find out what happened with sfc /scannow
     
  3. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
  4. Timster12

    Timster12 New Member

    Joined:
    Mar 26, 2012
    Messages:
    10
    Likes Received:
    0
    Thanks saltgrass, I got sfc to run except it comes back with "did not find any integrity violations". That's a problem because I cannot bootup windows 7 on my Dell Inspiron M5030. The computer boots into the Windows Error Recovery screen and then after it does the Startup repair it tells me that Startup Repair could not repair this computer automatically. I've tried system restore, Dell datasafe restore and a couple other scans from the comand prompt. Nothing! Any suggestions? Thanks!
     
  5. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    It may take a Startup Repair several tries to fix certain problems on your system.

    But some folks have taken drastic action to get out of the repair loop. I would not suggest doing some of them, but there may be some commands you could try if you can get into a Command Prompt window, such as bcdboot and bootrec, which must be run from the Recovery Environment.

    bcdboot C:\Windows

    bootrec /FixMBR

    bootrec /FixBoot

    You might try taking the battery out and running without it, or take it out and leave it overnight.

    Have you, or Windows Update installed any device drivers recently?

    And make sure none of the normal F keys. like F8, which may need to be actively tapped during boot. If you could get into Safe Mode, you might be able to work things out.
     
  6. Timster12

    Timster12 New Member

    Joined:
    Mar 26, 2012
    Messages:
    10
    Likes Received:
    0
    Saltgrass, It worked!!! I think it was bcdboot that did the trick. Can't thank you enough. It's been almost 2 weeks since I had this machine up and running. Thanks again!

    Timster12
     
  7. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Glad you got it working. Those repair loop situations are frustrating, because you don't normally know what even caused it. I will put your experience in my archives...
     
  8. TheHeloy

    TheHeloy Active Member

    Joined:
    Feb 9, 2014
    Messages:
    1
    Likes Received:
    0
    Saltgrass i cant thank you enough just made an accout just to thank you, thank you so much. after a whole day of trying this comment works. thanks again
     

Share This Page

Loading...