USB Devices Not Being Recognized

Discussion in 'Windows 8 Blue Screen of Death (BSOD)' started by CobaltDawg, Dec 9, 2012.

  1. CobaltDawg

    CobaltDawg New Member

    Joined:
    Dec 6, 2012
    Messages:
    10
    Likes Received:
    0
    I have discovered a strange issue with my USB ports.

    My external hard drive was reporting that it encountered an error and needed to be checked. I allowed Windows 8 to automatically fix the error. The wizard got about 70% done and then reported that it had failed.

    I then entered the command prompt as an administrator and ran a chkdsk :H /F on the device. The operation ran for about 80% and then reported that it did not have enough disk space to dump some random file cache.

    The HDD is a 2 TB drive with 600 GB free space.

    Just this evening, I noticed that it is now no longer recognized by Windows, and neither is any other USB device I try to use with it. I get no confirmation sound, and a little error box pops up that says "The last USB device you inserted has malfunctioned and Windows does not recognize it.

    Windows recommends disconnecting and reconnecting, both of which I have tried, but to no avail.

    My machine specs are as follows:
    HP ENVY DV6 - Manuf. November 2012
    Windows 8 Standard x64
    8 GB RAM
    3RD Gen. Intel Core i7 3630 QM @ 2.4 GHZ

    As it turns out, in the Event Viewer under "System", I am seeing the following messages multiple times:

    "Reset to device, \Device\RaidPort2, was issued."

    "The IO operation at logical block address 149b234 for Disk 1 was retried."

    "A timeout (30000 milliseconds) was reached while waiting for a transaction response from the WSearch service."

    CRITICAL ERROR - "A problem has occurred with one or more user-mode drivers and the hosting process has been terminated. This may temporarily interrupt your ability to access the devices."

    CRITICAL ERROR - "The device Iomega_HDD (location (unknown)) is offline due to a user-mode driver crash. Windows will attempt to restart the device 5 more times. Please contact the device manufacturer for more information about this problem."

    "The system failed to flush data to the transaction log. Corruption may occur in VolumeId: H:, DeviceName: \Device\HarddiskVolume6.
    (A device which does not exist was specified.)"

    "The program explorer.exe version 6.2.9200.16433 stopped interacting with Windows and was closed. To see if more information about the problem is available, check the problem history in the Action Center control panel."

    ----------------------------------------

    This drive has worked flawlessly on every other machine I've used it on. It has my life's work on it, and I cannot afford to format it. Funny thing is, I was planning on running a backup on it when this error occurred. Is there any hope for me/it?

    I am really REALLY trying my hardest to give Windows 8 a fighting chance, but my faith is starting to slip...
     
  2. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,810
    Likes Received:
    1,563
    Hi Dawg,

    is it possible for you to plug the device in a different machine just to make sure it isn't that which is the issue. Going from what you say, it sounds like an issue cropped up and win 8 tried to repair and couldn't. Also with drives of any type it's always best practice, if possible, to leave at least 25% free space for them to work at best efficiency.
     
  3. usasma

    usasma Fantastic Member
    Microsoft Community Contributor

    Joined:
    Mar 22, 2010
    Messages:
    3,048
    Likes Received:
    83
    I would strongly suggest getting the latest Win8 compatible drivers for your chipset and USB controllers from the website of the manufacturer of the chipset and USB controller. DO NOT use the one's from HP website unless they've been very recently updated (within the last week or two).

    Please search the system for files ending in .dmp Then, if you find any, zip them up and upload them with your next post. The reason for this is the Critical Errors that you posted that point to user-mode driver crashes - they usually produce .dmp files

    Also, please upload these reports (even though you're not receiving BSOD's). The reports should contain a bit more info on the errors. http://windows8forums.com/windows-8-errors-bsods/11837-how-ask-help-bsod.html
     
    1 person likes this.
  4. CobaltDawg

    CobaltDawg New Member

    Joined:
    Dec 6, 2012
    Messages:
    10
    Likes Received:
    0
    Ok, so after a little fiddling around, I have found the solution.

    I took my HDD to work and hooked it in to an old Win XP machine that I have laying in my office (one of several x.x). I noticed that the disk loaded up with no problems on this machine, so I ran "Chkdsk :H /F" from the command line with Admin privileges.

    The command completed successfully after about 15 minutes or so.

    Once that was done, I ran a disk cleanup on the drive and found a couple million KB of old files (Recycle bin, old data files, etc). I cleaned everything out, and then hooked the drive back into my Win 8 machine and presto! It loaded right up with no errors or warnings.

    I will monitor it for a few days to see if something else comes up, if not, Ill keep everyone updated.

    ~Cobalt

    ------------------------------------------------------------------------------------
    UPDATE:

    I THOUGHT the problem with the HDD was fixed, but now it seems I've run into a different problem. The drives connects just fine, but now when I go to transfer files to it, the progress bar does not move past 0%, even though the file (or at least, the icon) shows up in the destination directory!

    I've had this happen a few times since I bought the laptop, and its becoming increasingly frustrating. I'm one more problem away from wiping the machine and jumping BACK to W7...

    Anyone seen this before and/or have a solution?

    -----------------------------------------------------------------------------------

    SECOND UPDATE:
    The device is returning the following error after failing to copy files:

    "error code 0x8007045d: The USB Device failed because of an I/O error"
    ~Cobalt
     
    #4 CobaltDawg, Dec 10, 2012
    Last edited by a moderator: Dec 10, 2012
  5. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,810
    Likes Received:
    1,563
    It sounds like that drive isn't liked by win 8 for some reason. As you posted it opened fine under a different os so one has to consider that there maybe a compatibility issue. Can you post the manufacturer of the drive and model number please. I'll endevour to find out more..
     
  6. CobaltDawg

    CobaltDawg New Member

    Joined:
    Dec 6, 2012
    Messages:
    10
    Likes Received:
    0
    I was beginning to wonder the same thing. The drive is about 2 years old now, so that very well might be the case. Im just worried that if I go out and buy a new drive, and it doesnt work x.x

    The drive is an Iomega eGo model no. 31943600

    It never once gave me a problem in W7, so I'm wondering if it really isnt compatible, though I'm not really sure how something as simple as a mass storage device wouldnt be compatible... hmm...

    Anyways, my real concern here is that I'm going to go out and buy a new one and have the same issue come back. I want to make sure it isnt Windows 8 before I reach out to buy a new drive.

    ----------------------------------------------------------------------------------
    UPDATE:
    Things arent looking well for Iomega. Apparently I'm not the only one who has experienced this problem, and the Iomega website does not have any drivers listed for Windows 8.. Not good...

    ~Cobalt
     
    #6 CobaltDawg, Dec 11, 2012
    Last edited by a moderator: Dec 11, 2012
  7. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,810
    Likes Received:
    1,563
    Under the Windows 8 compatibility web page these drives return as compatible:

    I tried entering your model number but no matches were found. I'll keep looking till something more definite crops up..

    https://www.microsoft.com/en-us/windows/compatibility/win8/CompatCenter/ProductViewerWithDefaultFilters?TempOsid=win8&Locale=en-us&TextSearch=iomega%2Bego%2B2tb&Type=Both&CurrentPage=0&TotalPages=1&ShowCriteria=0&SortCriteria=Relevance&Compatibility=Unknown&LastRequested=14
     
  8. CobaltDawg

    CobaltDawg New Member

    Joined:
    Dec 6, 2012
    Messages:
    10
    Likes Received:
    0
    Yeah mine is the 1.2 TB model. Its an older one, so its not really a surprise to me that it doesnt work. There is hope though. I just happen to have 2 500 GB Western Digital "Mybook" units from several years back. I quit using them because I was worried with them being so old, that they might die. The units are about 4 years old or so now.

    Seeing as I've only used 600 GB on the iomega, I've decided to use both of the WD drives as backup, just in case. Im currently using an XP machine from the office to copy everything from the Iomega to the 2 WD units. These 2 units are even older than the Iomega, so chances are, they might not work either. Havent tried them yet, and I was actually looking at purchasing a new HDD in the event that they dont...

    Toshiba Canvio Basics 1.5TB External USB 3.0 Portable Hard Drive Black HDTB115XK3BA - Best Buy

    Also, it appears the unit is on sale, though it ends tonight. I've been looking up the specs on it, and there is nothing that says that it wont work with 8. I think there might be an issue with the USB 3.0 ports on my laptop as well... Seems lots of hardware doesnt quite work as well as it should with them.. I've read several reports of 3.0 ports not functioning correctly with older equipment.

    What do you think of that Toshiba though? Should I purchase it just in case?

    ~Cobalt
     
  9. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,810
    Likes Received:
    1,563
    I checked the drive under the compatibility page and it's listed as compatible so the choice is yours.
     
  10. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    What type of USB port are you plugging into? Have you tried changing ports?

    Does the drive have its own software? An external drive will not normally need any drivers installed for USB, but some, like my new Seagate drive, have additional utilities you can install. I don't use the extra stuff, just the basic external drive functionality.

    It has always seemed to me that many external drive enclosures will cause the drive to run a little hot. If this is happening, it may shorten the lifespan of a drive.

    Have you checked into replacing the internal drive? But this might not help because the controller on the enclosure may be having the problem.

    And I keep my external devices on one system. Changing it between Win XP and Win 8 may not be good, but I don't really have any proof to offer.

    And the only other thing I might offer is if you look in Device Manger, the View menu and Show Hidden devices. In the USB section, there may be many greyed out entries. These, I believe, are prior connections and will be reused when a device is reconnected. Maybe someone else will know more, but you might try uninstalling any greyed out entries with the drive disconnected. But as kemical says..the choice is yours.

    Edit: I suppose you saw this?

    https://iomega-na-en.custhelp.com/app/answers/detail/a_id/31808
     
    #10 Saltgrass, Dec 11, 2012
    Last edited by a moderator: Dec 11, 2012
  11. CobaltDawg

    CobaltDawg New Member

    Joined:
    Dec 6, 2012
    Messages:
    10
    Likes Received:
    0
    Thank you for the article, I have not seen that.
    The drive that I have does not use any software packages or utilities.. its just a blank drive.
    I have tried the drive on both USB 3.0 ports and both USB 2.0 ports on the system, none of which show any differences.
    The drive itself does run slightly warm, though not HOT pre se.
    As far as keeping the drive on one system, my Iomega drive has always run on W7 since i bought it, so that very well might be the case, but I'm not entirely sure. It seems to me like a "USB Mass Storage" driver should work pretty much anywhere...

    The hidden devices option is showing TONS of drivers. Im not entirely sure which is which, though I did remember something...

    About two weeks ago, I bought a drawing tablet for use with my laptop. When I went to use it, it would connect, and then a few seconds later, would disconnect... and disconnect... and disconnect... It would simply keeping playing the "Device removed" sound over and over and over again, and the device itself would appear for about half a second in the "Devices" window. What was stranger, is that it was showing itself listed as a mouse even AFTER I installed the driver from the manufacturer. I knew something was wrong when I went to draw with it and the pressure-sensitivity was not working...

    Anyway, I found that driver with the hidden view you mentioned, and deleted it. Im not sure if that might have any effect on the current problem, but ill be sure to test it out later.

    Also, I have purchased the Toshiba HDD I linked in an earlier post... just in case!

    ~Cobalt
     

Share This Page

Loading...