Windows 7 computer won't automatically connect to wifi

Discussion in 'Windows 7 Networking' started by theMountinman, Mar 8, 2015.

  1. theMountinman

    Joined:
    Mar 7, 2015
    Messages:
    4
    Likes Received:
    0
    I'm able to connect to wifi, but I have to enter the password at every login. When I press the 'connect' button to connect to my network, the 'connect automatically' check box is always checked. Still, log off or reboot, and I have to manually connect each time.

    When I first moved into my current address and installed my provider's modem/router, connecting automatically to the wifi network worked as expected. At some point, perhaps a year ago, due to security concerns, I changed the password for the network. Since then, automatic connection has failed. I tried creating a new network on the modem/router and giving that network a new password (at the request of my provider) and that didn't fix the issue. I have tried updating adapter drivers, setting and resetting network properties, and even cleaning the registry to remove knowledge of the old network. Nothing has had any affect.

    Just last night, I installed a new modem/router from different internet provider. New network, same result. Clearly, there is something wrong with my Windows 7 networking, but I don't know how to fix it (other than to perform a clean reinstall of Windows, and I would really like to avoid that). Any assistence would be greatly appreciated.
     
  2. Spirit Wolfe

    Spirit Wolfe Well-Known Member

    Joined:
    Mar 14, 2014
    Messages:
    38
    Likes Received:
    2
    Try logging into Safe Mode: How To Start Windows 7 in Safe Mode [Easy, 5 Minutes] ...
    By pressing F8 before the Windows initial startup screen...

    Open the Device Manager (Control Panel >> Driver Manager) , press the little carrot so that the networking drivers are seen. While in Safe Mode delete the driver. Reboot computer and try logging into your WiFi network again.

    What Safe Mode does is a lot. But for the bridged version Safe Mode tells Windows to, in a sense, work in real mode and not the virtual one. This is so that you can troubleshoot not only windows drivers, but for other things as well. Furthermore, by running in Safe Mode you can tell if Windows has installed multiple drivers for the same piece of hardware (such as your WiFi NIC card).

    DELETE the driver (left click once on driver(s) and press the delete key). Do not worry if you do not have a backup Windows will take care of that for you. By deleting the driver under Safe Mode you are forcing Windows' hand to reinstall the driver from a local backup and or from the internet, automatically. If you did this without going into Safe Mode first then you would be using a copy of the driver that is resident in memory and Windows would automatically reinstall that driver from a cache copy of that driver rather than loading a fresh copy of one.

    Hope this helps...
    Cheers!
     
  3. theMountinman

    Joined:
    Mar 7, 2015
    Messages:
    4
    Likes Received:
    0
    Tried your suggestion (at least, I think I did). I rebooted in safe mode (which I had to do from msconfig, as my Asrock UEFI setup utility changes the boot options), and I deleted the driver for the wireless adapter (I'm assuming that's what you meant by 'network driver'). I then rebooted. Windows was not able to find a driver for the wireless adapter on the computer, so I had to connect a ethernet cable and download the latest driver. I installed it. I disconnected the ethernet cable and connected to the wifi. I then rebooted the computer. It did not automatically connect.

    I do appreciate your time. Thanks.
     

Share This Page

Loading...