Windows 8.1 - Black screen after update

tallon

Well-Known Member
#1
Hi,

Three weeks ago I started my PC as normal and got a black screen after I logged in. A program update box suddenly appeared so clearly nothing wrong with the graphics or screen, just Windows not working. After a lot of messing around (yeah, thanks for hiding 'safe mode', Microsoft) and restarting I finally got into safe mode with internet and searched for solutions. The best seemed to suggest it was a Windows/graphics driver issue and a 'roll-back' would solve it whilst I rolled back my graphics driver (nvidia).

This I did and it worked - and I then disabled Windows Updates to prevent it happening again, hoping that both nvidia and Windows would meanwhile provide a fix. Because I leave my PC on between Mon-Fri, I forgot about it. Next Monday when I started my PC I got the same issue again. Thinking that Windows must have gone into update mode when I shut it down (I hadn't watched it), I went through the roll-back procedure again, and checked Windows updates were turned off. Again.

Last Friday night when I turned it off, it went into update mode - so I just forced shutdown. When I turned it on this morning it updated Windows and then gave me, yet again, a black screen.

1. How can I absolutely guarantee that Windows updates are turned off? I'm obviously not doing it right.
2. How can I find out what's going on - it can't just be a rogue driver?

thanks,
d

System:
- Asus P8B75-M LX motherboard
- Intel Core i7 3770K at 3.5Ghz
- 16 Gb memory
- nVidia GeForce GTX 650 graphics card
- Win 8.1
 


kemical

Windows Forum Admin
Staff member
Premium Supporter
Microsoft MVP
#2
Hi,
Windows update updating ones drivers can be a pain. I always turn this off by going to Start and type in sysdm.cpl and press Enter. You should then see the System Properties box. Look for Hardware along the top and click that. You'll see a button for 'Device Installation settings' which you should click. Where it says 'Do you want windows to download driver software and realistic icons for your devices?' click 'No, let me choose what to do' and tick the box to automatically get device info. Remember to save your changes and click apply. This will now stop Windows update from installing drivers although as another precaution I also have my WU app set to automatically 'check' for updates but ask me whether to download and install them. This way you get check whats being installed and if need be remove it. Turning the windows update unit off fully really isn't a good idea although once configured like this you shouldn't have any further issues regarding driver installs.
 


ussnorway

Windows Forum Team
Staff member
Premium Supporter
#3
Just an idea but you did say you forced the shutdown... have you got Asus Wake service running?
Screenshot (155).png

Press [windows key] + [r] type "msconfig" (without quotes) and look at the services.
 


tallon

Well-Known Member
#4
Hi ussnorway - no, can't see Asus Wake anywhere in services. Thanks kemical for that suggestion, it'll buy me some time till I can find a solution.
 


tallon

Well-Known Member
#5
SOLVED: MY BLACK SCREEN ISSUE WAS CAUSED BY 'STARTISBACK' UTILITY
I started getting other errors such as:
- Error 0xc000021a
- Loginui.exe application error. The instruction at 0xdd0cb179 referenced memory at blah blah

and in searching THESE errors I found someone who said that 'startisback.com' utility had caused some of their issues - I use this utility too so I deleted it and now that's solved the issue and all is back to normal. Pheww.
 


Last edited:

kemical

Windows Forum Admin
Staff member
Premium Supporter
Microsoft MVP
#6
Fantastic! Much thanks for updating your thread also as this will possibly help others with the same issue.. :)
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.