Can't connect to home wireless signal ("Limited access") - Windows 7

hi i need to buy new adapter with this? or the problem is in my computer? or what if i change to windows xp?

hi thanks still no action anyone know how to fix unknown device in device manager USB ROOT HUB the first spot maybe this is the problem thats why my internet connection always drop thanks vincent

Hello, I have the same problem as the person who posted this thread and i tried solving this problem the way you posted, Trouble. But the problem is that i dont have BSS on the list what do i do?

I had same problems for months...
I'm using lenovo x201 with router, issues are quite similar to the previous ppl's, I can use my iphone and the other laptop with vista to access the wireless, but not win7 for the lenovo one. I went thru a lot of websites asking the problem, so far, I found yours seems to be the only one solved my problem. I don't have 802.11g though, two options, one 20m sth, the other is auto, I changed the setting from 20M one to auto, the speed immediately increased to 150M hz from very slow speed (which shouldn't be the case).
thank you so much and will let you know if if keeps working fine.

After some additional research, I have found others having similar problems with that particular card which evidently uses a Broadcom chipset.
Evidently the driver (new versions) default to setting the "BSS Mode" to 802.11n and some have found that changing that setting to 802.11g has resolved their issues. So....
Go back into device manager
expand network adapters
select then right click the problem wireless adapter and choose properties
select the "Advanced" tab at the top
In the left column titled "Property:" see if you have a BSS Mode listed. If so select it and in the right column titled "Value:" use the drop down arrow to change from 802.11n to 802.11g
OK your way back out of there and reboot and see if that helps.

This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.