DVD drive doesn't appear in File Explorer

Discussion in 'Windows 8 Help and Support' started by Roger Guitard, Mar 10, 2014.

  1. Roger Guitard

    Roger Guitard New Member

    Joined:
    Mar 10, 2014
    Messages:
    14
    Likes Received:
    0
    I've recently installed a second DVD drive, and it's not appearing when I open File Explorer. I see it listed in Device Manager, Disk Management, when I click on My Computer, and the drive works fine. Everything is fine except for its absence from File Explorer. Any ideas as to how to add it to the list of drives?
     
  2. bassfisher6522

    bassfisher6522 Essential Member

    Joined:
    Aug 27, 2008
    Messages:
    4,878
    Likes Received:
    317
    Try rebooting as see if windows file explorer will pick up.
     
  3. Roger Guitard

    Roger Guitard New Member

    Joined:
    Mar 10, 2014
    Messages:
    14
    Likes Received:
    0
    I've tried that several times, no change.
     
  4. badrobot

    badrobot Senior Member

    Joined:
    Jun 14, 2012
    Messages:
    1,020
    Likes Received:
    102
    Is there a drive letter assigned to the DVD drive? If not, go back to Disk Management and assign a drive letter there.
     
  5. Roger Guitard

    Roger Guitard New Member

    Joined:
    Mar 10, 2014
    Messages:
    14
    Likes Received:
    0
    It does has a drive letter assigned. Like I said, everything appears and functions properly, except for its absence from the list of drives in File Explorer.
     
  6. bassfisher6522

    bassfisher6522 Essential Member

    Joined:
    Aug 27, 2008
    Messages:
    4,878
    Likes Received:
    317
    Could you please post some screen shots: of file explorer, device manager and disk management.
     
  7. badrobot

    badrobot Senior Member

    Joined:
    Jun 14, 2012
    Messages:
    1,020
    Likes Received:
    102
  8. Roger Guitard

    Roger Guitard New Member

    Joined:
    Mar 10, 2014
    Messages:
    14
    Likes Received:
    0
    I've attached a screen capture of File Explorer, Device Manager and Disk Management. When booting up this morning, neither of my two optical drives are showing up in File Explorer, but both are working fine. Strange.
    Capture.
     
  9. badrobot

    badrobot Senior Member

    Joined:
    Jun 14, 2012
    Messages:
    1,020
    Likes Received:
    102
    Oh. You don't have to worry about it. It will show up if you have a disc on it. By default, they don't show up unless there's a disc loaded. It will not show up because there's no data to show. That's the computer's way of showing you if the DVD drive is empty or not. Did you notice, even your floppy drive A: is not showing because it is empty.
     
    #9 badrobot, Mar 10, 2014
    Last edited: Mar 10, 2014
  10. Roger Guitard

    Roger Guitard New Member

    Joined:
    Mar 10, 2014
    Messages:
    14
    Likes Received:
    0
    Well, how do you like that. I hadn't ever noticed that before, I suppose because I wasn't really watching for it. Thanks for straightening that out. As for the A: drive, I have no idea what that's all about, I've never had a floppy drive on this computer.
     
  11. badrobot

    badrobot Senior Member

    Joined:
    Jun 14, 2012
    Messages:
    1,020
    Likes Received:
    102
    Now, that's what you should be asking about. How did it get there? Haha. :)
     
  12. Roger Guitard

    Roger Guitard New Member

    Joined:
    Mar 10, 2014
    Messages:
    14
    Likes Received:
    0
    We have a mutual understanding, it doesn't bother me, I don't bother it!
     
  13. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    Joined:
    May 25, 2009
    Messages:
    6,041
    Likes Received:
    300
    Hi

    There is actually an option in the settings in Folder Options / View, to show or not show empty drives.
    If you want to see the drive all the time, change the option HIde Empty Drives in the Computer Folder.

    I have mine set to hide because my card reader makes it look like I have a half dozen hard drives.

    Mike
     
  14. badrobot

    badrobot Senior Member

    Joined:
    Jun 14, 2012
    Messages:
    1,020
    Likes Received:
    102
    Does that apply to optical drives?
     
  15. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    Joined:
    May 25, 2009
    Messages:
    6,041
    Likes Received:
    300
    Hi

    I guess it doesn't anymore, I think that it used to, I remember when my DVD drives didn't show unless I had a disk in them, but I just checked and they do now.

    I usually do have a disk in them so I didn't notice that they show all the time either way.

    I used to show an "A" drive too, even though I didn't have a floppy drive but that doesn't happen anymore either.

    You could probably remove it in Disk Manager.

    Wow, remember 5.25" floppy disks, think how little data they could hold, I don't even remember any more but it was only like 1 mb.

    What could you put on a disk that small now?

    Mike
     
    #15 MikeHawthorne, Mar 11, 2014
    Last edited: Mar 11, 2014
  16. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    How are your drives attached to your system? If they are SATA, which ports, since some SATA ports are not recommended for optical drives.

    If they are PATA, do you have them on the same channel and one set to slave?

    My DVD shows up in Explorer whether any media is inserted or not.

    As far as the Floppy, you might check you bios to see if there is an option for enabling one. Or it might have something to do with the problem.

    I did have a DVD once on a laptop that would no show up unless I opened the tray. But it did not work normally otherwise and needed a firmware update to make it work correctly.
     
  17. Roger Guitard

    Roger Guitard New Member

    Joined:
    Mar 10, 2014
    Messages:
    14
    Likes Received:
    0
    Both optical drives are SATA, and after installing the second one, the reason I was seeing my original drive and not the new one was that the original drive had a disc in it. I'm not bothered by this behaviour, but as far as a floppy drive showing, I don't have a clue. I disabled it in Device Manager, and all is well in my world again.
     
  18. Tor Arne Johansen

    Joined:
    Oct 30, 2015
    Messages:
    1
    Likes Received:
    0
    For me the trick to get the empty optical drive to show up in the File Explorer was:

    upload_2015-10-30_11-48-27.

    Before that, I had done all the other 'show empty drive in File Explorer' tips that I had found on the web...

    But it was not before I ticked of the 'Show all folders' in the File Explorer Options - View, that the empty optical drive showed up in the File Explorer navigation pane!

    upload_2015-10-30_11-54-45.
     

    Attached Files:

  19. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    Joined:
    May 25, 2009
    Messages:
    6,041
    Likes Received:
    300
    Hi

    I just got a notice that this thread was active again, and came back to say that now running Windows 10 final version, my Optical Drives do not show if they don't have anything in them unless I uncheck that box that says Hide Empty Drives.

    So that does still work.

    I don't have Show all Folders checked.

    If I do click Show all Folders then everything shows up!
    That's true even if I have Hide Empty Drives selected.

    Mike
     
  20. Angelsix

    Angelsix New Member

    Joined:
    Nov 2, 2016
    Messages:
    1
    Likes Received:
    0
    For me (after the latest major update) I had to uncheck "Hide Empty Drives" and check "Show all Folders" to get my optical drives to show up. I wish those Redmondites would make up their minds.
     

Share This Page

Loading...