Method to Disable Charms Bar

Medico

Senior Member
#1
I found this in another Forum. Many have asked how to do this:

For those (of us) that want to stay on the old familiar Desktop when using Win-8, having the charms bar pop up when we touch the right corners of the screen, is just not acceptable.
Here's a fix that removes that activity.

How to disable the Edge UI panels aka Charms Bar and Switcher in Windows 8
1. Open Registry Editor (press Win+R, type regedit.exe in Run dialog and press Enter) and go to key
2. HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\ImmersiveShell
3. Create here a new key “EdgeUI“.
4. Select the EdgeUI key in the left pane and create two new DWORD values in the right pane of Registry Editor.
⦁ DisableTLcorner – stands for “Disable Top-Left corner”. Set it to 1, and Switcher will not appear when you move your mouse to the top-left corner of the screen. Note that it will still appear if you move the pointer to the bottom-left corner and then move it upwards along the left edge of the screen.
⦁ DisableCharmsHint – Set it to 1 to disable the Charms bar when using the mouse. It will not appear when you move the pointer to the top-right or bottom-rights corners. But as above, if you move the pointer to the top-right corner and then move it down along the right edge of the screen (or from the bottom-right corner up to the screen center along the right edge), it’ll appear again.
http://winaero.com/blog/wp-content/u...y_settings.png

Both settings prevent the Edge UI panels from appearing accidentally. They will take effect immediately - you do not need to restart Windows Explorer or log off. You will still be able to show them when you actually want to use them.

If you want to enable the default behavior of Switcher, simply set DisableTLcorner value to 0 or delete it. Same goes for DisableCharmsHint value – set it to 0 or delete it to enable the Charms Bar popup.

For those who prefer ready-made registry files:
Download Edge UI Tweaks, found here:
http://winaero.com/blog/wp-content/u.../08/edgeui.zip (Download link is near bottom of page.)

Now we can enjoy our Desktop in peace.
Very Cool!. The Charms Bar is still available, but does not pop up until you actually put your cursor in the Top, Right or Bottom Right corner and slide it along the right edge, then Charms pops up. Gives a way to not have Charms pop up when you do not want it, but still have it easily available when you wish to use it. This is a hack many were asking for.

This does work with my Win 8 Ent. Eval. edition. I used the automatic Registry option and it worked like a charm.
 


hb860

New Member
#2
hehe, I see my article here =)
 


Andrea Borman

Honorable Member
#3
There is another easy way to disable the Charms bar. And that is to install the latest version of Classic Shell. Since Classic Shell 3.6.0 the new version, you can now boot straight to the desktop,skipping the Metro start screen.And now in 3.6.1 the latest version,there is a setting to enable or disable the charms bar.

I use Classic Shell on my Windows 8. And while I have the Windows XP start button and start menu and have enabled boot to the desktop. I have not disabled the Charms Bar as it is still handy if I want to go to the Metro start menu. While still on the Windows XP or Windows 7 start menu. Andrea Borman
 


davehc

Essential Member
Premium Supporter
#4
I am not finding the charms bar a great nuisance. I am aware it is there and in the event that I do accidentally hit it, it is but an instant to clear again.
But, Andrea, if I understand your comment, doesn't the Windows key bring up the Metro screen? It is the default, and should do so.
 


#5
I am not finding the charms bar a great nuisance. I am aware it is there and in the event that I do accidentally hit it, it is but an instant to clear again.
But, Andrea, if I understand your comment, doesn't the Windows key bring up the Metro screen? It is the default, and should do so.
 


Andrea Borman

Honorable Member
#6
No,David,If you have Classic Shell installed on Windows 8 pressing the Windows key brings up the Classic Shell start menu instead of the start screen as it is set to do that by default. Just as the default settings now enable you to boot to the desktop. But you can change those settings in the settings menu in Classic Shell to disable this. The same as you change change the settings to enable or disable the Charms bar.

It is the same with Start Menu 7 although I don't think that it disables the Charms bar like Classic Shell. There are other new settings on Classic Shell. Classic Shell 3.6.0 and later versions, now enables you to change the start button or start orb on Windows 7. You can create your own custom button using a bitmap image. So now I have the Windows XP start button on my Windows 7,along with the Windows XP start menu. Andrea Borman.
 


davehc

Essential Member
Premium Supporter
#7
Andrea. Have another peek at the Classic customisation.
 


Last edited by a moderator:
#8
They fixed the Charms Bar in the release version. You now have to move your mouse all the way to the upper right/lower right corner to where it stops before it pops up. It'd be kind of difficult to do that by accident now. :)
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.