Poor video quality

Discussion in 'Windows 7 Help and Support' started by zurih, Jan 11, 2009.

  1. zurih

    zurih New Member

    Joined:
    Jan 10, 2009
    Messages:
    54
    Likes Received:
    0
    Hey,
    Anyone maybe noticed poor video quality after installing Windows 7?
    It's more fuzzy and like little blocks in videos.
    I tested the same videos under Windows XP and they look great.

    Have installed the latest NVIDIA drivers but it didn't help.

    Any suggestions of that would it be?

    Thanks
     
  2. Radenight

    Radenight New Member

    Joined:
    Nov 16, 2008
    Messages:
    4,525
    Likes Received:
    108
    Did you install the Windows 7 driver from Nvidia or the latest Vista driver? I've heard some other people having problems with Nvidia's Windows 7 driver as well... try installing the latest Vista driver and see if that helps.. I'm using an ATI card and all my videos look amazing on Win 7... You could also (if you haven't already) try using a different player then WMP.. VLC works very good in Win 7....;) Also there is a new version of Divx out, that might help too...
     
    #2 Radenight, Jan 11, 2009
    Last edited: Jan 11, 2009
  3. Ageless Stranger

    Ageless Stranger New Member

    Joined:
    Jan 11, 2009
    Messages:
    16
    Likes Received:
    0
    Sounds like a codec issue to me
     
  4. iroken22

    iroken22 Extraordinary Member
    Premium Supporter

    Joined:
    Nov 10, 2008
    Messages:
    1,649
    Likes Received:
    49
    Also remember "BETA" comes after the windows 7 name so it may just be a matter of time until they come out with a decent driver for your card.
     
  5. Moosetek13

    Moosetek13 New Member

    Joined:
    Jan 10, 2009
    Messages:
    282
    Likes Received:
    5
    I haven't tried video files, per say, but I do notice that my TV through Media Center is lower quality.
    I was trying to find the Video Codecs in Device Manager to adjust it, but they are no longer listed with the other sound and video devices (audio codecs also don't show there anymore).

    Anyone know if they are accessable somewhere else?
     
  6. BlackWolf

    BlackWolf New Member

    Joined:
    Jan 11, 2009
    Messages:
    286
    Likes Received:
    9
    hi,
    could you tell me which ati drivers you use? are you using the windows 7 beta ones?

    Because I got an ATI HD 4870 and use the Windows 7 Beta Drivers and I have really poor video quality as well amongst all video players. they are just really blurry if you watch them full screen. I tried installing the "old" vista drivers for ati, but ati installer doesn't finish the installation (it just keeps "gathering system information" forever), don't know why.

    everything worked fine using vista and the problem occurs in every video player, so it's either a windows 7 problem or an ati-driver problem. When I switch to OpenGL-video output in vlc media player the video looks fine but lags A LOT on fullscreen

    regards

    PS: I use the 64bit version of windows 7 which seems to have more issues than the x86 version, maybe this only occurs on x64?

    PPS: Can't be a codec problem since vlc ships with all the codecs, it doesn't care at all what codecs you have or havn't installed on your system.
     
    #6 BlackWolf, Jan 11, 2009
    Last edited: Jan 11, 2009
  7. zurih

    zurih New Member

    Joined:
    Jan 10, 2009
    Messages:
    54
    Likes Received:
    0
    I tried VLC, WINAMP, WMP, and almost every other player there is... same issue...
    I also tried to install the latest vista nvidia drivers, and it didn't seem to help on anything....
     
  8. zurih

    zurih New Member

    Joined:
    Jan 10, 2009
    Messages:
    54
    Likes Received:
    0
    I use k-lite codec.
    Do you have anything different do offer maybe?
     
  9. Ageless Stranger

    Ageless Stranger New Member

    Joined:
    Jan 11, 2009
    Messages:
    16
    Likes Received:
    0

    If ffdshow doesn't help then ignore my comment about codecs, from your description is sounds like macroblock decoding went awry. However, if it isn't decoding, then it must be rendering. Is the DirectX the "stock" directX ?
     
  10. iroken22

    iroken22 Extraordinary Member
    Premium Supporter

    Joined:
    Nov 10, 2008
    Messages:
    1,649
    Likes Received:
    49
    1. Right-click on Computer
    2. Select Properties from the context menu
    3. Click Advanced System Settings on left
    4. Click Environment Variables
    5. Click New
    6. In the variable name put devmgr_show_nonpresent_devices
    7. In the variable value put 1
    8. Click Ok three times

    Now go to Device Manager and Go to View and click show hidden Devices. See If that helps with the codecs
     
  11. zurih

    zurih New Member

    Joined:
    Jan 10, 2009
    Messages:
    54
    Likes Received:
    0
    Yeah I haven't touched DirectX. When I run dxdiag it says I have DirectX 11 installed.
     
  12. zurih

    zurih New Member

    Joined:
    Jan 10, 2009
    Messages:
    54
    Likes Received:
    0
    And also tried installing ffdshow, still same poor quality...
    what a hell is going on here...
     
  13. BlackWolf

    BlackWolf New Member

    Joined:
    Jan 11, 2009
    Messages:
    286
    Likes Received:
    9
    havn't touched directx as well and I am using ffdshow ...
    I tried iroken's tip but it didn't change anything. I noticed that when I close the device manager and restart it, "show hidden devices" isn't clicked anymore.

    I upgraded from windows vista instead of installing a fresh windows 7, maybe that has something to do with it?

    oh and btw: what is ffdshow and is there a way to re-install it? maybe that helps but I don't even know what it is, just that I have it :D

    regards

    Edit: Noticed something strange ... I uninstalled all codecs on my pc and installed the newest version of ffdshow tryouts. But when I play a video in vlc no ffdshow icon appears in my superbar - isn't it supposed to?
    Then again, I don't know if vlc uses ffdshow
    Is there any other version I should try or any setting in ffdshow that needs to be activated in particular?

    PS: Like I said before, OpenGL works "fine" regarding the quality of the video, it's only blurry when using directx ... so maybe it's related to DX11?
     
    #13 BlackWolf, Jan 11, 2009
    Last edited: Jan 11, 2009
  14. Ageless Stranger

    Ageless Stranger New Member

    Joined:
    Jan 11, 2009
    Messages:
    16
    Likes Received:
    0
    ffdshow = Free open source codecs based on ffmpeg, very highly rated.

    Didn't take long to get to the crux of the matter, DirectX
     
  15. Moosetek13

    Moosetek13 New Member

    Joined:
    Jan 10, 2009
    Messages:
    282
    Likes Received:
    5
    Thanks, but they still don't show up.

    Several things did, mostly Microsoft Streaming ... Proxy stuff.
     
  16. BlackWolf

    BlackWolf New Member

    Joined:
    Jan 11, 2009
    Messages:
    286
    Likes Received:
    9
    btw, another thing I just noticed is that the videos show perfectly fine when showing them in their normal resolution. They are only messed up on fullscreen (kind of like a picture gets really blurry when you zoom it)
     
  17. 2128

    2128 New Member

    Joined:
    Jan 11, 2009
    Messages:
    34
    Likes Received:
    0
    I use Winfast PVR2, which by default uses VMR9 rendering. Looks like absolute ass, quite frankly. However, when I switch it to Overlay rendering, it looks far, far better - at the price of killing Aero off. This also gives me no wallpaper until I reboot. Very odd.
     
  18. muyoso

    muyoso New Member

    Joined:
    Jan 11, 2009
    Messages:
    36
    Likes Received:
    0
    I have full 1080P videos playing flawlessly on my install. I am running 64 bit Windows 7, using Media Player Classic, VLC, and PowerDVD Ultra. DXVA hardware acceleration is working fine as well. It sounds like you are having codec issues possibly. Do you have a sample video that looks terrible on your computer that you could point us to, so we can see if we can replicate the problem?

    Well that is your first problem. K-lite codec pack is absolutely not needed. VLC on its own should play almost all file types without additional codecs needed. When you find a video that it doesnt play, which is rare, its much smarter to just install what you need rather than dozens of codecs which conflict with each other and are overkill.
     
    #18 muyoso, Jan 11, 2009
    Last edited: Jan 11, 2009
  19. 2128

    2128 New Member

    Joined:
    Jan 11, 2009
    Messages:
    34
    Likes Received:
    0
    I honestly doubt it's a codec issue. It would be affecting VLC and WMP/etc differently if it was.
     
  20. BlackWolf

    BlackWolf New Member

    Joined:
    Jan 11, 2009
    Messages:
    286
    Likes Received:
    9
    Alright so I checked again after this post and noticed that only VLC has issues after re-installing ffdshow, so I guess it's a vlc-internal problem. Don't know if others still have issues on all media players. That doesn't really help a lot because windows media player has sucky quality anyways and I really want to play my videos with vlc - but it's a start. Does anyone know if you can force vlc to use the system codecs? maybe that would help since media player seems to play the videos "fine" (it's still not really good quality - for example black parts have a lot of grey in them in WMP, but as far as I know WMP always did that and at least the videos don't get all blurry, the videos play perfectly on VLC on my mac btw so I know it's not an issue with the video).
    Don't know, maybe the problems will be back when I get home from work in WMP but we'll see ...

    thanks for your help so far
     

Share This Page

Loading...