USB 3.0 Problem

#1
I use windows 8. Recently I have bought an external hard disk[toshiba] with USB 3.0 support. I have one port in my laptop with USB 3.0. My every hardware drivers are up to date[Including my BIOS]. The problem is when i connect hdd to 3.0 port, what i get is 2.0. [There's a light that show up white colour if it's 2.0 and blue if it's 3.0]. I have google-ed this issue many times and i did not get a solution that works for me.

Now this is the part i don't understand. I do get blue light when i connect hdd to my 3.0 port and restart my pc. After that it becomes blue light and show installing device[only for the first time i got 3.0. Installed to Devices and Printers]. I could take off and plug in my USB at that time and get the speed of 3.0. But after another restart[or shutdown], it goes back to 2.0. Now my HDD is installed in Devices and Printers. There, its written in my status of my USB HDD that it could run a lot faster if it's connected to USB 3.0. After another restart I might get 3.0 again but now always. What i understand from this is my usb port that supports 3.0 don't recognize the port as 3.0 sometimes [not always] and uses my USB HDD as 2.0. In my other PC, i could connect my USB HDD whenever i want and get 3.0, so it's not a problem with USB HDD. I think some services in windows or some stuff needs to work to detect my port as one that supports 3.0. But i have no idea what to do. That's where i need help or if I'm wrong, please correct me.

Thank you.
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#2
One thing to check might be some of the bios settings. Some systems have a fast boot type of operation that may not initially start some USB ports and other items. If your system has such a setting, you might try turning it off. Also check the settings for the USB and see what is enabled, such as EHCI (not completely sure about the exact letters) to see if it is enabled or disabled.

In Device Manager (devmgmt.msc) you might compare the entry for and the properties of the xHCI Root Hubs and the eXtensible Host controllers to see if they might be present or different when the 3.0 is active. Make sure and check the Properties-Driver-Driver Details to see what drivers are loaded.

How are you removing the drive, with the Safe Removal or just unplugging it? The Properties-Details-property-Safe Removal Required might tell you which way you need to disconnect it. Also how the drive is set up in it Properties-Policies tab.

Are you loading any specific drivers for the 3.0 or using the Windows 8 ones?

Are there any bios updates that might effect the operation?
 


Joe S

Excellent Member
#3
I see on the WD forums that USB 3 seems to have a lot of problems in general. Try deleting the external drive's driver, disconnect drive, reboot system then reconnect drive. Try the same with the USB 3 driver. On reboot that should load fresh drivers. Logitech has been a frequent culprit in corrupting drivers. If you have a USB 3 addon card check the manufacturer's site for updates.
Joe
 


#4
Thank you for your reply,
In Device Manager, Under Universal Serial Bus Controllers, there's 3 USB Root Hub(one of them with XHCL). As i read in Wikipedia, XHCL is the one that controls version 3.0. There was an option in it's properties that allows my PC to turn it off to save power. I use Power Saver option at times to save time. I unchecked it and restarted [shut down -> power on] my PC. I still get a white light. I've experimented with this and what i find right now is If my USB 3.0 is connected to my PC before Windows is booted, then i get white. If it's connected after, i mostly get blue. I got white one time this way at the first try. Restarting[not shutting and opening] does not affect the blue light when its showed up. My BIOS are up to date but does this thing got to do anything with the BIOS or OS?

@Saltgrass,
I have fast boot option in bios, but it's not enabled.
I remove my HDD only after I select Safely Remove.
I'm using the Windows 8 ones. There's no other driver for USB 3.0 in Toshiba's drivers list for my model[not one year old].
Bios are updated well. There are not.

How to check EHCI is enabled or not? It's says in the Device Manager that all my USB things are working properly.

@Joe,
I did try removing the driver and re-installing it. And I did remove the device in Devices And Printers and re-installed it.
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#5
EHCI is a bios setting under the USB section. It is used, I believe, for a backward capability. On my system, it is disabled by default, and yours probably is also, but something to check.

Some folks initially had some problems with the 3.0 drivers in Windows 8. I never did, but perhaps Toshiba does not quite have it worked out. I will see if I can find a user's forum for their stuff. Maybe someone else has the same situation as you. I will assume your external is not part of the problem, but having another device to verify might eliminate that possibility. Flash drives do not really count, since they are not very fast either way, but I don't have a blue light to indicate 3.0 :waah:.

Make sure and compare the drivers for the root hub and controller during times when the blue light is on and off. It might show a driver is not being loaded.
 


davehc

Essential Member
Premium Supporter
#6
I have had the problem with different models. I have always found that going to the computer manufacturers original driver download page, has solved it.

Confirm that you have tried. For example here:

http://www.official-drivers.com/installer/?seed=Toshiba&v=2&gclid=CMK_xaLi77kCFbN3cAodrQ8A3A

or

http://www.toshiba.eu/innovation/download_drivers_bios.jsp?service=EU
 


#7
I've uploaded some images when the USB 3.0 is working as 2.0. And I've discovered that when USB 3.0 External HDD is connected before the boot of my OS, it opens as 3.0.

@davehc,

I've got no more drivers left to install.

@Saltgrass ,

It's already enables in my bios.
 


Attachments

Saltgrass

Excellent Member
Microsoft Community Contributor
#8
@Saltgrass , It's already enables in my bios.
In my system, EHCI Hand-off is Disabled in the Bios, you might try that.

Edit: I will go over your attachments and see if I notice anything. Is the Realtek USB 2.0 card reader built-in or have you added it?
 


#9
@Saltgrass ,
There's no EHCI Hand-off option in my BIOS. See the images of my BIOS. That's all the options i got.(others are boot,time and quit)

I added Realtek USB 2.0 Card Reader driver from Toshiba site. The images i uploaded before was when my PC detected 3.0 as 2.0. I've uploaded how it look like when the blue light appears. See the status of External USB 3.0 in Devices And Printers both in this post's picture and the picture from my last post.
 


Attachments

#10
Does this 2 days of no reply mean that there's no solution to this? I can use 3.0, but every time i connect my HDD, i must restart my PC for it to work.
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#11
Sorry, I wrote this earlier but did not post it.

The bios does have a Legacy USB setting you could try changing.

I was also wondering if there might be drive letter conflicts with the Realtek card reader since any reader ports it has, will be assigned a drive letter. So the Realtek reader was built-in?

It still could be related to your external device. It might be misbehaving or its current condition might effect how it is seen later.

But I do not have a good answer for you.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.