WIN 10 Microsoft's applications crashing, Start menu and available wifis

#1
Hello

Firstly I'm going to say that I'm familiar with the win 10 start menu problems and I've fixed them before. The fix now just does not work. Also this problem is a multiparter with start menu being just one area affected.

Getting down to business:

A week ago Microsoft's products started crashing on me. Visual Studio and Server Management Studio mostly that is.

I debugged the SSMS and it lead me to type exception in one of the dll files in windows folder. I also checked the crash event report and it was one with id number 1026 (iirc).

The problem being in the window's own dll file I couldn't go forward with the investigation. I tried to get a hang of things and checked If my win 10 user account was somehow bugged. After creating a new account (a copy of my admin account to my knowledge) I noticed that I'm completely unable to log into it. Trying to do just that caused a short black blink only to return to login screen again.

Thinking my account was corrupt I used the win 10 "fresh start" function. After that I installed all the drivers from ASUS' web page. Now the problem is that the win 10 start menu is broken and I can't see any available wifi connections on the system tray menu (the one in bottom right).

Being familiar with the start menu bug I did what I knew but the fixes did not work. Checking the %LocalAppData% folder I couldn't find the folder that has the serialized information at all. (To my knowledge it is there that windows saves the path data to applications and offers them on the start menu).

Debugging the wifi problem I conducted that wifi drivers and component are working. In cmd menu I was able to see all the available wifi networks just fine. I just don't know how to connect to them with all the connections being invisible to the Win 10 GUI.

That's all my current skills with win 10 can do. This being my school computer for IT studies it is of utmost importance I get it to up and running as soon as possible.

Help me learn how to deal with the situation, please! :)


"Give a man a fish and you feed him for a day; teach a man to fish and you feed him for a lifetime." - Goes well with the situation here!

Cheers!
 


#2
I want to add that the post bloated because I wanted to make sure I tell everything I tried already so I can have new solutions suggested.
 


Neemobeer

Windows Forum Team
Staff member
#3
If there is corruption in Windows the first commands you should run are the following

sfc /scannow if it finds any problems it will attempt to repair, reboot and repeat until there are no errors
chkdsk /f C: this command will require a reboot for it to run
 


#4
I did the scan earlier with a result: "Windows Resource Protection did not find any integrity violations".

With the command chkdsk I'm unfamiliar with. Worth a shot then?
 


Neemobeer

Windows Forum Team
Staff member
#5
Yes
 


Neemobeer

Windows Forum Team
Staff member
#6
As for your start button issue, does it not respond when you click on it?
 


#7
As for your start button issue, does it not respond when you click on it?
Ahaa! Maybe I was a bit vague on that part. It is responsive to clicks. It is very unaware about the computer though. It has no information about the system nor installed programs.
 


Neemobeer

Windows Forum Team
Staff member
#8
You can try resetting it with How to reset the Windows Start Menu

another possibility would be to run procmon and look for access denied for ProgramData which is where most of the start menu application entries are.
 


#9
Okay firstly, I did the chkdsk /f C: -command and it ran on start-up without anything coming up.

Secondly. from your tutorial I got the following message:
PS C:\WINDOWS\system32> Set-ExecutionPolicy -Scope LocalMachine -Policy Unrestricted
Set-ExecutionPolicy : A parameter cannot be found that matches parameter name 'Policy'.
At line:1 char:41
+ Set-ExecutionPolicy -Scope LocalMachine -Policy Unrestricted
+ ~~~~~~~
+ CategoryInfo : InvalidArgument: :)) [Set-ExecutionPolicy], ParameterBindingException
+ FullyQualifiedErrorId : NamedParameterNotFound,Microsoft.PowerShell.Commands.SetExecutionPolicyCommand

I need to look into that more since at first glance it makes little to no sense to me.

And lastly I just opened up procmon and with the huge bulk of data on the screen I think I need to look into some more documentation before I understand what's on the screen.

Thank you for the help and time so far Mr. NeemoBeer!
 


#10
Hmm interesting thing. My "access control entry is corrupt" it says still even after the "fresh start". I wonder what's going on. If it's a really malicious virus or what. I do not have anything pirated though and I've been keeping up with all the updates at all times. Investigation continues haha.
 


#11
[SOLUTION]?

For anyone having the same problem:
I did not get the wifi UI working but it is possible to connect to available wifi networks through cmd. This is more of a work around than a solution but:
-Netsh commands have all you need.
-Netsh wlan show all
-Netsh wlan show interfaces
-Netsh wlan show networks
-Netsh wlan connect ssid="Wireless net" name=profile1 interface="Wireless network connection"

Start menu refuses to operate still after all the suggestions above and the ones found in the internet. I also ran new indexing on my both HDD and SSD resulting to nothing.

I'm starting to wish I could go back to win 8 haha.

Cheers!
 


Neemobeer

Windows Forum Team
Staff member
#12
I've seen this (the wifi issue) happen due to bad updates. Either a new update may fix it, but the fact that you have so many other issues it may be quicker to do a clean install.
 


#13
I've seen this (the wifi issue) happen due to bad updates. Either a new update may fix it, but the fact that you have so many other issues it may be quicker to do a clean install.
Yes, unfortunately that might be the case. I'm also thinking about going back to Win 8 as it is free to download for students in my school. I have to look into how well it suits the Asus laptop though. It came pre-installed with Win 10 and I'm not sure whether it'll work or not (driver compatability and all that).

It would be really interesting to know, though, what caused all this.

Thanks again for the great help! Keep it up and have a nice day!
 


Neemobeer

Windows Forum Team
Staff member
#14
I wouldn't go back to 8 it will be end of life in January.
 


#15
I wouldn't go back to 8 it will be end of life in January.
Oh shoot! I really liked XP, 7 and 8! Not the biggest fan of 10 though. Let's hope for good news about the next OS from MS soon!
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top