Win8 lost activation (even though I own an original key)

Discussion in 'Windows 8 Help and Support' started by gygabyte017, Mar 24, 2013.

  1. gygabyte017

    gygabyte017 New Member

    Joined:
    Mar 24, 2013
    Messages:
    2
    Likes Received:
    0
    [SOLVED] Win8 lost activation (even though I own an original key)

    Hi to everybody, here is the problem:

    About twenty days ago, win8 did some automatic updates, it rebooted, but after that "update failure, rolling back" with error code 0x800f0922.
    Since that moment:
    - it does not install any other update (same error code for everything). I "cleaned" windows update with a procedure described online, in a way that it restarts from scratch, but same thing happens. I've even tried with winupdate diagnosing app which indeed fixes something, winupdate seems to work but after reboot same error again
    - every some hours it appears a message like "please activate windows" (it never did it up to now); now, I bought this pc with a licensed win8, so clearly my win is original, but if I click on "activate" it says "unable to activate please contact microsoft" (I have internet connection etc etc, no firewall no antivirus etc etc).
    - I tried to restore my win key with an app which is designed to this purpose (I backupped my win key several months ago): it says "unable to restore win key" too.
    - I tried to restore a restore point of about 30-40 days ago, but after it restored it successfully, same problems again.

    What can I do to fix this?
    Summary of the problems: 1) win8 lost activation and can't reactivate win even if it is original 2) every update fails with error 0x800f0922.

    Any help would be hugely appreciated,
    thank you in advance, I'm getting crazy!

    Regards
     
    #1 gygabyte017, Mar 24, 2013
    Last edited by a moderator: Mar 24, 2013
  2. patcooke

    patcooke Microsoft MVP
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    May 16, 2010
    Messages:
    5,454
    Likes Received:
    268
  3. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
  4. gygabyte017

    gygabyte017 New Member

    Joined:
    Mar 24, 2013
    Messages:
    2
    Likes Received:
    0
    Ok thank you guys, I might be closer to the solution.
    I succeeded in installing all updates.

    Anyway, win8 keeps not activating. So, I found on the internet that there is a command "slmgr" which deals with win activation. I tried "slmgr /rearm" which should try to reactivate win, but it says: Error: 80070422. I found out that this error is linked to Software Protection Service which may not be running. So, I executed C:\Windows\system32\sppsvc.exe to reenable it, and it says: "sppsvc: bad image. guard64.dll is either not designed to run on windows or it contains an error. [...] Error status 0xc0000428".

    So I guess that's it. This dll is most likely damaged, and it should deal with the activation problem.

    New updates: I found out that guard64.dll is linked to Comodo AntiVirus. I completely removed Comodo, and now sppsvc does not give that error anymore. Anyway, its service won't start. It is set on "disabled" and there is no way I can set it on "automatic" start. Everything is grayed.
    I think starting this service would solve everything. But I can't edit any setting in sppsvc service config. I even tried in safe mode, every option is always grayed and disabled. (Clearly if I do the same thing on other services I can change configs without problem). It seems to me a privileges issue, but I am admin of the machine.

    New updates2: I manually set the service start type in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\sppsvc to Start=2, rebooted, and now the service starts!!
    Windows finally is activated!

    Thank you very much!
     
    #4 gygabyte017, Mar 24, 2013
    Last edited by a moderator: Mar 24, 2013
  5. patcooke

    patcooke Microsoft MVP
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    May 16, 2010
    Messages:
    5,454
    Likes Received:
    268
    Well done! And thanks for the feedback.
     

Share This Page

Loading...