Cannot connect with wireless

#21
solved that but back to zero again... now changing the channel doesn't seem to work...
 


patcooke

Microsoft MVP
Staff member
Premium Supporter
Microsoft MVP
#22
Try going back to device manager, removing the adapter and rebooting.
 


#23
Try going back to device manager, removing the adapter and rebooting.
tried that...didn't work.. after working it stoped because it entered in sleep mode... any clue why?
 


#24
that's tought
 


Trouble

Noob Whisperer
#25
Power management is always a pain when it comes to networking, since the whole concept of networking is built around the idea of high availability and up-time and your laptop is built with the whole green environment concept in mind there is inherently a problem. Which might be compounded and complicated by poorly written software (drivers and or manufacturer's proprietary power management). You can change any number of settings in various places within Windows 7 (device manager, control panel power settings) to prevent this, but it will in all likelihood also prevent your laptop from sleeping and or hibernating, etc,.
First double check and make sure you still have the 9.2.0.113 driver installed and that removal and rebooting hasn't replaced it with some generic microsoft driver.
It is possible that your Router Manufacturer has a firmware upgrade available for that router but I cannot find a D-Link DIR-300 anywhere on D-Link's site. And a revision number is the number of the current software installed and should be on a label, possibly on the bottom of the router, if not then you can probably assume it is the first iteration of router's OS.
Have also read a couple complaints regarding the particular wireless card installed in that laptop as being "weak", so consider that proximity might be an issue regardless of what signal strength any software is indicating and move the laptop close to the router for testing.
 


#26
Power management is always a pain when it comes to networking, since the whole concept of networking is built around the idea of high availability and up-time and your laptop is built with the whole green environment concept in mind there is inherently a problem. Which might be compounded and complicated by poorly written software (drivers and or manufacturer's proprietary power management). You can change any number of settings in various places within Windows 7 (device manager, control panel power settings) to prevent this, but it will in all likelihood also prevent your laptop from sleeping and or hibernating, etc,.
First double check and make sure you still have the 9.2.0.113 driver installed and that removal and rebooting hasn't replaced it with some generic microsoft driver.
It is possible that your Router Manufacturer has a firmware upgrade available for that router but I cannot find a D-Link DIR-300 anywhere on D-Link's site. And a revision number is the number of the current software installed and should be on a label, possibly on the bottom of the router, if not then you can probably assume it is the first iteration of router's OS.
Have also read a couple complaints regarding the particular wireless card installed in that laptop as being "weak", so consider that proximity might be an issue regardless of what signal strength any software is indicating and move the laptop close to the router for testing.
I tested the power saving issues before... nothing seems to help... as for the porximity... if i cannot connect to a router with a bigger distance than mine then its useless even to connect... my router is right by my side since the beginning
no DIR-300? really? it's 3 years old... it's firmware is up to date, but i can't connect to any wireless network, not just mine, so i believe is my card or any setting in my notebook... though it's brand new... and the wireless card driver is 9.2.0.113.
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#27
Since the problem still exists, I will spout some more observations..... :)

Your lease is one day, which I will assume is set in the router that way.

Your IPCONFIG readout seems to be mising some things, which may be normal for you or you removed them for security.

Win IP Configuration
Primary DNS Sufix
DNS Suffix Search List

Ethernet Adapter
Connection Specific DNS Suffix

Just seems strange these are all related to DNS

I always disable the other Network Adapter if I have two installed. So I would try disabling the wired one if you have not already.

Since the connection is lost when the system sleeps, the fact it worked before may have meant the settings were just right for the connection to be made. Since it lost that one, it seems to be having problems making another one. So along this line, I would check the router and set a channel like 7 or 8 for testing. Then from the wireless, use the ipconfig /renew to see if it will resync.
I suppose clicking the wireless symbol in the System Tray does not list any wireless networks and therefore no signal strength?

Sorry if I am repeating prior tries...

Edit: You do have the router set up to broadcast the SSID?
 


Last edited:
#28
Since the problem still exists, I will spout some more observations..... :)

Your lease is one day, which I will assume is set in the router that way.

Your IPCONFIG readout seems to be mising some things, which may be normal for you or you removed them for security.

Win IP Configuration
Primary DNS Sufix
DNS Suffix Search List

Ethernet Adapter
Connection Specific DNS Suffix

Just seems strange these are all related to DNS

I always disable the other Network Adapter if I have two installed. So I would try disabling the wired one if you have not already.

Since the connection is lost when the system sleeps, the fact it worked before may have meant the settings were just right for the connection to be made. Since it lost that one, it seems to be having problems making another one. So along this line, I would check the router and set a channel like 7 or 8 for testing. Then from the wireless, use the ipconfig /renew to see if it will resync.
I suppose clicking the wireless symbol in the System Tray does not list any wireless networks and therefore no signal strength?

Sorry if I am repeating prior tries...

Edit: You do have the router set up to broadcast the SSID?
changing the channel returned no results and acctualy i CAN see the networks but cannot connect... yet disabling the wired connection seem to have solved the problem!!!! maybe at the first time i disabled it...

again i thank everubody for helping me out... if i come across any other problem i shal contact you guys!!

thanks!!
 


#29
ok, third round.. ceased working again.. it stopd 3 days ago, but i was busy with other stuff so i didn`t post it.... it worked for like 25 min the last time... i restored the PC to factory install... nothing... and now it's the same thing, but with one more detail... the name of the network appears wrong, for example :

gdematos appears gdematks and it trades other characters i=j...

maybe it`s just an hardware issue...
 


#30
just for common knowledge... i tried every step you guys suggested befeore after restoring the notebook..
 


patcooke

Microsoft MVP
Staff member
Premium Supporter
Microsoft MVP
#31
ok, third round.. ceased working again.. it stopd 3 days ago, but i was busy with other stuff so i didn`t post it.... it worked for like 25 min the last time... i restored the PC to factory install... nothing... and now it's the same thing, but with one more detail... the name of the network appears wrong, for example :

gdematos appears gdematks and it trades other characters i=j...

maybe it`s just an hardware issue...
That looks like it could be data corruption - losing/picking up bits. That can be due to connection speed problems (have you got both pc and router set to use the same wireless protocols rather then automatic setting. Also could be due to "noise" - it's one thing to have a good strong signal but you can get too close (like having your ear too close to a loud audio signal) and suffer overload.
 


#32
That looks like it could be data corruption - losing/picking up bits. That can be due to connection speed problems (have you got both pc and router set to use the same wireless protocols rather then automatic setting. Also could be due to "noise" - it's one thing to have a good strong signal but you can get too close (like having your ear too close to a loud audio signal) and suffer overload.
as for the proximity... i took the notebook to the other side of the house... rebooted it... nothing changed..

as for the protocols; how can i assure they are the same?
 


#33
I've not read the entire thread, so sorry if any of this is redundant...

Check Firmware
Power cycle modem & router, don't repower the router til 30 sec s after the modem locks
Check Update Driver for Wireless card
Router Channel is likely on Auto; try other channels. If it is due to interference, you may need to set to a channel that is not being affected & sometimes Auto doesn't find the best channel
Also, there should be a 1-800 # for your router's Support Help Desk... might be worth a shot.

Cheers,
Drew
 


#34
I've not read the entire thread, so sorry if any of this is redundant...

Check Firmware
Power cycle modem & router, don't repower the router til 30 sec s after the modem locks
Check Update Driver for Wireless card
Router Channel is likely on Auto; try other channels. If it is due to interference, you may need to set to a channel that is not being affected & sometimes Auto doesn't find the best channel
Also, there should be a 1-800 # for your router's Support Help Desk... might be worth a shot.

Cheers,
Drew

no problem about redundance... but tried all this already.. except for the 1-800# service...
 


Last edited:
#35
Well, then, give it a call... certainly can't hurt to try that, now...

Drew
 


#36
Well, then, give it a call... certainly can't hurt to try that, now...

Drew
you are right... well i called.. they told me to do the same thing you guys already told me to do... and also... it's not just my network i'm not connecting to... i'm not connecting wirelessly to ANY network...
 


#37
In that case...

Try another wireless card. You can hard-wire ok? Is the anntena ok? So the problem is in the PC not, the router? Swap out the wireless card... eliminate any hardware possibilities.

Drew
 


#38
In that case...

Try another wireless card. You can hard-wire ok? Is the anntena ok? So the problem is in the PC not, the router? Swap out the wireless card... eliminate any hardware possibilities.

Drew
i'll try that.. i will comment the results in the end of the weekend..
PS: yes, i can connect hard-wire and another notebook using ubuntu 11.04 is connecting to the internet wirelessly
 


#39
All of which seems to end up pointing to wireless hardware in the PC, I would suggest. We'll wait for an update from you...

Drew
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.