Canon TS5000 series printer installed but not installed-Please help!

ha33y

New Member
I just purchased the ts5051 (not sure of the US alternative)
I am using PC win 7 x64
All installation went smoothly, drivers, software, all good. The printer is now on my system via USB. Appears as the default printer in printers and devices..great!
I try to print....NO PRINTER IS INSTALLED ON YOUR SYSTEM...hmmm
I go to printers and devices, click on the printer and then on printer properties and....NO PRINTER IS INSTALLED...
I reinstall the drivers (updated from Canon). Same thing!!!
Something on my pc is blocking it. The scanner works but not the printer.
I have disabled windows firewall and malwarebytes......still the same.
I know the printer works as I installed it on my laptop and it's fine.
Canon tech support say it's a windows problem and can't fix this. It's definitely a Windows thing and I need to track it down.

Also it won't let me 'ADD PRINTER' from the 'printer and devices' section, just gives me errors and says "Unable to install printer operation could not be completed error 0x000003eb"

UPDATE:
Today I started getting the BSOD as soon as I plugged in the new printer. I even tried to 'upgrade-repair' my windows 7 from DVD only to get half way and it said, 'unable to continue' and put me back to where I was. I have scanned for viruses, malware etc but it comes up clean.
Managed to get past the BSOF death and got windows to install its own driver for the printer, so once again it is installed and set to default printer.
I just noticed that the printspooler folder is totally empty! no printer is installed.?
How can this be? The comp sees the printer and is installed and yet the printspooler has no printer?
Pulling my hair out, please anyone with some knowledge here would be greatly appreciated, I really don't want to reformat and start again...HELP!!

I attach some pics, hopefully may help?
 

Attachments

ha33y

New Member
Hi and thanks.
I tried all 3 methods to no avail. I have tried the initial install disk, updated drivers from Canon's website and it is the same.
It seems half of windows sees the printer but the other half doesn't...I am going crazy here.
When going to the printers and devices page and click on the printer's properties I get the same results (see pic 'pixma28.jpg' above) the printer will not install into the print spooler directory, there is nothing there (see pic 'pixma31.jpg') although the printer shows up everywhere else....
What on Earth could be causing windows to install everywhere except where it matters?
I must resolve this soon, please help.


UPDATE:
Just went over to my Laptop which also has win7 and checked the install of this printer. It works fine. Having checked the Spooler folder on that, it too is empty! how strange. So apparently it doesn't matter whether or not it is inside the print spooler folder, it should still work....hmmmm
Just a thought....I don't have Chrome installed on my Laptop, only Explorer, do you think maybe this printer has a problem with Chrome? can't see how or why, but, I ask because, when opening a page after install which takes me to a Canon website, all my plugins in Chrome crash. Dunno if this has a bearing or not, but just thought I would mention it.
This get stranger by the minute, I do hope some bright techie will be able to help me find the problem and eradicate it, I'm really losing hope....:(
 
Last edited:

livix07

Well-Known Member
Have you already tried to boot into Safe Mode, launch command prompt as admin and run sfc /scannow command?

When you checked for viruses with Malwarebytes did you do it in Safe Mode?

It seems to me that this is a file system corruption.
 
Top